summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxeyqe2015-09-12 18:06:00 +0200
committerxeyqe2015-09-12 18:06:00 +0200
commit1d34539c200ba00122e659f00268cdff9c36461f (patch)
tree371c122e4048718f82583113dc70bab3d87a1f87
downloadaur-1d34539c200ba00122e659f00268cdff9c36461f.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7eeaf28386e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = blackarch-menus-extended
+ pkgdesc = BlackArch specific XDG-compliant menu with more desktop files.
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://drive.google.com/file/d/0B_PopwyKmOH9MDM3M2xFbVdmRmc/view
+ arch = any
+ groups = blackarch
+ license = GPL
+ depends = xdg-utils
+ conflicts = blackarch-menus
+ source = https://drive.google.com/uc?export=download&id=0B_PopwyKmOH9MDM3M2xFbVdmRmc
+ md5sums = b941bb4e4b9eda858f6ae699162245fe
+
+pkgname = blackarch-menus-extended
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56a3c6d5c053
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: xeyqe <xeyqe@seznam.cz>
+
+pkgname='blackarch-menus-extended'
+pkgver='0.2'
+pkgrel=1
+groups=('blackarch')
+pkgdesc="BlackArch specific XDG-compliant menu with more desktop files."
+arch=('any')
+url="https://drive.google.com/file/d/0B_PopwyKmOH9MDM3M2xFbVdmRmc/view"
+license=('GPL')
+depends=('xdg-utils')
+conflicts=('blackarch-menus')
+source=('https://drive.google.com/uc?export=download&id=0B_PopwyKmOH9MDM3M2xFbVdmRmc')
+md5sums=('b941bb4e4b9eda858f6ae699162245fe')
+
+prepare() {
+ wget "https://raw.githubusercontent.com/BlackArch/blackarch-iso/master/tools/menu-maker/help-flags.txt"
+ bash blackarch-directory.sh
+ bash X-BlackArch.sh
+ bash blackarch_desktop_files.sh
+}
+
+package() {
+ install -m755 -d "${pkgdir}/etc/xdg/menus/applications-merged"
+ install -m755 -d "${pkgdir}/usr/share/applications"
+ install -m755 -d "${pkgdir}/usr/share/desktop-directories"
+
+ install -m644 X-BlackArch.menu "${pkgdir}/etc/xdg/menus/applications-merged/"
+ install -m644 *.directory "${pkgdir}/usr/share/desktop-directories/"
+ install -m644 *.desktop "${pkgdir}/usr/share/applications/"
+} \ No newline at end of file