summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxeyqe2019-08-22 11:29:05 +0200
committerxeyqe2019-08-22 11:29:05 +0200
commit39dffc63b52586091608a35da900c0f632d5ba12 (patch)
tree18ae68d0b80c14caa7cfbea4a147f227c9a3cf9d
parentcdf2c89e4d0f87f157392b97e037c08384013f23 (diff)
downloadaur-39dffc63b52586091608a35da900c0f632d5ba12.tar.gz
useful commit message
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD27
2 files changed, 15 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01754b6745fa..f69ca79f6fd1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = blackarch-menus-extended
pkgdesc = BlackArch specific XDG-compliant menu with more desktop files.
pkgver = 0.2
pkgrel = 2
- url = https://github.com/BlackArch/blackarch/tree/master/packages/blackarch-menus
+ url = https://github.com/xeyqe/blackarch-menus-extended
arch = any
license = GPL
depends = xdg-utils
@@ -11,8 +11,8 @@ pkgbase = blackarch-menus-extended
provides = blackarch-menus
conflicts = blackarch-menus
replaces = blackarch-menus
- source = https://drive.google.com/uc?export=download&id=0B_PopwyKmOH9WUUxRG1uQ0NVZVE
- md5sums = 84cdec2016c5b0f1958623295d9fa736
+ source = git+https://github.com/xeyqe/blackarch-menus-extended.git
+ md5sums = SKIP
pkgname = blackarch-menus-extended
diff --git a/PKGBUILD b/PKGBUILD
index 756f71ee430c..f6bf76788ac0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,33 @@
-# Maintainer: xeyqe <xeyqe@seznam.cz>
-
pkgname='blackarch-menus-extended'
pkgver='0.2'
pkgrel=2
pkgdesc="BlackArch specific XDG-compliant menu with more desktop files."
arch=('any')
-url="https://github.com/BlackArch/blackarch/tree/master/packages/blackarch-menus"
+url="https://github.com/xeyqe/blackarch-menus-extended"
license=('GPL')
depends=('xdg-utils' 'fakeroot' 'gksu')
provides=('blackarch-menus')
conflicts=('blackarch-menus')
replaces=('blackarch-menus')
-source=('https://drive.google.com/uc?export=download&id=0B_PopwyKmOH9WUUxRG1uQ0NVZVE')
-md5sums=('84cdec2016c5b0f1958623295d9fa736')
+source=("git+https://github.com/xeyqe/blackarch-menus-extended.git")
+md5sums=('SKIP')
prepare() {
- cd desktop_files
- wget "https://raw.githubusercontent.com/BlackArch/blackarch-iso/master/tools/menu-maker/help-flags.txt"
-
- bash blackarch-directory.sh
- bash X-BlackArch.sh
- #bash blackarch_desktop_files.sh
+ cd "${srcdir}"
}
package() {
install -m755 -d "${pkgdir}/etc/xdg/menus/applications-merged"
- install -m755 -d "${pkgdir}/usr/local/bin"
install -m755 -d "${pkgdir}/usr/share/applications"
install -m755 -d "${pkgdir}/usr/share/desktop-directories"
+ install -m755 -d "${pkgdir}/usr/local/bin"
+ install -dm 755 "$pkgdir/usr/share/icons/hicolor/32x32/apps"
+
+
- install -m644 desktop_files/X-BlackArch.menu "${pkgdir}/etc/xdg/menus/applications-merged/"
- install -m755 desktop_files/appHelper.sh "${pkgdir}/usr/local/bin"
+ install -m644 directories/X-BlackArch.menu "${pkgdir}/etc/xdg/menus/applications-merged/"
+ install -m644 directories/*.directory "${pkgdir}/usr/share/desktop-directories/"
install -m644 desktop_files/*.desktop "${pkgdir}/usr/share/applications/"
- install -m644 desktop_files/*.directory "${pkgdir}/usr/share/desktop-directories/"
+ install -m755 blackarch-menu-scripts/appHelper.sh "${pkgdir}/usr/local/bin"
+ install -m 644 directories/*.png "$pkgdir/usr/share/icons/hicolor/32x32/apps/"
} \ No newline at end of file