summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 05:08:54 -0600
committerBrian Bidulock2015-06-10 05:08:54 -0600
commit93542405c193d63bea2539273eb740495cb25fc0 (patch)
tree019e161cd49e75ba40cfb544ac9152c411b5f268
downloadaur-93542405c193d63bea2539273eb740495cb25fc0.tar.gz
initial version
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD58
-rw-r--r--bbdock.patch16
-rw-r--r--bsetbg-feh.patch23
-rw-r--r--ewmh.patch26
-rw-r--r--textpropertytostring-unconditional.patch28
6 files changed, 178 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5da9027be971
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = blackbox-cvs
+ pkgdesc = Blackbox CVS
+ pkgver = 0.70.2
+ pkgrel = 1
+ url = http://blackboxwm.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = cvs
+ depends = gcc-libs
+ depends = libxext
+ depends = bash
+ depends = libxft
+ provides = blackbox
+ conflicts = blackbox
+ options = !libtool
+ source = bbdock.patch
+ source = bsetbg-feh.patch
+ source = textpropertytostring-unconditional.patch
+ source = ewmh.patch
+ md5sums = 69c5a5e981b087b2d8267cab996b48dd
+ md5sums = e7fb0d5bfd95820c0194ec73df66dadc
+ md5sums = 3b92ad246f07126dd55ae9634d6e875e
+ md5sums = ecb8940c7e4a27cad6ba82d51e183461
+
+pkgname = blackbox-cvs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..657def6319d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Nathan Owe. <ndowens04+AUR@gmail.com>
+pkgname=blackbox-cvs
+pkgver=0.70.2
+pkgrel=1
+pkgdesc="Blackbox CVS"
+arch=(i686 x86_64)
+url="http://blackboxwm.sourceforge.net"
+license=('custom')
+provides=('blackbox')
+conflicts=('blackbox')
+depends=('gcc-libs' 'libxext' 'bash' 'libxft')
+options=('!libtool')
+makedepends=('cvs')
+source=(bbdock.patch
+ bsetbg-feh.patch
+ textpropertytostring-unconditional.patch
+ ewmh.patch)
+md5sums=('69c5a5e981b087b2d8267cab996b48dd'
+ 'e7fb0d5bfd95820c0194ec73df66dadc'
+ '3b92ad246f07126dd55ae9634d6e875e'
+ 'ecb8940c7e4a27cad6ba82d51e183461')
+
+_cvsroot=":pserver:anonymous@blackboxwm.cvs.sourceforge.net:/cvsroot/blackboxwm"
+_cvsmod="blackbox"
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to $_cvsmod.sourceforge.net CVS server...."
+ if [ -d $_cvsmod/CVS ]; then
+ cd $_cvsmod
+ cvs -z3 update -d
+ else
+ cvs -z3 -d $_cvsroot co -f $_cvsmod
+ cd $_cvsmod
+ fi
+
+ msg "CVS checkout done or server timeout"
+ msg "Starting make..."
+
+ rm -rf "$srcdir/$_cvsmod-build"
+ cp -r "$srcdir/$_cvsmod" "$srcdir/$_cvsmod-build"
+ cd "$srcdir/$_cvsmod-build"
+
+ patch -Np0 -i ../bbdock.patch
+ patch -Np0 -i ../bsetbg-feh.patch
+ patch -Np1 -i ../textpropertytostring-unconditional.patch
+ patch -Np0 -i ../ewmh.patch
+
+ autoreconf -fi
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make || return 1
+}
+package() {
+ cd "$srcdir/$_cvsmod-build"
+ make DESTDIR="$pkgdir/" install || return 1
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/bbdock.patch b/bbdock.patch
new file mode 100644
index 000000000000..709b6cfe11a2
--- /dev/null
+++ b/bbdock.patch
@@ -0,0 +1,16 @@
+--- src/Slit.cc 2005-01-04 05:58:33.000000000 -0700
++++ /root/tmp/Slit.cc 2007-12-29 11:13:09.000000000 -0700
+@@ -248,6 +248,13 @@
+ bt::PixmapCache::find(screen->screenNumber(), texture,
+ frame.rect.width(), frame.rect.height(),
+ frame.pixmap);
++/*** START: BBDOCK PATCH FOR DOCK APPS THAT USE ParentRelative **************/
++ if ((texture.texture() & bt::Texture::Gradient) && frame.pixmap)
++ XSetWindowBackgroundPixmap(display, frame.window, frame.pixmap);
++ else if ((texture.texture() & bt::Texture::Solid))
++ XSetWindowBackground(display, frame.window,
++ texture.color1().pixel(screen->screenNumber()));
++/*** STOP: BBDOCK PATCH FOR DOCK APPS THAT USE ParentRelative ***************/
+ XClearArea(display, frame.window, 0, 0,
+ frame.rect.width(), frame.rect.height(), True);
+
diff --git a/bsetbg-feh.patch b/bsetbg-feh.patch
new file mode 100644
index 000000000000..17a612ff04e4
--- /dev/null
+++ b/bsetbg-feh.patch
@@ -0,0 +1,23 @@
+--- util/bsetbg.orig 2008-03-26 21:17:04.000000000 -0700
++++ util/bsetbg 2008-03-26 21:21:57.000000000 -0700
+@@ -22,7 +22,7 @@
+
+ PATH=$PATH:/usr/bin:/usr/local/bin:/usr/X11R6/bin
+
+-img_apps="display xli xsetbg Esetroot qiv wmsetbg xv"
++img_apps="display xli xsetbg Esetroot qiv wmsetbg xv feh"
+
+ display_full_cmd="display -geometry 800x600 -window root"
+ display_tile_cmd="display -window root"
+@@ -59,6 +59,11 @@
+ xsetbg_center_cmd="xsetbg -center"
+ xsetbg_default_cmd="$xsetbg_center_cmd"
+
++feh_full_cmd="feh --bg-scale"
++feh_tile_cmd="feh --bg-tile"
++feh_center_cmd="feh --bg-center"
++feh_default_cmd="$feh_center_cmd"
++
+ ##################################
+
+ me=`basename $0`
diff --git a/ewmh.patch b/ewmh.patch
new file mode 100644
index 000000000000..8166571da90a
--- /dev/null
+++ b/ewmh.patch
@@ -0,0 +1,26 @@
+Description: fix runaway workspace creation
+Author: Brian Bidulock <bidulock@openss7.org>
+Forwarded: no
+Last-Update: 2013-06-09
+
+diff -up src/Screen.cc.orig src/Screen.cc
+--- src/Screen.cc.orig 2008-04-22 23:48:07.000000000 -0600
++++ src/Screen.cc 2013-06-09 18:20:20.000000000 -0600
+@@ -1873,11 +1873,15 @@ void BScreen::clientMessageEvent(const X
+ if (event->message_type == _blackbox->ewmh().numberOfDesktops()) {
+ unsigned int number = event->data.l[0];
+ if (number > workspaceCount()) {
+- for (; number != workspaceCount(); --number)
++ do {
+ addWorkspace();
++ }
++ while (number > workspaceCount());
+ } else if (number < workspaceCount()) {
+- for (; number != workspaceCount(); ++number)
++ do {
+ removeLastWorkspace();
++ }
++ while (number < workspaceCount());
+ }
+ } else if (event->message_type == _blackbox->ewmh().desktopNames()) {
+ readDesktopNames();
diff --git a/textpropertytostring-unconditional.patch b/textpropertytostring-unconditional.patch
new file mode 100644
index 000000000000..ed320388a1c3
--- /dev/null
+++ b/textpropertytostring-unconditional.patch
@@ -0,0 +1,28 @@
+Description: Declare bt::textPropertyToString unconditionally.
+Author: Jakub Wilk <jwilk@debian.org>
+Forwarded: no
+Bug-Debian: http://bugs.debian.org/614468
+Last-Update: 2011-03-12
+
+--- a/lib/Util.hh
++++ b/lib/Util.hh
+@@ -25,6 +25,8 @@
+ #ifndef __Util_hh
+ #define __Util_hh
+
++#include <X11/Xutil.h>
++
+ #include <limits.h>
+ #include <string>
+
+@@ -94,10 +96,8 @@
+
+ std::string tolower(const std::string &string);
+
+-#ifdef _XUTIL_H_
+ std::string textPropertyToString(::Display *display,
+ ::XTextProperty& text_prop);
+-#endif
+
+ } // namespace bt
+