summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake2018-03-10 23:36:03 +0100
committerJake2018-03-10 23:36:03 +0100
commite7e0473540015e7de8daae5d70861ad98c5b2c96 (patch)
tree826ba83e682e8270ea1cfed5a1772a30d299e02f
downloadaur-e7e0473540015e7de8daae5d70861ad98c5b2c96.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93f014f3ac58
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = blackbox-explorer
+ pkgdesc = Cleanflight and Betaflight Blackbox Explorer (NW.js build)
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = https://github.com/cleanflight/blackbox-log-viewer-master
+ arch = x86_64
+ license = GPL3
+ makedepends = yarn
+ options = !strip
+ source = https://github.com/cleanflight/blackbox-log-viewer/archive/master.zip
+ md5sums = SKIP
+
+pkgname = blackbox-explorer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d08b4877a36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jake <aur@ja-ke.tech>
+pkgname=blackbox-explorer
+_reponame=blackbox-log-viewer-master
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="Cleanflight and Betaflight Blackbox Explorer (NW.js build)"
+arch=("x86_64")
+url="https://github.com/cleanflight/$_reponame"
+license=('GPL3')
+makedepends=('yarn')
+source=("https://github.com/cleanflight/blackbox-log-viewer/archive/master.zip")
+md5sums=(SKIP)
+options=(!strip)
+
+build() {
+ cd "$_reponame"
+ yarn install
+ ./node_modules/.bin/gulp apps
+}
+
+package() {
+ cd "$_reponame"
+ install -D apps/cleanflight-$pkgname/linux64/cleanflight-$pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -d "$pkgdir/opt/cleanflight/cleanflight-blackbox-explorer/"
+ cp -r apps/cleanflight-$pkgname/linux64/* "$pkgdir/opt/cleanflight/cleanflight-blackbox-explorer"
+ install -d "$pkgdir/usr/bin/"
+ ln -s /opt/cleanflight/cleanflight-blackbox-explorer/cleanflight-$pkgname "$pkgdir/usr/bin/$pkgname"
+}