summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Bornschein2020-11-14 14:32:42 +0100
committerFabian Bornschein2020-11-14 14:32:42 +0100
commit8d304277ffc07a231cb246704191d093b08e09eb (patch)
tree970f0bfdd786aa728d693a2c0f1039a1bbde065a
downloadaur-8d304277ffc07a231cb246704191d093b08e09eb.tar.gz
The true success lies in earning satisfaction in life instead of money.
-rw-r--r--.SRCINFO14
-rw-r--r--98-blacklist-hw-watchdog.hook10
-rw-r--r--PKGBUILD25
-rw-r--r--archlinux.install25
-rw-r--r--blacklist-hw-watchdog.conf5
5 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12000aad0ef4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = blacklist-hw-watchdog
+ pkgdesc = blacklist following kernel module: iTCO_wdt, sp5100-tco
+ pkgver = 1
+ pkgrel = 1
+ install = archlinux.install
+ arch = any
+ license = GPL3
+ source = 98-blacklist-hw-watchdog.hook
+ source = blacklist-hw-watchdog.conf
+ sha512sums = 3e77984545ce4568a984e76fc5770af623eeac99655b0ee5bd4b1e33f8f5d95af8d12256e0482cf167cfb4e0710b7c3e170c6eb45a8641a8802c215fcd454bac
+ sha512sums = 9ccabc32e6ab45c32400df3b5ad359dc91c44e50270b7b80fb486ed2c52b92a51624b9795fc97255994d09b2e8f1783abfc4b7613395805632c3a01d3d9a77f6
+
+pkgname = blacklist-hw-watchdog
+
diff --git a/98-blacklist-hw-watchdog.hook b/98-blacklist-hw-watchdog.hook
new file mode 100644
index 000000000000..96c0c5dfbe1f
--- /dev/null
+++ b/98-blacklist-hw-watchdog.hook
@@ -0,0 +1,10 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Target = usr/lib/modprobe.d/blacklist-hw-watchdog.conf
+
+[Action]
+Description = Rebuild Initram to apply of hardware watchdoge
+When = PostTransaction
+Exec = /usr/bin/mkinitcpio -P
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa01505ac75d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Fabian Bornschein <plusfabi-cat-gmail-dog-com>
+
+pkgname=blacklist-hw-watchdog
+pkgdesc="blacklist following kernel module: iTCO_wdt, sp5100-tco"
+install="archlinux.install"
+pkgver=1
+pkgrel=1
+url="https://aur.archlinux.org/packages/blacklist-hw-watchdog"
+arch=('any')
+license=('GPL3')
+source=('98-blacklist-hw-watchdog.hook'
+ 'blacklist-hw-watchdog.conf')
+sha512sums=('3e77984545ce4568a984e76fc5770af623eeac99655b0ee5bd4b1e33f8f5d95af8d12256e0482cf167cfb4e0710b7c3e170c6eb45a8641a8802c215fcd454bac'
+ '9ccabc32e6ab45c32400df3b5ad359dc91c44e50270b7b80fb486ed2c52b92a51624b9795fc97255994d09b2e8f1783abfc4b7613395805632c3a01d3d9a77f6')
+
+package()
+{
+ cd "${srcdir}"
+
+ install -D -m644 "${srcdir}/blacklist-hw-watchdog.conf" \
+ "${pkgdir}/usr/lib/modprobe.d/blacklist-hw-watchdog.conf"
+
+ install -D -m644 "${srcdir}/98-blacklist-hw-watchdog.hook" \
+ "${pkgdir}/usr/share/libalpm/hooks/98-blacklist-hw-watchdog.hook"
+}
diff --git a/archlinux.install b/archlinux.install
new file mode 100644
index 000000000000..5501baa22c91
--- /dev/null
+++ b/archlinux.install
@@ -0,0 +1,25 @@
+post_install()
+{
+ if [[ $(/usr/bin/tail -n 1 /usr/lib/os-release | /usr/bin/cut -d= -f2) != "archlinux" ]];
+ then
+ printf "==>\tUNSUPPORTED DISTRO DETECTED.\n";
+ printf "==>\tTHIS PACKAGE ONLY SUPPORTS Arch Linux.\n";
+ printf "==>\tPLEASE DO NOT ASK FOR SUPPORT ON THE AUR, YOU ARE ON YOUR OWN.\n\n";
+ fi
+ printf "\nWatchdog will be blacklisted with the next boot of your system\n"
+ printf "Thanks for using my pkg :)\n\n"
+}
+
+pre_remove()
+{
+post_upgrade() {
+ if [[ $(/usr/bin/tail -n 1 /usr/lib/os-release | /usr/bin/cut -d= -f2) != "archlinux" ]];
+ then
+ printf "==>\tUNSUPPORTED DISTRO DETECTED.\n";
+ printf "==>\tTHIS PACKAGE ONLY SUPPORTS Arch Linux.\n";
+ printf "==>\tPLEASE DO NOT ASK FOR SUPPORT ON THE AUR, YOU ARE ON YOUR OWN.\n\n";
+ fi
+
+ printf "\nThanks for still using my pkg :)\n\n"
+ }
+}
diff --git a/blacklist-hw-watchdog.conf b/blacklist-hw-watchdog.conf
new file mode 100644
index 000000000000..ba55ab2ae46c
--- /dev/null
+++ b/blacklist-hw-watchdog.conf
@@ -0,0 +1,5 @@
+# This file is Part of the blacklist-hw-watchdog package
+# DO NOT EDIT OR REMOVE
+blacklist iTCO_wdt
+blacklist sp5100-tco
+