summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2016-02-03 01:25:49 +0100
committerPiotr Rogoża2016-02-03 01:25:49 +0100
commit10127d3ddf81d0ff0bb02167a82975e733503d7a (patch)
treed40f52dfb323cf054d5c45fd9250cb19b2c3bc9d
downloadaur-10127d3ddf81d0ff0bb02167a82975e733503d7a.tar.gz
Initial PKGBUILD: 1.0.0-RC2
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD51
-rw-r--r--blacksilk.desktop10
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29b0044fb106
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Wed Feb 3 00:23:41 UTC 2016
+pkgbase = blacksilk
+ pkgdesc = an intuitive black and white conversion software with focus on a responsive user interface and workflow
+ pkgver = 1.0.0_RC2
+ pkgrel = 1
+ url = http://fd-imaging.com/apps-2/blacksilk-bw-toolkit/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = chrpath
+ depends = qt5-quick1
+ depends = libpng12
+ depends = postgresql-libs
+ depends = qt5-svg
+ depends = lcms2
+ depends = qt5-multimedia
+ source = https://fd-imaging.com/files/blacksilk/releases/BlackSilk.Standalone.1.0.0-RC2.linux.zip
+ source = https://fd-imaging.com/wp-content/uploads/2012/03/Black_Silk_Logo_Big.png
+ source = blacksilk.desktop
+ sha256sums = 378dc74906e27185e45f9981b5cd0eb271ec2bc29de4ef0a2cc816e6da206927
+ sha256sums = 2b2b7d572b0e7d52ded83180aa2f3d8a31af472685fbf436b0b9b448279c07f8
+ sha256sums = 4e3e81eb78fcfdc643708e6a38600d5045ff4302b3515af3cd16193914d0fe05
+
+pkgname = blacksilk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0774dfd256f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: dracorp aka Piotr Rogoza <piotr.r.public@gmail.com>
+
+pkgname=blacksilk
+_pkgname=BlackSilk.Standalone
+pkgver=1.0.0_RC2
+_pkgver=1.0.0-RC2
+pkgrel=1
+pkgdesc='an intuitive black and white conversion software with focus on a responsive user interface and workflow'
+arch=('i686' 'x86_64')
+url='http://fd-imaging.com/apps-2/blacksilk-bw-toolkit/'
+license=('GPL')
+groups=()
+depends=(
+qt5-quick1
+libpng12
+postgresql-libs
+qt5-svg
+lcms2
+# gcc-libs
+qt5-multimedia
+)
+makedepends=(
+chrpath
+)
+install=''
+source=(
+https://fd-imaging.com/files/blacksilk/releases/BlackSilk.Standalone.${_pkgver}.linux.zip
+https://fd-imaging.com/wp-content/uploads/2012/03/Black_Silk_Logo_Big.png
+blacksilk.desktop
+)
+sha256sums=('378dc74906e27185e45f9981b5cd0eb271ec2bc29de4ef0a2cc816e6da206927'
+ '2b2b7d572b0e7d52ded83180aa2f3d8a31af472685fbf436b0b9b448279c07f8'
+ '4e3e81eb78fcfdc643708e6a38600d5045ff4302b3515af3cd16193914d0fe05')
+
+build() {
+ cd "$srcdir"/${_pkgname}.${_pkgver}.linux
+ find -type f -a -name '*.so*' -exec chrpath -d '{}' ';'
+ convert ../Black_Silk_Logo_Big.png -resize 128 ../blacksilk.png
+}
+package(){
+ cd "$srcdir"/${_pkgname}.${_pkgver}.linux
+ install -dm755 "$pkgdir"/opt/blacksilk
+ install -dm755 "$pkgdir"/usr/bin
+ cp -r ./ "$pkgdir"/opt/blacksilk
+ install -Dm644 ../blacksilk.desktop "$pkgdir"/usr/share/applications/blacksilk.desktop
+ install -Dm644 ../blacksilk.png "$pkgdir"/usr/share/icons/blacksilk.png
+ cd "$pkgdir"/usr/bin
+ ln -s /opt/blacksilk/BlackSilk blacksilk
+
+}
+
diff --git a/blacksilk.desktop b/blacksilk.desktop
new file mode 100644
index 000000000000..58d959094713
--- /dev/null
+++ b/blacksilk.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=Blacksilk
+Comment=An intuitive black and white conversion software with focus on a responsive user interface and workflow
+Exec=blacksilk
+Icon=blacksilk
+Terminal=false
+StartupNotify=false
+Categories=Application;Graphics