summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2015-08-27 23:01:03 +0200
committerMartchus2015-08-27 23:01:03 +0200
commit9381d6f3aadce1a58dab06392f309eb49e1fcf59 (patch)
tree3c64021ed8be4b7bbcdfe56c46a0a8e19fce930d
downloadaur-9381d6f3aadce1a58dab06392f309eb49e1fcf59.tar.gz
initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..658970a1aef4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = blackwidowcontrol
+ pkgdesc = Python script to enable macro keys of BlackWidow keyboard under GNU/Linux
+ pkgver = 1.0.0
+ pkgrel = 3
+ arch = any
+ license = GPL
+ depends = python
+ depends = python-pyusb
+ source = blackwidowcontrol-1.0.0.tar.gz::https://github.com/Martchus/blackwidowcontrol/archive/v1.0.0.tar.gz
+ sha256sums = SKIP
+
+pkgname = blackwidowcontrol
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b4d642a4df9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Martchus <martchus@gmx.net>
+pkgname=blackwidowcontrol
+pkgver=1.0.0
+pkgrel=3
+pkgdesc="Python script to enable macro keys of BlackWidow keyboard under GNU/Linux"
+arch=('any')
+license=('GPL')
+groups=
+provides=
+depends=("python" "python-pyusb")
+makedepends=
+conflicts=
+replaces=
+backup=
+install=
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${pkgname}/archive/v${pkgver}.tar.gz")
+noextract=
+sha256sums=('b840f36debfdf7ce745105b2d187d643ac7588589aa7caf2a475af7da72ef362')
+
+package() {
+ _srcdir="${srcdir}/${PROJECT_DIR_NAME:-$pkgname-$pkgver}"
+ install -Dm755 "${_srcdir}/blackwidowcontrol.py" "${pkgdir}/usr/bin/blackwidowcontrol"
+ install -Dm644 "${_srcdir}/razer_blackwidow.rules" "${pkgdir}/etc/udev/rules.d/70-razer_blackwidow.rules"
+}