summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2017-01-21 19:13:56 +0100
committerBalló György2017-01-21 19:13:56 +0100
commit5caadc98e30c500e3db61eeb263cf3fd68d461e7 (patch)
tree27df82d66ff291b7038785f560119442248b2fe3
downloadaur-5caadc98e30c500e3db61eeb263cf3fd68d461e7.tar.gz
Move blam from [community]
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3cc4fb6909a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = blam
+ pkgdesc = Simple newsreader for GNOME written in C Sharp
+ pkgver = 1.8.12
+ pkgrel = 4
+ url = https://git.gnome.org/browse/blam
+ arch = any
+ license = GPL
+ makedepends = intltool
+ depends = webkit-sharp
+ depends = gconf-sharp
+ depends = notify-sharp
+ source = https://download.gnome.org/sources/blam/1.8/blam-1.8.12.tar.xz
+ sha256sums = 6294d13629cd0cabc50ed3a489682b50c2c61972d55d8209b59b2a8b434810ea
+
+pkgname = blam
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ecacfd97901c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 176208 2016-05-24 11:46:59Z bgyorgy $
+# Maintainer: Balló György <ballogyor+arch at gmail dot com>
+
+pkgname=blam
+pkgver=1.8.12
+pkgrel=4
+pkgdesc="Simple newsreader for GNOME written in C Sharp"
+arch=('any')
+url="https://git.gnome.org/browse/blam"
+license=('GPL')
+depends=('webkit-sharp' 'gconf-sharp' 'notify-sharp')
+makedepends=('intltool')
+source=(https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz)
+sha256sums=('6294d13629cd0cabc50ed3a489682b50c2c61972d55d8209b59b2a8b434810ea')
+
+prepare() {
+ cd $pkgname-$pkgver
+ sed -i -e 's/dbus-sharp-glib-1.0/dbus-sharp-glib-2.0/g' configure.ac
+ autoreconf -fi
+}
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --disable-schemas-install \
+ --with-gconf-schema-file-dir=/usr/share/gconf/schemas
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}