summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Krause2015-07-17 10:18:37 +0200
committerChristian Krause2015-07-17 10:18:37 +0200
commitdb42972ca5f8f0754ad12e3cdc822237897c4542 (patch)
tree1fd4029b8ec23d243cfc123c139201a901834301
parent683f583423c6efec76f0fed31cf33306e4aefe1b (diff)
downloadaur-db42972ca5f8f0754ad12e3cdc822237897c4542.tar.gz
blasr-git-r98.caaf74a-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD46
2 files changed, 38 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9bb5cd6f278..c433c57280f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,16 @@
pkgbase = blasr-git
pkgdesc = The PacBio long read aligner
- pkgver = r70.463a369
+ pkgver = r98.caaf74a
pkgrel = 1
url = https://github.com/PacificBiosciences/blasr
arch = i686
arch = x86_64
license = custom
+ makedepends = python2
depends = hdf5-cpp-fortran
+ depends = htslib
+ provides = blasr
+ conflicts = blasr
source = blasr-git::git+https://github.com/PacificBiosciences/blasr
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 70c79574ad1d..bdf3d66eebc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,16 @@
# Maintainer: Christian Krause ("wookietreiber") <kizkizzbangbang@googlemail.com>
pkgname=blasr-git
-pkgver=r70.463a369
+pkgver=r98.caaf74a
pkgrel=1
pkgdesc="The PacBio long read aligner"
arch=('i686' 'x86_64')
url="https://github.com/PacificBiosciences/blasr"
license=('custom')
-depends=('hdf5-cpp-fortran')
+depends=('hdf5-cpp-fortran' 'htslib')
+makedepends=('python2')
+conflicts=('blasr')
+provides=('blasr')
source=("$pkgname::git+https://github.com/PacificBiosciences/blasr")
@@ -22,18 +25,11 @@ pkgver() {
prepare() {
cd $srcdir/$pkgname
- # with the git@github.com: url you would need to have both a github account and have set it up for ssh
- # so we use https instead
- sed -e 's|git@github.com:|https://github.com/|' \
- -i .gitmodules
-
git submodule init
git submodule update
- # otherwise there would be this error:
- # Makefile:42: *** recipe commences before first target. Stop.
- sed -e 's| INCLUDES +=|\tINCLUDES +=|' \
- -i libcpp/pbdata/Makefile
+ sed -e 's|^#!/usr/bin/env python$|#!/usr/bin/env python2|' \
+ -i libcpp/configure.py
# we want to link against shared libs
sed -e 's|LDFLAGS := $(LDFLAGS1) $(HDF5_LIB)/libhdf5_cpp.a $(HDF5_LIB)/libhdf5.a -lpthread -lz -ldl|LDFLAGS += $(LDFLAGS1) -lhdf5_cpp -lhdf5 -lpthread -lz -ldl|' \
@@ -41,6 +37,26 @@ prepare() {
-i common.mk \
libcpp/unittest/common.mk
+ # use system provided htslib
+ sed -e 's|HTSLIB_INCLUDE := $(PBBAM)/../htslib/htslib|HTSLIB_INCLUDE := /usr/include|' \
+ -e 's|HTSLIB_LIB := $(PBBAM)/../htslib|HTSLIB_LIB := /usr/lib|' \
+ -e 's|$(HTSLIB_LIB)/libhts.a|$(HTSLIB_LIB)/libhts.so|' \
+ -i common.mk
+
+ # PBINCROOT fix
+ sed -e '1 i top_srcdir := $(PWD)' \
+ -e '1 i PBINCROOT := $(top_srcdir)/libcpp' \
+ -i Makefile
+
+ # moar PBINCROOT fixes
+ sed -e '1 i PBINCROOT := ../libcpp' \
+ -e 's|pblib: $(PBINCROOT)/Makefile|pblib: $(PBINCROOT)/makefile|' \
+ -i utils/Makefile
+
+ # this is neither included nor needed
+ sed -e 's|-lpbbam||' \
+ -i common.mk
+
# don't link statically
sed -e 's|-static||' \
-i common.mk
@@ -49,7 +65,7 @@ prepare() {
build() {
cd $srcdir/$pkgname
- make HDF5_LIB=/usr/lib HDF5_INC=/usr/include ZLIB_ROOT=/usr
+ make -j1 HDF5_LIB=/usr/lib/libhdf5.so HDF5_INC=/usr/include ZLIB_ROOT=/usr
}
package() {
@@ -59,5 +75,9 @@ package() {
install -Dm755 $file $pkgdir/usr/bin/$(basename $file)
done
- install -Dm644 <(echo unknown) $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ for file in libcpp/pbdata/libpbdata.so libcpp/hdf/libpbihdf.so libcpp/alignment/libblasr.so ; do
+ install -Dm755 $file $pkgdir/usr/lib/$(basename $file)
+ done
+
+ install -Dm644 LICENSES.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
}