summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Krause2015-07-09 11:27:30 +0200
committerChristian Krause2015-07-09 11:27:30 +0200
commit20d7bc837e5ffd69dc292641b4f2c0ac33ab3e8c (patch)
tree31d49fca87e98fa34639387fcb631a5e7895c8bb
downloadaur-20d7bc837e5ffd69dc292641b4f2c0ac33ab3e8c.tar.gz
blast+-2.2.31-1
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD50
-rw-r--r--typeinfo.patch11
3 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..542ccf58dfe7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = blast+
+ pkgdesc = finds regions of similarity between biological sequences
+ pkgver = 2.2.31
+ pkgrel = 1
+ url = http://blast.ncbi.nlm.nih.gov/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = cpio
+ depends = lzo2
+ depends = pcre
+ depends = python
+ provides = blast
+ provides = blast+-bin
+ provides = ncbi-blast
+ provides = ncbi-blast+
+ conflicts = blast
+ conflicts = blast+-bin
+ conflicts = ncbi-blast
+ conflicts = ncbi-blast+
+ conflicts = cddlib
+ conflicts = proj
+ source = ftp://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/2.2.31/ncbi-blast-2.2.31+-src.tar.gz
+ source = typeinfo.patch
+ md5sums = f32bd2d2c66205c53c6981f94e1a0d54
+ md5sums = 9c257a762ce4e7418e95a48723832a86
+
+pkgname = blast+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ebda68b38ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Christian Krause ("wookietreiber") <kizkizzbangbang@googlemail.com>
+
+pkgname=blast+
+pkgver=2.2.31
+pkgrel=1
+pkgdesc="finds regions of similarity between biological sequences"
+arch=('i686' 'x86_64')
+url="http://blast.ncbi.nlm.nih.gov/"
+license=('custom')
+depends=('lzo2' 'pcre' 'python')
+makedepends=('cpio')
+conflicts=('blast' 'blast+-bin' 'ncbi-blast' 'ncbi-blast+' 'cddlib' 'proj')
+provides=('blast' 'blast+-bin' 'ncbi-blast' 'ncbi-blast+')
+source=("ftp://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/$pkgver/ncbi-blast-$pkgver+-src.tar.gz"
+ 'typeinfo.patch')
+md5sums=('f32bd2d2c66205c53c6981f94e1a0d54'
+ '9c257a762ce4e7418e95a48723832a86')
+
+prepare() {
+ cd $srcdir/ncbi-blast-$pkgver+-src/c++
+
+ patch -p1 -i $srcdir/typeinfo.patch
+
+ sed -e '/if test "$with_mt" != "no" ; then/i compiler=GCC' \
+ -i src/build-system/configure
+}
+
+build() {
+ cd $srcdir/ncbi-blast-$pkgver+-src/c++
+
+ ./configure \
+ --prefix=/usr \
+ --with-dll \
+ --with-mt \
+ --without-gnutls
+
+ make
+}
+
+package() {
+ cd $srcdir/ncbi-blast-$pkgver+-src/c++
+
+ make prefix=$pkgdir/usr install
+
+ chmod +x $pkgdir/usr/lib/*.so
+
+ install -d $pkgdir/usr/share/licenses/$pkgname
+
+ echo 'public domain' > $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/typeinfo.patch b/typeinfo.patch
new file mode 100644
index 000000000000..5962080b91a3
--- /dev/null
+++ b/typeinfo.patch
@@ -0,0 +1,11 @@
+diff -aur c++/include/corelib/ncbistl.hpp c++.new/include/corelib/ncbistl.hpp
+--- c++/include/corelib/ncbistl.hpp 2013-09-06 20:29:54.000000000 +0200
++++ c++.new/include/corelib/ncbistl.hpp 2014-06-05 11:04:30.533234506 +0200
+@@ -37,6 +37,7 @@
+
+ #include <common/ncbi_export.h>
+ #include <string>
++#include <typeinfo>
+
+
+ // Get rid of some warnings in MSVC++