summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYishen Miao2023-08-23 23:31:28 -0700
committerYishen Miao2023-08-23 23:37:11 -0700
commita3e5950f7cb4349553b1624f4105a9e0740fc27a (patch)
treed5039ef38497229837de1379e3c8c76b32d4cc53
parentc397c5d4bdbc3264b11696a99f4fa3e026370497 (diff)
downloadaur-a3e5950f7cb4349553b1624f4105a9e0740fc27a.tar.gz
Bumping to 2.14.1
Bumps to 2.14.1. cstdint patch merged by upstream.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
-rw-r--r--cstdint.patch12
3 files changed, 7 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20f57ac3e9db..b9bbebc9aa69 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = blast+
pkgdesc = BLAST tool suite from NCBI (blastn, blastp, blastx, psiblast, etc)
- pkgver = 2.14.0
- pkgrel = 3
+ pkgver = 2.14.1
+ pkgrel = 1
url = http://blast.ncbi.nlm.nih.gov/
arch = i686
arch = x86_64
@@ -28,9 +28,7 @@ pkgbase = blast+
conflicts = ncbi-blast
conflicts = proj
replaces = ncbi-blast
- source = https://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/2.14.0/ncbi-blast-2.14.0+-src.tar.gz
- source = cstdint.patch
- sha256sums = bf477f1b0c3b82f0b7a7094bf003a9a83e37e3b0716c1df799060c4feab17500
- sha256sums = 7cae72ec356224d9a75c4ce1c6c276dcb22b9a36b3d92f9c57b024dff23cc7f2
+ source = https://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/2.14.1/ncbi-blast-2.14.1+-src.tar.gz
+ sha256sums = 712c2dbdf0fb13cc1c2d4f4ef5dd1ce4b06c3b57e96dfea8f23e6e99f5b1650e
pkgname = blast+
diff --git a/PKGBUILD b/PKGBUILD
index 8f4ab7a34937..5b03f7fb227d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# shellcheck disable=SC2034,SC2148,SC2154
pkgname=blast+
-pkgver=2.14.0
-pkgrel=3
+pkgver=2.14.1
+pkgrel=1
pkgdesc="BLAST tool suite from NCBI (blastn, blastp, blastx, psiblast, etc)"
arch=('i686' 'x86_64')
url="http://blast.ncbi.nlm.nih.gov/"
@@ -33,16 +33,13 @@ provides=('blast')
replaces=('ncbi-blast')
source=(
"https://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/$pkgver/ncbi-blast-$pkgver+-src.tar.gz"
- "cstdint.patch"
)
sha256sums=(
- 'bf477f1b0c3b82f0b7a7094bf003a9a83e37e3b0716c1df799060c4feab17500'
- '7cae72ec356224d9a75c4ce1c6c276dcb22b9a36b3d92f9c57b024dff23cc7f2'
+ '712c2dbdf0fb13cc1c2d4f4ef5dd1ce4b06c3b57e96dfea8f23e6e99f5b1650e'
)
prepare() {
cd "$srcdir"/ncbi-blast-"$pkgver"+-src/c++ || exit
- patch --forward --strip 1 --input="${srcdir}/cstdint.patch"
./configure \
--prefix=/usr \
--with-dll \
diff --git a/cstdint.patch b/cstdint.patch
deleted file mode 100644
index 58151d3b8dff..000000000000
--- a/cstdint.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-*** c++/include/util/impl/compile_time_bits.hpp 2023-01-05 07:04:14.000000000 -0800
---- c++/include/util/impl/compile_time_bits.hpp 2023-06-19 12:41:35.780871378 -0700
-***************
-*** 35,40 ****
---- 35,41 ----
- *
- */
-
-+ #include <cstdint>
- #include <type_traits>
- #include <limits>
- #include <stdexcept>