summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYishen Miao2023-06-19 13:25:21 -0700
committerYishen Miao2023-06-19 13:26:38 -0700
commitc397c5d4bdbc3264b11696a99f4fa3e026370497 (patch)
treef73d7c9d48f4c4e38d7fdfc834a3d874b9924915
parent28d7d1a62a74ddd3e114d7ef202284e4745c3efe (diff)
downloadaur-c397c5d4bdbc3264b11696a99f4fa3e026370497.tar.gz
Patching cstdint
Patches cstdint to compile with GCC 13.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD47
-rw-r--r--cstdint.patch12
3 files changed, 45 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91f6ffa6ceb8..20f57ac3e9db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = blast+
pkgdesc = BLAST tool suite from NCBI (blastn, blastp, blastx, psiblast, etc)
pkgver = 2.14.0
- pkgrel = 2
+ pkgrel = 3
url = http://blast.ncbi.nlm.nih.gov/
arch = i686
arch = x86_64
license = custom
makedepends = cpio
- makedepends = gcc12
- depends = gcc12-libs
+ makedepends = gcc
+ depends = gcc-libs
depends = libelf
depends = zlib
depends = bzip2
@@ -29,6 +29,8 @@ pkgbase = blast+
conflicts = proj
replaces = ncbi-blast
source = https://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/2.14.0/ncbi-blast-2.14.0+-src.tar.gz
+ source = cstdint.patch
sha256sums = bf477f1b0c3b82f0b7a7094bf003a9a83e37e3b0716c1df799060c4feab17500
+ sha256sums = 7cae72ec356224d9a75c4ce1c6c276dcb22b9a36b3d92f9c57b024dff23cc7f2
pkgname = blast+
diff --git a/PKGBUILD b/PKGBUILD
index 0d405bc34df9..8f4ab7a34937 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,36 +5,45 @@
pkgname=blast+
pkgver=2.14.0
-pkgrel=2
+pkgrel=3
pkgdesc="BLAST tool suite from NCBI (blastn, blastp, blastx, psiblast, etc)"
arch=('i686' 'x86_64')
url="http://blast.ncbi.nlm.nih.gov/"
license=('custom')
-depends=('gcc12-libs'
- 'libelf'
- 'zlib'
- 'bzip2'
- 'lzo'
- 'zstd'
- 'db'
- 'pcre'
- 'perl'
- 'python'
- 'lmdb'
- 'libuv'
- 'libnghttp2'
- 'sqlite')
-makedepends=('cpio' 'gcc12')
+depends=(
+ 'gcc-libs'
+ 'libelf'
+ 'zlib'
+ 'bzip2'
+ 'lzo'
+ 'zstd'
+ 'db'
+ 'pcre'
+ 'perl'
+ 'python'
+ 'lmdb'
+ 'libuv'
+ 'libnghttp2'
+ 'sqlite'
+)
+makedepends=('cpio' 'gcc')
# conflicts with proj on libproj.so
conflicts=('blast' 'blast+-bin' 'ncbi-blast' 'proj')
provides=('blast')
replaces=('ncbi-blast')
-source=("https://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/$pkgver/ncbi-blast-$pkgver+-src.tar.gz")
-sha256sums=('bf477f1b0c3b82f0b7a7094bf003a9a83e37e3b0716c1df799060c4feab17500')
+source=(
+ "https://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/$pkgver/ncbi-blast-$pkgver+-src.tar.gz"
+ "cstdint.patch"
+)
+sha256sums=(
+ 'bf477f1b0c3b82f0b7a7094bf003a9a83e37e3b0716c1df799060c4feab17500'
+ '7cae72ec356224d9a75c4ce1c6c276dcb22b9a36b3d92f9c57b024dff23cc7f2'
+)
prepare() {
cd "$srcdir"/ncbi-blast-"$pkgver"+-src/c++ || exit
- CC=/usr/bin/gcc-12 CXX=/usr/bin/g++-12 ./configure \
+ patch --forward --strip 1 --input="${srcdir}/cstdint.patch"
+ ./configure \
--prefix=/usr \
--with-dll \
--with-mt
diff --git a/cstdint.patch b/cstdint.patch
new file mode 100644
index 000000000000..58151d3b8dff
--- /dev/null
+++ b/cstdint.patch
@@ -0,0 +1,12 @@
+*** c++/include/util/impl/compile_time_bits.hpp 2023-01-05 07:04:14.000000000 -0800
+--- c++/include/util/impl/compile_time_bits.hpp 2023-06-19 12:41:35.780871378 -0700
+***************
+*** 35,40 ****
+--- 35,41 ----
+ *
+ */
+
++ #include <cstdint>
+ #include <type_traits>
+ #include <limits>
+ #include <stdexcept>