summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYishen Miao2023-06-19 00:30:08 -0700
committerYishen Miao2023-06-19 00:30:08 -0700
commitcc8d69eb2968cb56f91aab07f9bf4e5cf9b02e21 (patch)
treedb72fc6d6f1651f3d42585b690da440a999dd6a3
parentc160516230b57cb59fbe36062ddf85450bd538bd (diff)
downloadaur-cc8d69eb2968cb56f91aab07f9bf4e5cf9b02e21.tar.gz
Updating to blast 2.14.0
Updates to blast 2.14.0. Switches to GCC 12.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46f2dfa2111c..0f40b7e0b7d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = blast+
pkgdesc = BLAST tool suite from NCBI (blastn, blastp, blastx, psiblast, etc)
- pkgver = 2.13.0
- pkgrel = 2
+ pkgver = 2.14.0
+ pkgrel = 1
url = http://blast.ncbi.nlm.nih.gov/
arch = i686
arch = x86_64
license = custom
makedepends = cpio
+ makedepends = gcc12
+ depends = gcc12
depends = glibc
depends = gcc-libs
depends = libelf
@@ -28,7 +30,7 @@ pkgbase = blast+
conflicts = ncbi-blast
conflicts = proj
replaces = ncbi-blast
- source = https://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/2.13.0/ncbi-blast-2.13.0+-src.tar.gz
- sha256sums = 89553714d133daf28c477f83d333794b3c62e4148408c072a1b4620e5ec4feb2
+ source = https://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/2.14.0/ncbi-blast-2.14.0+-src.tar.gz
+ sha256sums = bf477f1b0c3b82f0b7a7094bf003a9a83e37e3b0716c1df799060c4feab17500
pkgname = blast+
diff --git a/PKGBUILD b/PKGBUILD
index 1fc7110c76d9..1abe5860c446 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,14 @@
# shellcheck disable=SC2034,SC2148,SC2154
pkgname=blast+
-pkgver=2.13.0
-pkgrel=2
+pkgver=2.14.0
+pkgrel=1
pkgdesc="BLAST tool suite from NCBI (blastn, blastp, blastx, psiblast, etc)"
arch=('i686' 'x86_64')
url="http://blast.ncbi.nlm.nih.gov/"
license=('custom')
-depends=('glibc'
+depends=('gcc12'
+ 'glibc'
'gcc-libs'
'libelf'
'zlib'
@@ -25,17 +26,17 @@ depends=('glibc'
'libuv'
'libnghttp2'
'sqlite')
-makedepends=('cpio')
+makedepends=('cpio' 'gcc12')
# conflicts with proj on libproj.so
conflicts=('blast' 'blast+-bin' 'ncbi-blast' 'proj')
provides=('blast')
replaces=('ncbi-blast')
source=("https://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/$pkgver/ncbi-blast-$pkgver+-src.tar.gz")
-sha256sums=('89553714d133daf28c477f83d333794b3c62e4148408c072a1b4620e5ec4feb2')
+sha256sums=('bf477f1b0c3b82f0b7a7094bf003a9a83e37e3b0716c1df799060c4feab17500')
prepare() {
cd "$srcdir"/ncbi-blast-"$pkgver"+-src/c++ || exit
- ./configure \
+ CC=/usr/bin/gcc-12 CXX=/usr/bin/g++-12 ./configure \
--prefix=/usr \
--with-dll \
--with-mt