summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVaporeon2021-01-16 03:22:54 +1300
committerVaporeon2021-01-16 03:22:54 +1300
commit6ae5e749107094b30d44d4e8e5dc690442c3ee40 (patch)
tree51c67b8b3c6e73895bacba417b746aba553e0ba0
parent1aa7d38fb9b9875abb7d66c1efec71b0f625315c (diff)
downloadaur-6ae5e749107094b30d44d4e8e5dc690442c3ee40.tar.gz
fix build
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD57
2 files changed, 30 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0c8756271fa..e3dc8af3e418 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,9 @@
-# Generated by mksrcinfo v8
-# Tue Apr 2 12:26:31 UTC 2019
pkgbase = blastem
pkgdesc = Fast and accurate Sega Genesis/Mega Drive emulator
pkgver = 0.6.2
- pkgrel = 1
+ pkgrel = 2
url = https://www.retrodev.com/blastem/changes.html
arch = x86_64
- arch = i686
license = GPL3
makedepends = python2-pillow
depends = sdl2
@@ -15,7 +12,7 @@ pkgbase = blastem
optdepends = xcftools: game selection menu (must rebuild)
provides = blastem
conflicts = blastem-hg
- source = https://www.retrodev.com/repos/blastem/archive/8aeac7bd9fa7.tar.gz
+ source = blastem-0.6.2.tar.gz::https://www.retrodev.com/repos/blastem/archive/8aeac7bd9fa7.tar.gz
source = menu.patch
sha1sums = 1953ebfd0eaf5e5630ff5488779eb8e6bb8fe9bf
sha1sums = 9336fcf3ee45f3861838d4633a74de6b6392a2fe
diff --git a/PKGBUILD b/PKGBUILD
index dbb4012531e6..292fba99683b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,51 +3,50 @@
pkgname=blastem
pkgver=0.6.2
_srcver=8aeac7bd9fa7
-pkgrel=1
+pkgrel=2
pkgdesc="Fast and accurate Sega Genesis/Mega Drive emulator"
-arch=('x86_64' 'i686')
+arch=('x86_64')
url="https://www.retrodev.com/blastem/changes.html"
license=('GPL3')
depends=('sdl2' 'glew')
makedepends=('python2-pillow')
optdepends=('vasm: game selection menu (must rebuild)'
- 'xcftools: game selection menu (must rebuild)')
+ 'xcftools: game selection menu (must rebuild)')
provides=("${pkgname}")
conflicts=("${pkgname}-hg")
-source=(
- "https://www.retrodev.com/repos/blastem/archive/$_srcver.tar.gz"
- 'menu.patch'
- )
+source=("$pkgname-$pkgver.tar.gz::https://www.retrodev.com/repos/blastem/archive/$_srcver.tar.gz"
+ 'menu.patch')
sha1sums=('1953ebfd0eaf5e5630ff5488779eb8e6bb8fe9bf'
'9336fcf3ee45f3861838d4633a74de6b6392a2fe')
prepare() {
- mv "$srcdir/blastem-$_srcver" "$srcdir/blastem"
- cd "$srcdir/${pkgname}"
- patch -Np1 -i "${srcdir}/menu.patch"
- chmod a+x menumake.sh install.sh
+ cd $pkgname-$_srcver
+ patch -Np1 -i "$srcdir/menu.patch"
+ chmod a+x menumake.sh install.sh
+ #GCC10 workaround
+ perl -pi -e 's|(CFLAGS:=)(-std=gnu99.*)|\1-fcommon \2|g' Makefile
}
build() {
- cd "$srcdir/${pkgname}"
- make blastem
- ./menumake.sh
+ cd $pkgname-$_srcver
+ make blastem
+ ./menumake.sh
}
package() {
- cd "$srcdir/${pkgname}"
- ./install.sh
- mkdir -p "$pkgdir/opt/blastem"
- install -d -g games "$pkgdir/opt/blastem"
- install -m 755 -g games -D to_install/* "$pkgdir/opt/blastem"
- install -m 666 -g games -D default.cfg "$pkgdir/opt/blastem"
- install -m 666 -g games rom.db gamecontrollerdb.txt "$pkgdir/opt/blastem"
- install -m 644 -g games -d "$pkgdir/opt/blastem/shaders"
- install -m 644 -g games -D shaders/* "$pkgdir/opt/blastem/shaders"
- chmod 755 "$pkgdir/opt/blastem/blastem"
- chown root:games "$pkgdir/opt/blastem"
- chown root:games "$pkgdir/opt/blastem/shaders"
- chmod 755 "$pkgdir/opt/blastem/shaders"
- mkdir -p "$pkgdir/usr/bin"
- ln -s "/opt/blastem/blastem" "$pkgdir/usr/bin/blastem"
+ cd $pkgname-$_srcver
+ ./install.sh
+ mkdir -p "$pkgdir/opt/blastem"
+ install -d -g games "$pkgdir/opt/blastem"
+ install -m 755 -g games -D to_install/* "$pkgdir/opt/blastem"
+ install -m 666 -g games -D default.cfg "$pkgdir/opt/blastem"
+ install -m 666 -g games rom.db gamecontrollerdb.txt "$pkgdir/opt/blastem"
+ install -m 644 -g games -d "$pkgdir/opt/blastem/shaders"
+ install -m 644 -g games -D shaders/* "$pkgdir/opt/blastem/shaders"
+ chmod 755 "$pkgdir/opt/blastem/blastem"
+ chown root:games "$pkgdir/opt/blastem"
+ chown root:games "$pkgdir/opt/blastem/shaders"
+ chmod 755 "$pkgdir/opt/blastem/shaders"
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s "/opt/blastem/blastem" "$pkgdir/usr/bin/blastem"
}