summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSalvador Pardiñas2017-06-08 00:54:33 -0300
committerSalvador Pardiñas2017-06-08 00:54:33 -0300
commita18d1f3086f2aa13bfee9032057ba0ec7838eecf (patch)
treeff90655044d94b3ee108cc6efad2feb2ce73d9af
parent40d6a527d6a8605ffe1f7dde0cdd7592a2f7783c (diff)
downloadaur-a18d1f3086f2aa13bfee9032057ba0ec7838eecf.tar.gz
Fixed xcftools requirement
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
-rw-r--r--menu.patch16
3 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b9604c988d8..8671e5278913 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = blastem
pkgdesc = Fast and accurate Sega Genesis/Mega Drive emulator
pkgver = 0.5.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.retrodev.com/blastem/changes.html
arch = x86_64
arch = i686
@@ -10,12 +10,13 @@ pkgbase = blastem
depends = sdl2
depends = glew
optdepends = vasm: game selection menu (must rebuild)
+ optdepends = xcftools: game selection menu (must rebuild)
provides = blastem
conflicts = blastem-hg
source = https://www.retrodev.com/repos/blastem/archive/99d153d9e9ca.tar.gz
source = menu.patch
md5sums = 8d2fbac987082700912d84d00cbbe67d
- md5sums = cea255d6ac07a7ac8eab47cef08c5e93
+ md5sums = b01d07f2630bb2c31ffda48dddc85785
pkgname = blastem
diff --git a/PKGBUILD b/PKGBUILD
index c28f1ba9b8de..ba1f43c7089f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Salvador Pardiñas <darkfm@vera.com.uy>
pkgname=blastem
pkgver=0.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Fast and accurate Sega Genesis/Mega Drive emulator"
arch=('x86_64' 'i686')
url="https://www.retrodev.com/blastem/changes.html"
@@ -9,7 +9,8 @@ license=('GPL3')
groups=()
depends=('sdl2' 'glew')
makedepends=('python2-pillow')
-optdepends=('vasm: game selection menu (must rebuild)')
+optdepends=('vasm: game selection menu (must rebuild)'
+ 'xcftools: game selection menu (must rebuild)')
provides=("${pkgname}")
conflicts=("${pkgname}-hg")
replaces=()
@@ -51,4 +52,4 @@ package() {
ln -s "/opt/blastem/blastem" "$pkgdir/usr/bin/blastem"
}
md5sums=('8d2fbac987082700912d84d00cbbe67d'
- 'cea255d6ac07a7ac8eab47cef08c5e93')
+ 'b01d07f2630bb2c31ffda48dddc85785')
diff --git a/menu.patch b/menu.patch
index 514a4c945862..d12b760c7d59 100644
--- a/menu.patch
+++ b/menu.patch
@@ -1,6 +1,6 @@
diff -Nura blastem.old/img2tiles.py blastem.new/img2tiles.py
--- blastem.old/img2tiles.py 2017-06-02 05:44:36.000000000 -0300
-+++ blastem.new/img2tiles.py 2017-06-04 07:41:18.821726079 -0300
++++ blastem.new/img2tiles.py 2017-06-08 00:50:40.400366258 -0300
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python2
@@ -9,7 +9,7 @@ diff -Nura blastem.old/img2tiles.py blastem.new/img2tiles.py
def gchannel(Val):
diff -Nura blastem.old/install.sh blastem.new/install.sh
--- blastem.old/install.sh 1969-12-31 21:00:00.000000000 -0300
-+++ blastem.new/install.sh 2017-06-04 07:29:19.335054226 -0300
++++ blastem.new/install.sh 2017-06-08 00:50:40.403699591 -0300
@@ -0,0 +1,5 @@
+mkdir "to_install"
+cp blastem to_install/blastem
@@ -18,11 +18,15 @@ diff -Nura blastem.old/install.sh blastem.new/install.sh
+fi
diff -Nura blastem.old/menumake.sh blastem.new/menumake.sh
--- blastem.old/menumake.sh 1969-12-31 21:00:00.000000000 -0300
-+++ blastem.new/menumake.sh 2017-06-04 07:25:16.008385802 -0300
-@@ -0,0 +1,6 @@
++++ blastem.new/menumake.sh 2017-06-08 00:52:01.067033096 -0300
+@@ -0,0 +1,10 @@
+#!/bin/bash
+if(pacman -Q vasm >/dev/null); then
-+ make menu.bin
++ if(pacman -Q xcftools >/dev/null); then
++ make menu.bin
++ else
++ echo "You need to install vasm and xcftools from AUR to compile the menu"
++ fi
+else
-+ echo "You need to install vasm from AUR to compile the menu"
++ echo "You need to install vasm and xcftools from AUR to compile the menu"
+fi