summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVaporeon2019-01-31 02:45:02 +1300
committerVaporeon2019-01-31 02:45:02 +1300
commit856212f3f01ff0c00a50532638a1cae1ddc8eb9b (patch)
treef13c0f26ffcf753be3b4f1d9335b51928c7e5dae
parent1ce12a34748be30d323debebf7f1aacc01edb55a (diff)
downloadaur-856212f3f01ff0c00a50532638a1cae1ddc8eb9b.tar.gz
update package
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD56
-rw-r--r--menu.patch32
3 files changed, 74 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 599089ca6fe9..0597234b9e61 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,22 @@
+# Generated by mksrcinfo v8
+# Wed Jan 30 13:44:51 UTC 2019
pkgbase = blastem-hg
pkgdesc = Fast and accurate Sega Genesis/Mega Drive emulator
- pkgver = r682.7ed1dbb48f61
- pkgrel = 2
+ pkgver = r1693.ba3fb7a3be6b
+ pkgrel = 1
url = http://rhope.retrodev.com/files/blastem.html
arch = x86_64
license = GPLv3
makedepends = mercurial
- depends = sdl
+ makedepends = python2-pillow
+ depends = sdl2
+ depends = glew
provides = blastem
conflicts = blastem
source = blastem::hg+http://rhope.retrodev.com/repos/blastem
+ source = menu.patch
sha256sums = SKIP
+ sha256sums = 4b8e76103e1d607f2e4117c1a23e1d97b2bdca5f01ac2b5d3b433478a3b211d6
pkgname = blastem-hg
diff --git a/PKGBUILD b/PKGBUILD
index c029987d0c8e..95ca8d4ce884 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,53 @@
-# Maintainer: Lukas Sabota <lukas@lwsabota.com>
+# Maintainer: Vaporeon <vaporeon@vaporeon.io>
# Contributor: Lukas Sabota <lukas@lwsabota.com>
pkgname=blastem-hg
-pkgver=r682.7ed1dbb48f61
-pkgrel=2
+pkgver=r1693.ba3fb7a3be6b
+pkgrel=1
pkgdesc="Fast and accurate Sega Genesis/Mega Drive emulator"
arch=('x86_64')
url="http://rhope.retrodev.com/files/blastem.html"
license=('GPLv3')
-groups=()
-depends=('sdl')
-makedepends=('mercurial')
+depends=('sdl2' 'glew')
+makedepends=('mercurial' 'python2-pillow')
provides=('blastem')
conflicts=('blastem')
-replaces=()
-backup=()
-options=()
-install=
-source=(blastem::hg+http://rhope.retrodev.com/repos/blastem)
-sha256sums=('SKIP')
+source=(blastem::hg+http://rhope.retrodev.com/repos/blastem
+ 'menu.patch')
+sha256sums=('SKIP'
+ '4b8e76103e1d607f2e4117c1a23e1d97b2bdca5f01ac2b5d3b433478a3b211d6')
_hgrepo="blastem"
pkgver() {
cd $srcdir/$_hgrepo
- printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)" | sed s/+//g
}
+prepare() {
+ cd "$srcdir/${pkgname%-hg}"
+ patch -Np1 -i "${srcdir}/menu.patch"
+ chmod a+x menumake.sh install.sh
+}
build() {
- cd $srcdir
- rm -rf "$srcdir/$_hgrepo-build"
- cp -r "$srcdir/$_hgrepo" "$srcdir/$_hgrepo-build"
- cd "$srcdir/$_hgrepo-build"
- make blastem
+ cd "$srcdir/${pkgname%-hg}"
+ make blastem
+ ./menumake.sh
}
-
package() {
- cd "$srcdir/$_hgrepo-build"
- install -Dm 755 blastem $pkgdir/usr/bin/blastem
+ cd "$srcdir/${pkgname%-hg}"
+ ./install.sh
+ mkdir -p "$pkgdir/opt/blastem"
+ install -d -g games "$pkgdir/opt/blastem"
+ install -m 755 -g games -D to_install/* "$pkgdir/opt/blastem"
+ install -m 666 -g games -D default.cfg "$pkgdir/opt/blastem"
+ install -m 666 -g games rom.db gamecontrollerdb.txt "$pkgdir/opt/blastem"
+ install -m 644 -g games -d "$pkgdir/opt/blastem/shaders"
+ install -m 644 -g games -D shaders/* "$pkgdir/opt/blastem/shaders"
+ chmod 755 "$pkgdir/opt/blastem/blastem"
+ chown root:games "$pkgdir/opt/blastem"
+ chown root:games "$pkgdir/opt/blastem/shaders"
+ chmod 755 "$pkgdir/opt/blastem/shaders"
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s "/opt/blastem/blastem" "$pkgdir/usr/bin/blastem"
}
-
-# vim:set ts=2 sw=2 et:
diff --git a/menu.patch b/menu.patch
new file mode 100644
index 000000000000..d12b760c7d59
--- /dev/null
+++ b/menu.patch
@@ -0,0 +1,32 @@
+diff -Nura blastem.old/img2tiles.py blastem.new/img2tiles.py
+--- blastem.old/img2tiles.py 2017-06-02 05:44:36.000000000 -0300
++++ blastem.new/img2tiles.py 2017-06-08 00:50:40.400366258 -0300
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ from PIL import Image
+
+ def gchannel(Val):
+diff -Nura blastem.old/install.sh blastem.new/install.sh
+--- blastem.old/install.sh 1969-12-31 21:00:00.000000000 -0300
++++ blastem.new/install.sh 2017-06-08 00:50:40.403699591 -0300
+@@ -0,0 +1,5 @@
++mkdir "to_install"
++cp blastem to_install/blastem
++if [ -f "./menu.bin" ]; then
++ cp menu.bin to_install/menu.bin
++fi
+diff -Nura blastem.old/menumake.sh blastem.new/menumake.sh
+--- blastem.old/menumake.sh 1969-12-31 21:00:00.000000000 -0300
++++ blastem.new/menumake.sh 2017-06-08 00:52:01.067033096 -0300
+@@ -0,0 +1,10 @@
++#!/bin/bash
++if(pacman -Q vasm >/dev/null); then
++ if(pacman -Q xcftools >/dev/null); then
++ make menu.bin
++ else
++ echo "You need to install vasm and xcftools from AUR to compile the menu"
++ fi
++else
++ echo "You need to install vasm and xcftools from AUR to compile the menu"
++fi