summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAfnan Enayet2020-04-20 13:09:17 -0400
committerAfnan Enayet2020-04-20 13:10:36 -0400
commit19d349d02dde74d610b1cc06f69fe508abb57251 (patch)
treea1c1cdc4406471f9b75dd61d4e22e2758408514b
parentd79f5db10060d794b24a0554b9844945a66309e0 (diff)
downloadaur-19d349d02dde74d610b1cc06f69fe508abb57251.tar.gz
Use variables in download URL, bump pkgrel
I had accidentally hardcoded the package version instead of using the version from the `pkgver` variable. This usees the proper variable so it downloads the specified version of blaze
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 618c299d0992..9d623144d4ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = blaze
pkgdesc = An open-source, high-performance C++ math library for dense and sparse arithmetic.
pkgver = 3.7
- pkgrel = 1
+ pkgrel = 2
url = https://bitbucket.org/blaze-lib/blaze
arch = any
license = BSD
@@ -12,7 +12,7 @@ pkgbase = blaze
makedepends = blas
makedepends = lapack
provides = blaze
- source = blaze-3.7.tar.gz::https://bitbucket.org/blaze-lib/blaze/get/v3.6.tar.gz
+ source = blaze-3.7.tar.gz::https://bitbucket.org/blaze-lib/blaze/get/v3.7.tar.gz
sha256sums = 7ce39023c0c20569355d39ba31ce4584041de898a7f0eb13c91d75532b173bdb
pkgname = blaze
diff --git a/PKGBUILD b/PKGBUILD
index 61fddc874fd1..c59be2df65b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=blaze
provides=('blaze')
pkgver=3.7
-pkgrel=1
+pkgrel=2
pkgdesc='An open-source, high-performance C++ math library for dense and sparse arithmetic.'
url='https://bitbucket.org/blaze-lib/blaze'
arch=('any')
license=('BSD')
makedepends=('cmake' 'git' 'make' 'gcc' 'blas' 'lapack')
sha256sums=('7ce39023c0c20569355d39ba31ce4584041de898a7f0eb13c91d75532b173bdb')
-source=("$pkgname-$pkgver.tar.gz::https://bitbucket.org/blaze-lib/blaze/get/v3.6.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://bitbucket.org/blaze-lib/blaze/get/v${pkgver}.tar.gz")
prepare() {
mv "blaze-lib-blaze-51fff70fcc70" "$pkgname-$pkgver"