summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAfnan Enayet2020-04-21 21:23:07 -0400
committerAfnan Enayet2020-04-21 21:25:39 -0400
commita1714b25c7908f3ba22b2d7d292b41b4f6c97392 (patch)
tree35d38e91b64f64a3477593c5ea08f00c5dd3d89c
parente2ed99db67457d16e4ca5e9fefc46f2592f3e6f4 (diff)
downloadaur-a1714b25c7908f3ba22b2d7d292b41b4f6c97392.tar.gz
Use variable for git ref
We need to specify the git ref, since bitbucket includes the ref as part of the folder name
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0cb9640e88aa..c0338d89ba66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = blaze
pkgdesc = An open-source, high-performance C++ math library for dense and sparse arithmetic.
pkgver = 3.7
- pkgrel = 3
+ pkgrel = 4
url = https://bitbucket.org/blaze-lib/blaze
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 3b867a8e29fa..511047ebf52f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=blaze
provides=('blaze')
pkgver=3.7
-pkgrel=3
+pkgrel=4
pkgdesc='An open-source, high-performance C++ math library for dense and sparse arithmetic.'
url='https://bitbucket.org/blaze-lib/blaze'
arch=('any')
@@ -10,9 +10,10 @@ license=('BSD')
makedepends=('cmake' 'git' 'make' 'gcc' 'blas' 'lapack')
sha256sums=('a24328da1deabc8e15295fbbaa242d0b37cda8d4e05d0e6772926308c6a953f0')
source=("$pkgname-$pkgver.tar.gz::https://bitbucket.org/blaze-lib/blaze/get/v${pkgver}.tar.gz")
+_git_ref='e9724478a5fd'
prepare() {
- mv "blaze-lib-blaze-51fff70fcc70" "$pkgname-$pkgver"
+ mv "blaze-lib-blaze-${_git_ref}" "$pkgname-$pkgver"
}
build() {