summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornameful.tee2018-08-19 09:03:36 +0300
committernameful.tee2018-08-19 09:03:36 +0300
commite7de4b90c2f6637a602e5aa899052681bae7cb5c (patch)
treed19c0042186e21166f6e7186653f009d75eed61a
parent960ce938e5154fa20beafb5b19cb754fbaa3485f (diff)
downloadaur-e7de4b90c2f6637a602e5aa899052681bae7cb5c.tar.gz
Use cmake for build and install
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD40
2 files changed, 23 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 673191748f31..223e039eb747 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = blaze-git
pkgdesc = An open-source, high-performance C++ math library for dense and sparse arithmetic.
- pkgver = 3.2.r424.55424cc65
+ pkgver = 3.3.r430.ea158fdf7
pkgrel = 1
url = https://bitbucket.org/blaze-lib/blaze
arch = i686
arch = x86_64
license = New BSD
makedepends = git
+ makedepends = cmake
optdepends = blas: for maximum performance.
optdepends = lapack: for computing the determinant of a dense matrix and for the dense matrix inversion.
optdepends = boost: to use Boost threads to run numeric operations in parallel.
diff --git a/PKGBUILD b/PKGBUILD
index d5e1c59b5571..1b6caaf870e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,41 @@
-# Maintainer: Hal Gentz <zegentzy@protonmail.com>
+# Maintainer: nameful.tee <nameful.tee@protonmail.ch>
+# Contributor: Hal Gentz <zegentzy@protonmail.com>
pkgname=blaze-git
-pkgver=3.2.r424.55424cc65
+pkgver=3.3.r430.ea158fdf7
pkgrel=1
pkgdesc="An open-source, high-performance C++ math library for dense and sparse arithmetic."
arch=('i686' 'x86_64')
url="https://bitbucket.org/blaze-lib/blaze"
license=('New BSD')
optdepends=('blas: for maximum performance.'
- 'lapack: for computing the determinant of a dense matrix and for the dense matrix inversion.'
- 'boost: to use Boost threads to run numeric operations in parallel.')
-makedepends=('git')
+ 'lapack: for computing the determinant of a dense matrix and for the dense matrix inversion.'
+ 'boost: to use Boost threads to run numeric operations in parallel.')
+makedepends=('git' 'cmake')
provides=('blaze')
conflicts=('blaze')
-source=("$pkgname::git+https://bitbucket.org/blaze-lib/blaze.git")
+source=("${pkgname}::git+https://bitbucket.org/blaze-lib/blaze.git")
md5sums=('SKIP')
pkgver()
{
- cd "$srcdir/${pkgname}"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
+ cd "${srcdir}/${pkgname}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
+}
+
+build() {
+ mkdir -p "${srcdir}/build"
+ cd "${srcdir}/build"
+ cmake "${srcdir}/${pkgname}" \
+ -DCMAKE_INSTALL_PREFIX="/usr"
}
package()
{
- cd "$srcdir/$pkgname"
-
- # New BSD license
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-
- # include files
- install -d -m644 "${pkgdir}/usr/include"
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}" install
- cp -r ./blaze "${pkgdir}/usr/include"
-
- find "${pkgdir}/usr/include" -type d -exec chmod 755 {} \;
- find "${pkgdir}/usr/include" -type f -exec chmod 644 {} \;
+ # Install LICENSE file
+ cd "${srcdir}/${pkgname}"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}