summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornameful.tee2018-09-24 19:41:22 +0300
committernameful.tee2018-09-24 19:41:22 +0300
commited5f411f753843bcee9595b793524854770e767b (patch)
treeef0d24af0774ffce6f478144b1b1697f38e8c60f
parente7de4b90c2f6637a602e5aa899052681bae7cb5c (diff)
downloadaur-ed5f411f753843bcee9595b793524854770e767b.tar.gz
optdepends correction
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 223e039eb747..3ecf72ddae1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = blaze-git
pkgdesc = An open-source, high-performance C++ math library for dense and sparse arithmetic.
- pkgver = 3.3.r430.ea158fdf7
+ pkgver = 3.4.r84.d518c7ccf
pkgrel = 1
url = https://bitbucket.org/blaze-lib/blaze
arch = i686
@@ -8,9 +8,12 @@ pkgbase = blaze-git
license = New BSD
makedepends = git
makedepends = cmake
+ makedepends = blas
+ makedepends = lapack
+ makedepends = boost-libs
optdepends = blas: for maximum performance.
optdepends = lapack: for computing the determinant of a dense matrix and for the dense matrix inversion.
- optdepends = boost: to use Boost threads to run numeric operations in parallel.
+ optdepends = boost-libs: to use Boost threads to run numeric operations in parallel.
provides = blaze
conflicts = blaze
source = blaze-git::git+https://bitbucket.org/blaze-lib/blaze.git
diff --git a/PKGBUILD b/PKGBUILD
index 1b6caaf870e9..f8385353a4c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: nameful.tee <nameful.tee@protonmail.ch>
+# Contributor: bartus <arch-user-repoᘓbartus.33mail.com>
# Contributor: Hal Gentz <zegentzy@protonmail.com>
pkgname=blaze-git
-pkgver=3.3.r430.ea158fdf7
+pkgver=3.4.r84.d518c7ccf
pkgrel=1
pkgdesc="An open-source, high-performance C++ math library for dense and sparse arithmetic."
arch=('i686' 'x86_64')
@@ -10,8 +11,8 @@ url="https://bitbucket.org/blaze-lib/blaze"
license=('New BSD')
optdepends=('blas: for maximum performance.'
'lapack: for computing the determinant of a dense matrix and for the dense matrix inversion.'
- 'boost: to use Boost threads to run numeric operations in parallel.')
-makedepends=('git' 'cmake')
+ 'boost-libs: to use Boost threads to run numeric operations in parallel.')
+makedepends=('git' 'cmake' 'blas' 'lapack' 'boost-libs')
provides=('blaze')
conflicts=('blaze')
source=("${pkgname}::git+https://bitbucket.org/blaze-lib/blaze.git")