summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2019-11-09 10:02:13 -0500
committergraysky2019-11-09 10:02:13 -0500
commit28f2d8bbf4e480a461acfc8d9eb252981253b622 (patch)
tree3a254c44c729de1014150527ce707e9eb61f5df5
parentab33161e2dce5762e7f768847afa255c8054c499 (diff)
downloadaur-28f2d8bbf4e480a461acfc8d9eb252981253b622.tar.gz
Update to 3.0-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 22 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84a101a31e7d..67e11f5a4bee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
-# Generated by mksrcinfo v8
-# Sat May 11 13:01:58 UTC 2019
pkgbase = bleachbit-cli
pkgdesc = Deletes unneeded files to free disk space and maintain privacy. CLI version/no GUI.
- pkgver = 2.2
- pkgrel = 2
+ pkgver = 3.0
+ pkgrel = 1
url = https://www.bleachbit.org/
arch = any
license = GPL3
- makedepends = python
- depends = python2
- provides = bleachbit=2.2
- source = https://download.bleachbit.org/bleachbit-2.2.tar.bz2
- sha256sums = 0318cd1bc83655971c9ffd6bf27f4866bbe57381e92cfbcf8a2a6833075b49fa
+ depends = python2-gobject
+ provides = bleachbit=3.0
+ conflicts = bleachbit
+ source = https://download.bleachbit.org/bleachbit-3.0.tar.bz2
+ sha256sums = ed18cb522cc375589cc0c94fbfaf6d7ee6fb94a8a1261400252b1ca32b4cdaa2
pkgname = bleachbit-cli
diff --git a/PKGBUILD b/PKGBUILD
index 96136a4f0857..4b38f530f7ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,24 +8,31 @@
pkgname=bleachbit-cli
_pkgname=bleachbit
-pkgver=2.2
-pkgrel=2
+pkgver=3.0
+pkgrel=1
pkgdesc='Deletes unneeded files to free disk space and maintain privacy. CLI version/no GUI.'
+conflicts=($_pkgname)
provides=("bleachbit=${pkgver}")
arch=(any)
url='https://www.bleachbit.org/'
license=(GPL3)
-depends=(python2)
-makedepends=(python)
+depends=(python2-gobject)
source=(https://download.bleachbit.org/$_pkgname-$pkgver.tar.bz2)
-sha256sums=('0318cd1bc83655971c9ffd6bf27f4866bbe57381e92cfbcf8a2a6833075b49fa')
+sha256sums=('ed18cb522cc375589cc0c94fbfaf6d7ee6fb94a8a1261400252b1ca32b4cdaa2')
+
+prepare() {
+ cd $_pkgname-$pkgver
+ sed -e 's|python|python2|g' -i bleachbit/CLI.py
+}
package() {
- cd $_pkgname-$pkgver
+ cd $_pkgname-$pkgver
- make prefix=/usr DESTDIR="$pkgdir" PYTHON=python2 install
+ make prefix=/usr DESTDIR="$pkgdir" install
- # suggestion by Meow to force script to operate in cli mode
+ # suggestion by Meow to force script to operate in cli mode
sed -i 's/if 1/if 0/' "$pkgdir"/usr/bin/bleachbit
+
rm -rf "$pkgdir"/usr/share/{applications,pixmaps}
+ rm -rf "$pkgdir"/usr/share/polkit-1
}