summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorthegala2020-01-21 00:39:40 +0100
committerthegala2020-01-21 00:42:41 +0100
commit4fd71baef3ebdb17bbde8053384f956e611c29dd (patch)
tree96e403519fcfb6b8a7206a989233d118da28e398
downloadaur-4fd71baef3ebdb17bbde8053384f956e611c29dd.tar.gz
Initial commit.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
-rw-r--r--python3-patch.patch8
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31d7ce3df16f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = bleachbit-py3-git
+ pkgdesc = Deletes unneeded files to free disk space and maintain privacy. Python 3 version.
+ pkgver = r4914.13ee23b7
+ pkgrel = 1
+ url = https://www.bleachbit.org/
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = pygtk
+ depends = python-gobject
+ depends = gtk3
+ provides = bleachbit
+ conflicts = bleachbit
+ source = bleachbit::git+https://github.com/bleachbit/bleachbit.git
+ sha256sums = SKIP
+
+pkgname = bleachbit-py3-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a644eda54ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: thegala <thegala@disroot.org>
+
+_pkgname=bleachbit
+pkgname=bleachbit-py3-git
+pkgver=r4914.13ee23b7
+pkgrel=1
+pkgdesc='Deletes unneeded files to free disk space and maintain privacy. Python 3 version.'
+url='https://www.bleachbit.org/'
+license=('GPL3')
+source=("${_pkgname}::git+https://github.com/bleachbit/bleachbit.git")
+sha256sums=('SKIP')
+arch=('any')
+depends=('pygtk' 'python-gobject' 'gtk3')
+makedepends=('git')
+conflicts=('bleachbit')
+provides=('bleachbit')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ git checkout origin/py3
+ patch bleachbit.py < ../../python3-patch.patch
+}
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make prefix=/usr DESTDIR="$pkgdir" install
+}
diff --git a/python3-patch.patch b/python3-patch.patch
new file mode 100644
index 000000000000..c7f1df2f2df3
--- /dev/null
+++ b/python3-patch.patch
@@ -0,0 +1,8 @@
+--- bleachbit.py 2020-01-21 00:30:43.309694006 +0100
++++ bleachbit2.py 2020-01-21 00:30:07.440085690 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python2
++#!/usr/bin/env python3
+ # vim: ts=4:sw=4:expandtab
+
+ # BleachBit