aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2017-07-14 14:48:20 +0200
committerbartus2017-07-14 14:48:20 +0200
commit6fda0965c4f0857ddd81eae9f0e3445a8d1c534b (patch)
tree7a97c68f5b9d0974572eb81a5687c478628078e1
parent2960da023ab4d8c357c7373d2d953fd12f2015ba (diff)
downloadaur-6fda0965c4f0857ddd81eae9f0e3445a8d1c534b.tar.gz
move python detection inside build()
-rw-r--r--PKGBUILD4
1 files changed, 1 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c513c717bba4..46cd3c427894 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -47,9 +47,6 @@ pkgver() {
}
prepare() {
-# move _pyver inside preapre to allow build in clean chroot which is missing python package
-
- _pyver=$(python -c "from sys import version_info; print(\"%d.%d\" % (version_info[0],version_info[1]))")
cd "$srcdir/blender"
# update the submodules
git submodule update --init --recursive
@@ -61,6 +58,7 @@ build() {
mkdir -p "$srcdir/blender-build"
cd "$srcdir/blender-build"
+ _pyver=$(python -c "from sys import version_info; print(\"%d.%d\" % (version_info[0],version_info[1]))")
msg "python version detected: ${_pyver}"
cmake "$srcdir/blender" \