aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2020-07-30 16:53:24 +0200
committerbartus2020-09-02 09:29:34 +0200
commit0446014062b6e49bf2fbdc458a90eb7420db4e0f (patch)
treed3e37e2f1b6d68db1416b3eaf8d260ab67ca330f
parentb91ec93ad498a530bdc3475792119a9c6657670e (diff)
downloadaur-0446014062b6e49bf2fbdc458a90eb7420db4e0f.tar.gz
Port changes form blender-2.83-git
* Fix build against cuda11. * Remove old install/desktop files.
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD162
-rw-r--r--blender-2.8.desktop14
-rw-r--r--blender.install14
-rw-r--r--cuda11.patch64
-rw-r--r--embree.patch43
6 files changed, 213 insertions, 120 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1ca796518bd..412553416852 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,23 @@
pkgbase = blender-2.81-git
- pkgdesc = Alpha version of Blender 2.81-release branch
- pkgver = 2.81.r91291.f8e8f4ee0f8
+ pkgdesc = Maintenance version of Blender 2.81-release branch
+ pkgver = 2.81.r91465.gf1aa4d18d49
pkgrel = 1
url = https://blender.org/
- install = blender.install
arch = i686
arch = x86_64
license = GPL
+ makedepends = ninja
makedepends = git
makedepends = cmake
makedepends = boost
makedepends = mesa
makedepends = llvm
- makedepends = ninja
+ depends = embree
depends = alembic
depends = libgl
depends = python
depends = python-numpy
- depends = openjpeg
- depends = desktop-file-utils
- depends = hicolor-icon-theme
+ depends = openjpeg2
depends = ffmpeg
depends = fftw
depends = openal
@@ -27,30 +25,32 @@ pkgbase = blender-2.81-git
depends = libxi
depends = openimageio
depends = opencolorio
- depends = openimagedenoise
depends = openvdb
depends = opencollada
depends = opensubdiv
depends = openshadinglanguage
depends = libtiff
depends = libpng
+ depends = openimagedenoise
optdepends = cuda: CUDA support in Cycles
- provides = blender-2.81
- conflicts = blender-2.81
+ provides = blender=2.81
+ conflicts = blender=2.81
source = git://git.blender.org/blender.git#branch=blender-v2.81-release
source = blender-addons.git::git://git.blender.org/blender-addons.git
source = blender-addons-contrib.git::git://git.blender.org/blender-addons-contrib.git
source = blender-translations.git::git://git.blender.org/blender-translations.git
source = blender-dev-tools.git::git://git.blender.org/blender-dev-tools.git
- source = blender-2.8.desktop
source = SelectCudaComputeArch.patch
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = cd108dca1c77607c6a7cc45aa284ea97
- md5sums = 4441d9a6db38b85b7dc5c3c9e6872951
+ source = embree.patch
+ source = cuda11.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 66b9bf3db441f35119ef0eb5f855142f2e773e8002ac0216e056bcc6f8ac409c
+ sha256sums = 42afe119529a5350034a489225958112bf4b84bdee38757a932e5caaa9bd5ed4
+ sha256sums = 0316d92f180f2fa428a206074bd5adfd30968f9ae5d308efea05e42741dd53fd
pkgname = blender-2.81-git
diff --git a/PKGBUILD b/PKGBUILD
index 89c0b16a11fc..a3073f688aff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,37 @@
+#!/bin/hint/bash
# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
-# shellcheck disable=SC2034
+# shellcheck disable=SC2034,SC2154 # allow unused/unset variables
+# shellcheck disable=SC2191 # preserve current _CMAKE_FLAGS initialization.
-#to enforce cuda verison uncomment this line and update value of sm_xx model accordingly
-#_cuda_capability+=(sm_30 sm_35 sm_37)
-#_cuda_capability+=(sm_50 sm_52 sm_60 sm_61 sm_70 sm_75)
-((TRAVIS)) && _cuda_capability+=(sm_50 sm_52 sm_60 sm_61 sm_70 sm_75) # suppress 3.x to prevent Travis build exceed time limit.
+# Configuration.
+_fragment=${FRAGMENT:-#branch=blender-v2.81-release}
+[[ -v CUDA_ARCH ]] && _cuda_capability=${CUDA_ARCH}
+
+#some extra, unofficially supported stuff goes here:
+((TRAVIS)) && _cuda_capability+=(sm_50 sm_52 sm_60 sm_61 sm_70 sm_75) # Travis memory limit is not enough to build for arch 3.x.
+_CMAKE_FLAGS+=( -DWITH_ALEMBIC_HDF5=ON )
+((DISABLE_EMBREE)) || {
+ _CMAKE_FLAGS+=( -DWITH_CYCLES_EMBREE=ON )
+ depends+=(embree)
+}
+((DISABLE_NINJA)) || makedepends+=('ninja')
+#shellcheck disable=SC2015
+((DISABLE_CUDA)) && optdepends+=('cuda: CUDA support in Cycles') || { makedepends+=('cuda') ; ((DISABLE_OPTIX)) || makedepends+=('optix=7.0'); }
pkgname=blender-2.81-git
-_fragment="#branch=blender-v2.81-release"
-pkgver=2.81.r91291.f8e8f4ee0f8
+pkgver=2.81.r91465.gf1aa4d18d49
pkgrel=1
-pkgdesc="Alpha version of Blender 2.81-release branch"
+pkgdesc="Maintenance version of Blender 2.81-release branch"
arch=('i686' 'x86_64')
url="https://blender.org/"
-depends=('alembic' 'libgl' 'python' 'python-numpy' 'openjpeg' 'desktop-file-utils' 'hicolor-icon-theme'
- 'ffmpeg' 'fftw' 'openal' 'freetype2' 'libxi' 'openimageio' 'opencolorio' 'openimagedenoise'
+depends+=('alembic' 'libgl' 'python' 'python-numpy' 'openjpeg2'
+ 'ffmpeg' 'fftw' 'openal' 'freetype2' 'libxi' 'openimageio' 'opencolorio'
'openvdb' 'opencollada' 'opensubdiv' 'openshadinglanguage' 'libtiff' 'libpng')
-makedepends=('git' 'cmake' 'boost' 'mesa' 'llvm')
-((DISABLE_NINJA)) || makedepends+=('ninja')
-((DISABLE_CUDA)) && optdepends=('cuda: CUDA support in Cycles') || { makedepends+=('cuda') ; ((DISABLE_OPTIX)) || makedepends+=('optix>=7.0'); }
-provides=("blender-${pkgver%%.r*}")
-conflicts=("blender-${pkgver%%.r*}")
+depends+=('openimagedenoise')
+makedepends+=('git' 'cmake' 'boost' 'mesa' 'llvm')
+provides=("blender=${pkgver%%.r*}")
+conflicts=("blender=${pkgver%%.r*}")
license=('GPL')
-install=blender.install
# NOTE: the source array has to be kept in sync with .gitmodules
# the submodules has to be stored in path ending with git to match
# the path in .gitmodules.
@@ -33,99 +42,104 @@ source=("git://git.blender.org/blender.git${_fragment}"
'blender-addons-contrib.git::git://git.blender.org/blender-addons-contrib.git'
'blender-translations.git::git://git.blender.org/blender-translations.git'
'blender-dev-tools.git::git://git.blender.org/blender-dev-tools.git'
- blender-2.8.desktop
SelectCudaComputeArch.patch
+ embree.patch #add missing embree link.
+ 'cuda11.patch'
)
-md5sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'cd108dca1c77607c6a7cc45aa284ea97'
- '4441d9a6db38b85b7dc5c3c9e6872951')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ '66b9bf3db441f35119ef0eb5f855142f2e773e8002ac0216e056bcc6f8ac409c'
+ '42afe119529a5350034a489225958112bf4b84bdee38757a932e5caaa9bd5ed4'
+ '0316d92f180f2fa428a206074bd5adfd30968f9ae5d308efea05e42741dd53fd')
pkgver() {
- cd "$srcdir/blender"
- printf "%s.r%s.%s" "$(grep -Po "BLENDER_VERSION \K[0-9]{3}" source/blender/blenkernel/BKE_blender_version.h|sed 's/./&./1')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ blender_version=$(grep -Po "BLENDER_VERSION \K[0-9]{3}" "$srcdir"/blender/source/blender/blenkernel/BKE_blender_version.h)
+ printf "%d.%d.r%s.g%s" \
+ $((blender_version/100)) \
+ $((blender_version%100)) \
+ "$(git -C "$srcdir/blender" rev-list --count HEAD)" \
+ "$(git -C "$srcdir/blender" rev-parse --short HEAD)"
}
prepare() {
- cd "$srcdir/blender"
# update the submodules
- git submodule update --init --recursive --remote
- if [ -z "$_cuda_capability" ] && grep -q nvidia <(lsmod); then
- git apply -v ${srcdir}/SelectCudaComputeArch.patch
+ git -C "$srcdir/blender" submodule update --init --recursive --remote
+ if [ ! -v _cuda_capability ] && grep -q nvidia <(lsmod); then
+ git -C "$srcdir/blender" apply -v "${srcdir}"/SelectCudaComputeArch.patch
fi
+ ((DISABLE_EMBREE)) || git -C "$srcdir/blender" apply -v "${srcdir}"/embree.patch
+ git -C "$srcdir/blender" apply -v "$srcdir/cuda11.patch"
}
build() {
- mkdir -p "$srcdir/blender-build"
- cd "$srcdir/blender-build"
-
_pyver=$(python -c "from sys import version_info; print(\"%d.%d\" % (version_info[0],version_info[1]))")
msg "python version detected: ${_pyver}"
# determine whether we can precompile CUDA kernels
- _CUDA_PKG=`pacman -Qq cuda 2>/dev/null` || true
+ _CUDA_PKG=$(pacman -Qq cuda 2>/dev/null) || true
if [ "$_CUDA_PKG" != "" ] && ! ((DISABLE_CUDA)) ; then
- _EXTRAOPTS=( -DWITH_CYCLES_CUDA_BINARIES=ON
- -DCUDA_TOOLKIT_ROOT_DIR=/opt/cuda
- -DOPTIX_ROOT_DIR=/opt/optix )
- if [ -v _cuda_capability ]; then
- _EXTRAOPTS+=(-DCYCLES_CUDA_BINARIES_ARCH=$(IFS=';'; echo "${_cuda_capability[*]}";))
- fi
- [ -f "/usr/lib/ccache/bin/nvcc-ccache" ] && _CMAKE_FLAGS+=( -DCUDA_NVCC_EXECUTABLE=/usr/lib/ccache/bin/nvcc-ccache )
- if _cuda_gcc=$(basename $(readlink /opt/cuda/bin/gcc)) ; then
- [ -L "/usr/lib/ccache/bin/$_cuda_gcc" ] && _CMAKE_FLAGS+=( -DCUDA_HOST_COMPILER=/usr/lib/ccache/bin/$_cuda_gcc )
- fi
+ _CMAKE_FLAGS+=( -DWITH_CYCLES_CUDA_BINARIES=ON
+ -DCUDA_TOOLKIT_ROOT_DIR=/opt/cuda )
+ ((DISABLE_OPTIX)) || _CMAKE_FLAGS+=( -DOPTIX_ROOT_DIR=/opt/optix )
+ if [[ -v _cuda_capability ]]; then
+ _CMAKE_FLAGS+=( -DCYCLES_CUDA_BINARIES_ARCH="$(IFS=';'; echo "${_cuda_capability[*]}";)" )
+ fi
+ [ -f "/usr/lib/ccache/bin/nvcc-ccache" ] && _CMAKE_FLAGS+=( -DCUDA_NVCC_EXECUTABLE=/usr/lib/ccache/bin/nvcc-ccache )
+ if _cuda_gcc=$(basename "$(readlink /opt/cuda/bin/gcc)") ; then
+ [ -L "/usr/lib/ccache/bin/$_cuda_gcc" ] && _CMAKE_FLAGS+=( -DCUDA_HOST_COMPILER=/usr/lib/ccache/bin/"$_cuda_gcc" )
+ fi
fi
((DISABLE_NINJA)) && generator="Unix Makefiles" || generator="Ninja"
- cmake -G "$generator" "$srcdir/blender" \
- -C${srcdir}/blender/build_files/cmake/config/blender_release.cmake \
+ cmake -G "$generator" -S "$srcdir/blender" -B "$srcdir/build" \
+ -C "${srcdir}/blender/build_files/cmake/config/blender_release.cmake" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DWITH_INSTALL_PORTABLE=OFF \
-DWITH_SYSTEM_GLEW=ON \
-DWITH_PYTHON_INSTALL=OFF \
- -DPYTHON_VERSION=${_pyver} \
- ${_EXTRAOPTS[@]}
+ -DPYTHON_VERSION="${_pyver}" \
+ "${_CMAKE_FLAGS[@]}"
export NINJA_STATUS="[%p | %f<%r<%u | %cbps ] "
- ((DISABLE_NINJA)) && make || ninja $([ -v MAKEFLAGS ] || echo -j1) -d stats
+# shellcheck disable=SC2086 # allow MAKEFLAGS to split when multiple flags provided.
+ if ((DISABLE_NINJA)); then make -C "$srcdir/build" ; else ninja -C "$srcdir/build" ${MAKEFLAGS:--j1}; fi
}
package() {
- cd "$srcdir/blender-build"
- ((DISABLE_NINJA)) && make install DESTDIR="$pkgdir" || DESTDIR="$pkgdir" ninja install
-
- msg "add -${pkgver%%.r*} sufix to desktop shortcut"
- sed -i "s/=blender/=blender-${pkgver%%.r*}/g" ${pkgdir}/usr/share/applications/blender.desktop
- sed -i "s/=Blender/=Blender-${pkgver%%.r*}/g" ${pkgdir}/usr/share/applications/blender.desktop
- mv ${pkgdir}/usr/share/applications/blender.desktop ${pkgdir}/usr/share/applications/blender-${pkgver%%.r*}.desktop
+ _suffix=${pkgver%%.r*}
+ export DESTDIR="$pkgdir"
+ if ((DISABLE_NINJA)); then make -C "$srcdir/build" install; else ninja -C "$srcdir/build" install; fi
+
+ msg "add -${_suffix} suffix to desktop shortcut"
+ sed -i "s/=blender/=blender-${_suffix}/g" "${pkgdir}/usr/share/applications/blender.desktop"
+ sed -i "s/=Blender/=Blender-${_suffix}/g" "${pkgdir}/usr/share/applications/blender.desktop"
+ mv "${pkgdir}/usr/share/applications/blender.desktop" "${pkgdir}/usr/share/applications/blender-${_suffix}.desktop"
- msg "add -${pkgver%%.r*} sufix to binaries"
- mv ${pkgdir}/usr/bin/blender ${pkgdir}/usr/bin/blender-${pkgver%%.r*}
- mv ${pkgdir}/usr/bin/blender-thumbnailer.py ${pkgdir}/usr/bin/blender-${pkgver%%.r*}-thumbnailer.py
-# mv ${pkgdir}/usr/bin/blenderplayer ${pkgdir}/usr/bin/blenderplayer-${pkgver%%.r*}
+ msg "add -${_suffix} suffix to binaries"
+ mv "${pkgdir}/usr/bin/blender" "${pkgdir}/usr/bin/blender-${_suffix}"
+ mv "${pkgdir}/usr/bin/blender-thumbnailer.py" "${pkgdir}/usr/bin/blender-${_suffix}-thumbnailer.py"
- msg "mv doc/blender to doc/blender-${pkgver%%.r*}"
- mv ${pkgdir}/usr/share/doc/blender ${pkgdir}/usr/share/doc/blender-${pkgver%%.r*}
+ msg "mv doc/blender to doc/blender-${_suffix}"
+ mv "${pkgdir}/usr/share/doc/blender" "${pkgdir}/usr/share/doc/blender-${_suffix}"
- msg "add -${pkgver%%.r*} sufix to man page"
- mv ${pkgdir}/usr/share/man/man1/blender.1 ${pkgdir}/usr/share/man/man1/blender-${pkgver%%.r*}
+ msg "add -${_suffix} suffix to man page"
+ mv "${pkgdir}/usr/share/man/man1/blender.1" "${pkgdir}/usr/share/man/man1/blender-${_suffix}.1"
- msg "add -${pkgver%%.r*} sufix to all icons"
- for icon in `find ${pkgdir}/usr/share/icons -type f`
- do
- # ${filename##/*.} extra extenssion from path
- # ${filename%.*} extract filename form path
- # look at bash "manipulatin string"
- mv $icon ${icon%.*}-${pkgver%%.r*}.${icon##/*.}
- done
+ msg "add -${_suffix} suffix to all icons"
+ while read -r icon
+ do
+ # ${filename##/*.} extra extenssion from path
+ # ${filename%.*} extract filename form path
+ # look at bash "manipulatin string"
+ mv "$icon" "${icon%.*}-${_suffix}.${icon##/*.}"
+ done < <(find "${pkgdir}/usr/share/icons" -type f)
- if [ -e "$pkgdir"/usr/share/blender/*/scripts/addons/cycles/lib/ ] ; then
+ if [[ -e "$pkgdir/usr/share/blender/${_suffix}/scripts/addons/cycles/lib/" ]] ; then
# make sure the cuda kernels are not stripped
- chmod 444 "$pkgdir"/usr/share/blender/*/scripts/addons/cycles/lib/*
+ chmod 444 "$pkgdir"/usr/share/blender/${_suffix}/scripts/addons/cycles/lib/*
fi
}
# vim:set sw=2 ts=2 et:
diff --git a/blender-2.8.desktop b/blender-2.8.desktop
deleted file mode 100644
index 388688ba0de0..000000000000
--- a/blender-2.8.desktop
+++ /dev/null
@@ -1,14 +0,0 @@
-[Desktop Entry]
-Name=Blender-git
-Comment=A 3D program
-Comment[cs]=Program pro 3D modeling a animaci
-Comment[es]=Un programa de 3D
-Comment[no]=Et 3d-program
-Comment[da]=Et program til 3d-modelering
-Exec=blender-2.8
-Icon=blender-2.8
-Terminal=false
-X-MultipleArgs=false
-Type=Application
-Categories=Graphics;3DGraphics;
-MimeType=application/blender;application/x-blender;
diff --git a/blender.install b/blender.install
deleted file mode 100644
index d061748130f3..000000000000
--- a/blender.install
+++ /dev/null
@@ -1,14 +0,0 @@
-
-post_install() {
- update-desktop-database -q
- gtk-update-icon-cache -qf /usr/share/icons/hicolor/
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install $1
-}
-
diff --git a/cuda11.patch b/cuda11.patch
new file mode 100644
index 000000000000..e06ec9a39a72
--- /dev/null
+++ b/cuda11.patch
@@ -0,0 +1,64 @@
+From a9644c812fc17b38503828d6edf7d259b6fe0e74 Mon Sep 17 00:00:00 2001
+From: Patrick Mours <pmours@nvidia.com>
+Date: Fri, 17 Jul 2020 15:06:55 +0200
+Subject: [PATCH] Cycles: Use pre-compiled PTX kernel for older generation when
+ no matching one is found
+
+This patch changes the discovery of pre-compiled kernels, to look for any PTX, even if
+it does not match the current architecture version exactly. It works because the driver can
+JIT-compile PTX generated for architectures less than or equal to the current one.
+This e.g. makes it possible to render on a new GPU architecture even if no pre-compiled
+binary kernel was distributed for it as part of the Blender installation.
+
+Reviewed By: brecht
+
+Differential Revision: https://developer.blender.org/D8332
+---
+ CMakeLists.txt | 2 +-
+ .../cmake/config/blender_release.cmake | 2 +-
+ .../cycles/device/cuda/device_cuda_impl.cpp | 23 +++++++++++++++----
+ intern/cycles/kernel/CMakeLists.txt | 4 ++--
+ 4 files changed, 22 insertions(+), 9 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 49b974596f7..cc0e5a2491f 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -367,7 +367,7 @@ option(WITH_CYCLES_CUDA_BINARIES "Build Cycles CUDA binaries" OFF)
+ option(WITH_CYCLES_CUBIN_COMPILER "Build cubins with nvrtc based compiler instead of nvcc" OFF)
+ option(WITH_CYCLES_CUDA_BUILD_SERIAL "Build cubins one after another (useful on machines with limited RAM)" OFF)
+ mark_as_advanced(WITH_CYCLES_CUDA_BUILD_SERIAL)
+-set(CYCLES_CUDA_BINARIES_ARCH sm_30 sm_35 sm_37 sm_50 sm_52 sm_60 sm_61 sm_70 sm_75 CACHE STRING "CUDA architectures to build binaries for")
++set(CYCLES_CUDA_BINARIES_ARCH sm_30 sm_35 sm_37 sm_50 sm_52 sm_60 sm_61 sm_70 sm_75 compute_75 CACHE STRING "CUDA architectures to build binaries for")
+ mark_as_advanced(CYCLES_CUDA_BINARIES_ARCH)
+ unset(PLATFORM_DEFAULT)
+ option(WITH_CYCLES_LOGGING "Build Cycles with logging support" ON)
+diff --git a/build_files/cmake/config/blender_release.cmake b/build_files/cmake/config/blender_release.cmake
+index 5fce64ce719..e6fc73a75ed 100644
+--- a/build_files/cmake/config/blender_release.cmake
++++ b/build_files/cmake/config/blender_release.cmake
+@@ -53,7 +53,7 @@ set(WITH_USD ON CACHE BOOL "" FORCE)
+ set(WITH_MEM_JEMALLOC ON CACHE BOOL "" FORCE)
+ set(WITH_CYCLES_CUDA_BINARIES ON CACHE BOOL "" FORCE)
+ set(WITH_CYCLES_CUBIN_COMPILER OFF CACHE BOOL "" FORCE)
+-set(CYCLES_CUDA_BINARIES_ARCH sm_30;sm_35;sm_37;sm_50;sm_52;sm_60;sm_61;sm_70;sm_75 CACHE STRING "" FORCE)
++set(CYCLES_CUDA_BINARIES_ARCH sm_30;sm_35;sm_37;sm_50;sm_52;sm_60;sm_61;sm_70;sm_75;compute_75 CACHE STRING "" FORCE)
+ set(WITH_CYCLES_DEVICE_OPTIX ON CACHE BOOL "" FORCE)
+
+ # platform dependent options
+diff --git a/intern/cycles/kernel/CMakeLists.txt b/intern/cycles/kernel/CMakeLists.txt
+index 782553e405c..6f139c44b6c 100644
+--- a/intern/cycles/kernel/CMakeLists.txt
++++ b/intern/cycles/kernel/CMakeLists.txt
+@@ -495,7 +495,7 @@ if(WITH_CYCLES_DEVICE_OPTIX)
+ -I "${OPTIX_INCLUDE_DIR}"
+ -I "${CMAKE_CURRENT_SOURCE_DIR}/.."
+ -I "${CMAKE_CURRENT_SOURCE_DIR}/kernels/cuda"
+- -arch=sm_30
++ -arch=sm_50
+ --use_fast_math
+ -o ${output})
+
+--
+2.27.0
+
diff --git a/embree.patch b/embree.patch
new file mode 100644
index 000000000000..bed0b39e744c
--- /dev/null
+++ b/embree.patch
@@ -0,0 +1,43 @@
+diff --git a/intern/cycles/blender/CMakeLists.txt b/intern/cycles/blender/CMakeLists.txt
+index d9a2ebf8571..f3b7d156024 100644
+--- a/intern/cycles/blender/CMakeLists.txt
++++ b/intern/cycles/blender/CMakeLists.txt
+@@ -66,6 +66,12 @@ if(WITH_CYCLES_LOGGING)
+ )
+ endif()
+
++if(WITH_CYCLES_EMBREE)
++ list(APPEND LIB
++ ${EMBREE_LIBRARIES}
++ )
++endif()
++
+ set(ADDON_FILES
+ addon/__init__.py
+ addon/engine.py
+diff --git a/build_files/cmake/Modules/FindEmbree.cmake b/build_files/cmake/Modules/FindEmbree.cmake
+index d9d525d4586..03b509a28f3 100644
+--- a/build_files/cmake/Modules/FindEmbree.cmake
++++ b/build_files/cmake/Modules/FindEmbree.cmake
+@@ -72,7 +72,7 @@ ENDFOREACH()
+
+ FIND_LIBRARY(EMBREE_LIBRARY
+ NAMES
+- libembree3
++ embree3
+ HINTS
+ ${_embree_SEARCH_DIRS}
+ PATH_SUFFIXES
+@@ -83,10 +83,10 @@ FIND_LIBRARY(EMBREE_LIBRARY
+ # all listed variables are TRUE
+ INCLUDE(FindPackageHandleStandardArgs)
+ FIND_PACKAGE_HANDLE_STANDARD_ARGS(EMBREE DEFAULT_MSG
+- _embree_LIBRARIES EMBREE_INCLUDE_DIR)
++ EMBREE_LIBRARY EMBREE_INCLUDE_DIR)
+
+ IF(EMBREE_FOUND)
+- SET(EMBREE_LIBRARIES ${_embree_LIBRARIES})
++ SET(EMBREE_LIBRARIES ${EMBREE_LIBRARY})
+ SET(EMBREE_INCLUDE_DIRS ${EMBREE_INCLUDE_DIR})
+ ENDIF(EMBREE_FOUND)
+