aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2020-09-01 21:14:16 +0200
committerbartus2020-09-02 09:29:34 +0200
commitb01d3a5eb84cfad8a40b12e2dca0feccd8ad1964 (patch)
treecd9e72457a695753baf42a542f62e5aaf299446e
parent0446014062b6e49bf2fbdc458a90eb7420db4e0f (diff)
downloadaur-b01d3a5eb84cfad8a40b12e2dca0feccd8ad1964.tar.gz
Fix gcc10 build, refactor.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD21
-rw-r--r--blender.changelog102
3 files changed, 121 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 412553416852..a659092c8311 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = blender-2.81-git
- pkgdesc = Maintenance version of Blender 2.81-release branch
+ pkgdesc = Maintenance version of blender-v2.81-release branch
pkgver = 2.81.r91465.gf1aa4d18d49
pkgrel = 1
url = https://blender.org/
+ changelog = blender.changelog
arch = i686
arch = x86_64
license = GPL
@@ -43,6 +44,7 @@ pkgbase = blender-2.81-git
source = SelectCudaComputeArch.patch
source = embree.patch
source = cuda11.patch
+ source = cpp14.patch::https://git.blender.org/gitweb/gitweb.cgi/blender.git/patch/171c4fb238a2a65291540ac5406187bc69f3a6bc
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -51,6 +53,7 @@ pkgbase = blender-2.81-git
sha256sums = 66b9bf3db441f35119ef0eb5f855142f2e773e8002ac0216e056bcc6f8ac409c
sha256sums = 42afe119529a5350034a489225958112bf4b84bdee38757a932e5caaa9bd5ed4
sha256sums = 0316d92f180f2fa428a206074bd5adfd30968f9ae5d308efea05e42741dd53fd
+ sha256sums = 44fad9ac2320d20d21b7aef46f70c05d55697ecde1446513f0a5842014a9d99c
pkgname = blender-2.81-git
diff --git a/PKGBUILD b/PKGBUILD
index a3073f688aff..f049cd2e609b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,9 @@
# shellcheck disable=SC2191 # preserve current _CMAKE_FLAGS initialization.
# Configuration.
-_fragment=${FRAGMENT:-#branch=blender-v2.81-release}
+_blenver="2.81"
+_branch="blender-v${_blenver}-release"
+_fragment=${FRAGMENT:-#branch=${_branch}}
[[ -v CUDA_ARCH ]] && _cuda_capability=${CUDA_ARCH}
#some extra, unofficially supported stuff goes here:
@@ -21,7 +23,8 @@ _CMAKE_FLAGS+=( -DWITH_ALEMBIC_HDF5=ON )
pkgname=blender-2.81-git
pkgver=2.81.r91465.gf1aa4d18d49
pkgrel=1
-pkgdesc="Maintenance version of Blender 2.81-release branch"
+pkgdesc="Maintenance version of ${_branch} branch"
+changelog=blender.changelog
arch=('i686' 'x86_64')
url="https://blender.org/"
depends+=('alembic' 'libgl' 'python' 'python-numpy' 'openjpeg2'
@@ -29,8 +32,8 @@ depends+=('alembic' 'libgl' 'python' 'python-numpy' 'openjpeg2'
'openvdb' 'opencollada' 'opensubdiv' 'openshadinglanguage' 'libtiff' 'libpng')
depends+=('openimagedenoise')
makedepends+=('git' 'cmake' 'boost' 'mesa' 'llvm')
-provides=("blender=${pkgver%%.r*}")
-conflicts=("blender=${pkgver%%.r*}")
+provides=("blender=${_blenver}")
+conflicts=("blender=${_blenver}")
license=('GPL')
# NOTE: the source array has to be kept in sync with .gitmodules
# the submodules has to be stored in path ending with git to match
@@ -45,6 +48,7 @@ source=("git://git.blender.org/blender.git${_fragment}"
SelectCudaComputeArch.patch
embree.patch #add missing embree link.
'cuda11.patch'
+ 'cpp14.patch::https://git.blender.org/gitweb/gitweb.cgi/blender.git/patch/171c4fb238a2a65291540ac5406187bc69f3a6bc'
)
sha256sums=('SKIP'
'SKIP'
@@ -53,7 +57,8 @@ sha256sums=('SKIP'
'SKIP'
'66b9bf3db441f35119ef0eb5f855142f2e773e8002ac0216e056bcc6f8ac409c'
'42afe119529a5350034a489225958112bf4b84bdee38757a932e5caaa9bd5ed4'
- '0316d92f180f2fa428a206074bd5adfd30968f9ae5d308efea05e42741dd53fd')
+ '0316d92f180f2fa428a206074bd5adfd30968f9ae5d308efea05e42741dd53fd'
+ '44fad9ac2320d20d21b7aef46f70c05d55697ecde1446513f0a5842014a9d99c')
pkgver() {
blender_version=$(grep -Po "BLENDER_VERSION \K[0-9]{3}" "$srcdir"/blender/source/blender/blenkernel/BKE_blender_version.h)
@@ -70,8 +75,12 @@ prepare() {
if [ ! -v _cuda_capability ] && grep -q nvidia <(lsmod); then
git -C "$srcdir/blender" apply -v "${srcdir}"/SelectCudaComputeArch.patch
fi
+ if [[ -v _suffix ]]; then
+ git -C "$srcdir/blender" apply -v <(sed "s/@@_suffix@@/${_suffix}/g" "${srcdir}/addon_path.patch")
+ fi
((DISABLE_EMBREE)) || git -C "$srcdir/blender" apply -v "${srcdir}"/embree.patch
git -C "$srcdir/blender" apply -v "$srcdir/cuda11.patch"
+ git -C "$srcdir/blender" apply -v "$srcdir/cpp14.patch"
}
build() {
@@ -109,7 +118,7 @@ build() {
}
package() {
- _suffix=${pkgver%%.r*}
+ local _suffix=${_blenver}${_suffix:+_$_suffix}
export DESTDIR="$pkgdir"
if ((DISABLE_NINJA)); then make -C "$srcdir/build" install; else ninja -C "$srcdir/build" install; fi
diff --git a/blender.changelog b/blender.changelog
new file mode 100644
index 000000000000..e23436e473f7
--- /dev/null
+++ b/blender.changelog
@@ -0,0 +1,102 @@
+# Version 2.81
+[release notes](https://wiki.blender.org/wiki/Reference/Release_Notes/2.81)
+- Cycles: Nvidia Optix [task](https://developer.blender.org/T69800)
+- Cycles: Intel Oidn [diff](https://developer.blender.org/D4304)
+- Cycles: Osd edge stitching.
+- Cycles: Viewport render passes.
+- Shading: 4D noises.
+- Shading: vertex color.
+- Shading: volume info.
+- Eevee: Shadow refactor [diff](https://developer.blender.org/D5659).
+- Eevee: Transparent BSDF congruent to Cycles.
+- Eevee: Holdout shader.
+- Viewport: HDRI studio light.
+- Viewport: per viewport visibility selection [task](https://developer.blender.org/T61327).
+- Viewport: OpenEXR matcaps with separate diffuse/specular layers.
+- Grease Pencil: Self overlapping material.
+- Grease Pencil: Smooth stroke endings.
+- Grease Pencil: New brushes.
+- Grease Pencil: New snapping.
+- Grease Pencil: New stroke form curve.
+- Grease Pencil: New merge by distance.
+- Grease Pencil: New simplify sample.
+- Sculpting: Pose brush [diff](https://developer.blender.org/D5647).
+- Sculpting: Transform around pivot with symmetry.
+- Sculpting: Draw sharp brush.
+- Sculpting: Cursor follow normal and shows symmetry.
+- Sculpting: Stroke point even distance.
+- Sculpting: Auto-masking.
+- Sculpting: Dynamic mesh preview.
+- Sculpting: Mask Filter.
+- Sculpting: Dirty Mask.
+- Sculpting: Mask expand with curvature limits.
+- Sculpting: Mask to object.
+- Sculpting: Voxel remesher [diff](https://developer.blender.org/D5407).
+- Sculpting: [QuadriFlow](https://github.com/hjwdzh/QuadriFlow) remesher.
+- UI: <f2> - rename active element.
+- UI: <c-f2> - Batch rename.
+- UI: Parent dnd for multiple objects.
+- UI: Selection sync.
+- UI: New pop-up file browser.
+- UI: Industry compatible key map.
+- Blenlib: New library override [task](https://developer.blender.org/T53500).
+- Animation: Copy as new driver.
+
+# Version 2.80
+[release notes](https://wiki.blender.org/wiki/Reference/Release_Notes/2.80)
+- UI: New collection system in place of layers.
+- UI: New outliner.
+- UI: New view layers in palace of render layers.
+- UI: Blender default key map.
+- UI: Left click select new default.
+- UI: Re-theme.
+- UI: <q> - context quick favorite.
+- UI: New file UI templates.
+- UI: New workspaces.
+- UI: New object gizmos.
+- UI: New tools with gizmos.
+- UI: New context status bar.
+- UI: Single column layout.
+- UI: New pop overs.
+- UI: New pie menus.
+- Eevee: Principled BSDF.
+- Eevee: Env lightning with HDRI.
+- Eevee: Screen-space reflection and refraction.
+- Eevee: Indirect lighting with light probes.
+- Eevee: Soft and contact shadows.
+- Eevee: SSS and volume rendering.
+- Eevee: Dof, bloom, motion blur for camera.
+- Eevee: Shader to RGB node.
+- Eevee: Light probes.
+- Eevee: Light cache.
+- Eevee: Ground truth ambient occlusion.
+- Viewport: Workbench engine.
+- Viewport: Overlays.
+- Viewport: Look dev - material preview.
+- Viewport: Volume preview.
+- Grease Pencil: New 2d Animation.
+- Cycles: Principled hair BSDF [doc](https://docs.blender.org/manual/en/2.80/render/shader_nodes/shader/hair_principled.html).
+- Cycles: Principled volume [doc](https://docs.blender.org/manual/en/2.80/render/shader_nodes/shader/volume_principled.html).
+- Cycles: Cryptomate.
+- Cycles: Random walk SSS.
+- Cycles: Vector Displacement.
+- Cycles: New adaptive subdivision dicing scheme.
+- Cycles: Bevel shader.
+- Cycles: AO shader.
+- Cycles: IES light node.
+- Cycles: New baking anti aliasing.
+- Cycles: New area light shapes.
+- Cycles: Transparent film rendering for glass.
+- Cycles: Motion blur arbitrary sample count.
+- Cycles: Combined CPU and GPU rendering.
+- Cycles: CUDA small tiles optimization.
+- Cycles: CUDA object streaming for out of gRAM rendering.
+- Cycles: CUDA minimum version bump to 3.x
+- Mesh: New multi object editing.
+- Mesh: Custom normal maps.
+- Animation: Pop over driver editor.
+- Blenlib: New dependency graph for parallelization.
+- Blenlib: New unit system.
+- Physics: New cloth bending springs.
+- Physics: New cloth collisions.
+