aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2019-10-22 14:05:15 +0200
committerbartus2019-10-22 14:05:15 +0200
commit2d1cfa0a430e86ce62ee9c320248cf046e6e4705 (patch)
tree4f0e16ba73ad3534fa526f86335f2f2050721777
parent4733234d1902246f62aae712819b294ad5f6e689 (diff)
downloadaur-2d1cfa0a430e86ce62ee9c320248cf046e6e4705.tar.gz
Remove old patches.
-rw-r--r--SelectCudaComputeArch.cmake.patch17
-rw-r--r--ffmpeg.patch39
2 files changed, 0 insertions, 56 deletions
diff --git a/SelectCudaComputeArch.cmake.patch b/SelectCudaComputeArch.cmake.patch
deleted file mode 100644
index 94139e29da66..000000000000
--- a/SelectCudaComputeArch.cmake.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/intern/cycles/cmake/external_libs.cmake b/intern/cycles/cmake/external_libs.cmake
-index df88b91f5ac..4b3335122b2 100644
---- a/intern/cycles/cmake/external_libs.cmake
-+++ b/intern/cycles/cmake/external_libs.cmake
-@@ -41,6 +41,13 @@ if(WITH_CYCLES_CUDA_BINARIES OR NOT WITH_CUDA_DYNLOAD)
- find_package(CUDA) # Try to auto locate CUDA toolkit
- if(CUDA_FOUND)
- message(STATUS "CUDA nvcc = ${CUDA_NVCC_EXECUTABLE}")
-+
-+ CUDA_SELECT_NVCC_ARCH_FLAGS(CUDA_ARCH_FLAGS Auto)
-+ set(CYCLES_CUDA_BINARIES_ARCH "${CUDA_ARCH_FLAGS_readable}")
-+ message(STATUS "Enabling CUDA support (version: ${CUDA_VERSION_STRING},"
-+ " archs: ${CUDA_ARCH_FLAGS_readable})")
-+
- else()
- message(STATUS "CUDA compiler not found, disabling WITH_CYCLES_CUDA_BINARIES")
- set(WITH_CYCLES_CUDA_BINARIES OFF)
diff --git a/ffmpeg.patch b/ffmpeg.patch
deleted file mode 100644
index 94ffa7eba914..000000000000
--- a/ffmpeg.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff --git a/extern/audaspace/CMakeLists.txt b/extern/audaspace/CMakeLists.txt
-index 9e2921ef35a..67f8ada7802 100644
---- a/extern/audaspace/CMakeLists.txt
-+++ b/extern/audaspace/CMakeLists.txt
-@@ -412,6 +412,10 @@ if(WITH_FFMPEG)
- plugins/ffmpeg/FFMPEGWriter.h
- )
-
-+ list(APPEND INC
-+ ../../intern/ffmpeg
-+ )
-+
- if(NOT PLUGIN_FFMPEG)
- list(APPEND INCLUDE ${FFMPEG_INCLUDE_DIRS})
- list(APPEND LIBRARIES ${FFMPEG_LIBRARIES})
-diff --git a/extern/audaspace/plugins/ffmpeg/FFMPEGReader.cpp b/extern/audaspace/plugins/ffmpeg/FFMPEGReader.cpp
-index 6b79cc5abfd..5e9ec29f302 100644
---- a/extern/audaspace/plugins/ffmpeg/FFMPEGReader.cpp
-+++ b/extern/audaspace/plugins/ffmpeg/FFMPEGReader.cpp
-@@ -16,6 +16,7 @@
-
- #include "FFMPEGReader.h"
- #include "Exception.h"
-+#include "../../../../intern/ffmpeg/ffmpeg_compat.h"
-
- #include <algorithm>
-
-diff --git a/extern/audaspace/plugins/ffmpeg/FFMPEGWriter.cpp b/extern/audaspace/plugins/ffmpeg/FFMPEGWriter.cpp
-index f79f0f7fc6b..6b89a83613c 100644
---- a/extern/audaspace/plugins/ffmpeg/FFMPEGWriter.cpp
-+++ b/extern/audaspace/plugins/ffmpeg/FFMPEGWriter.cpp
-@@ -16,6 +16,7 @@
-
- #include "FFMPEGWriter.h"
- #include "Exception.h"
-+#include "../../../../intern/ffmpeg/ffmpeg_compat.h"
-
- #include <algorithm>
- #include <cstring>