aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2020-07-23 11:29:07 +0200
committerbartus2020-07-23 11:29:07 +0200
commit5b59f0e6cdbed799d75c4e71fb74ba67fe1b3353 (patch)
tree309e230fb9e36b1d244803bcb9f7c76b47cadaee
parentf02fa8a6907d3de7b904351ba8c2e621aa575513 (diff)
downloadaur-5b59f0e6cdbed799d75c4e71fb74ba67fe1b3353.tar.gz
Refactor: remove `mkdir` use `$()`
-rw-r--r--PKGBUILD4
1 files changed, 1 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 50ccfd6b7f21..f922cb812523 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -81,13 +81,11 @@ prepare() {
}
build() {
- mkdir -p "$srcdir/build"
-
_pyver=$(python -c "from sys import version_info; print(\"%d.%d\" % (version_info[0],version_info[1]))")
msg "python version detected: ${_pyver}"
# determine whether we can precompile CUDA kernels
- _CUDA_PKG=`pacman -Qq cuda 2>/dev/null` || true
+ _CUDA_PKG=$(pacman -Qq cuda 2>/dev/null) || true
if [ "$_CUDA_PKG" != "" ] && ! ((DISABLE_CUDA)) ; then
_CMAKE_FLAGS+=( -DWITH_CYCLES_CUDA_BINARIES=ON
-DCUDA_TOOLKIT_ROOT_DIR=/opt/cuda )