aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-05-02 11:01:13 +0200
committerbartus2021-05-02 11:01:13 +0200
commita41dbc41806efd90a2d9b0ce1cc83b22f55bc0df (patch)
tree61f734b251eae246150aa5b16d082a15a1c6a715
parent0a00763c17b4535fff5a8488bd864856025c77b0 (diff)
downloadaur-a41dbc41806efd90a2d9b0ce1cc83b22f55bc0df.tar.gz
Fix build against openexr:3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--openexr3.patch42
3 files changed, 52 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0bf973ebe185..8a6c8b1fceb6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = blender-develop-git
pkgdesc = Development version of Blender (non-conflicting version)
- pkgver = 2.93.r105258.gd63b72e9f93
+ pkgver = 3.0.r105731.gecc7a837982
pkgrel = 1
url = https://blender.org/
changelog = blender.changelog
@@ -37,8 +37,8 @@ pkgbase = blender-develop-git
depends = libpng
depends = openimagedenoise
optdepends = cuda: CUDA support in Cycles
- provides = blender=2.93
- conflicts = blender=2.93
+ provides = blender=3.0
+ conflicts = blender=3.0
source = git://git.blender.org/blender.git#branch=master
source = blender-addons.git::git://git.blender.org/blender-addons.git
source = blender-addons-contrib.git::git://git.blender.org/blender-addons-contrib.git
@@ -47,6 +47,7 @@ pkgbase = blender-develop-git
source = SelectCudaComputeArch.patch
source = usd_python.patch
source = embree.patch
+ source = openexr3.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -55,6 +56,7 @@ pkgbase = blender-develop-git
sha256sums = 66b9bf3db441f35119ef0eb5f855142f2e773e8002ac0216e056bcc6f8ac409c
sha256sums = 333b6fd864d55da2077bc85c55af1a27d4aee9764a1a839df26873a9f19b8703
sha256sums = 6249892f99ffd960e36f43fb893c14e2f8e4dd1d901b9581d25882e865f2603f
+ sha256sums = 5297dc61cc4edcc1d5bad3474ab882264b69d68036cebbd0f2600d9fe21d5a1b
pkgname = blender-develop-git
diff --git a/PKGBUILD b/PKGBUILD
index 878248e8723d..33501fff5a17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,7 +26,7 @@ _CMAKE_FLAGS+=( -DOSL_ROOT_DIR=/opt/osl
((DISABLE_CUDA)) && optdepends+=('cuda: CUDA support in Cycles') || { makedepends+=('cuda') ; ((DISABLE_OPTIX)) || makedepends+=('optix>=7.0'); }
pkgname=blender-develop-git
-pkgver=2.93.r105258.gd63b72e9f93
+pkgver=3.0.r105731.gecc7a837982
pkgrel=1
pkgdesc="Development version of Blender (non-conflicting version)"
changelog=blender.changelog
@@ -53,6 +53,7 @@ source=("git://git.blender.org/blender.git${_fragment}"
SelectCudaComputeArch.patch
usd_python.patch #add missing python headers when building against python enabled usd.
embree.patch #add missing embree link.
+ openexr3.patch #fix build against openexr:3
)
sha256sums=('SKIP'
'SKIP'
@@ -61,7 +62,8 @@ sha256sums=('SKIP'
'SKIP'
'66b9bf3db441f35119ef0eb5f855142f2e773e8002ac0216e056bcc6f8ac409c'
'333b6fd864d55da2077bc85c55af1a27d4aee9764a1a839df26873a9f19b8703'
- '6249892f99ffd960e36f43fb893c14e2f8e4dd1d901b9581d25882e865f2603f')
+ '6249892f99ffd960e36f43fb893c14e2f8e4dd1d901b9581d25882e865f2603f'
+ '5297dc61cc4edcc1d5bad3474ab882264b69d68036cebbd0f2600d9fe21d5a1b')
pkgver() {
blender_version=$(grep -Po "BLENDER_VERSION \K[0-9]{3}" "$srcdir"/blender/source/blender/blenkernel/BKE_blender_version.h)
@@ -79,7 +81,7 @@ prepare() {
git -C "$srcdir/blender" apply -v "${srcdir}"/SelectCudaComputeArch.patch
fi
((DISABLE_USD)) || git -C "$srcdir/blender" apply -v "${srcdir}"/usd_python.patch
- git -C "$srcdir/blender" apply -v "${srcdir}"/embree.patch
+ git -C "$srcdir/blender" apply -v "${srcdir}"/{embree,openexr3}.patch
}
build() {
diff --git a/openexr3.patch b/openexr3.patch
new file mode 100644
index 000000000000..73a727a3dbc9
--- /dev/null
+++ b/openexr3.patch
@@ -0,0 +1,42 @@
+diff --git a/build_files/cmake/Modules/FindOpenEXR.cmake b/build_files/cmake/Modules/FindOpenEXR.cmake
+index 090f80b8df7..a2f7b4c622b 100644
+--- a/build_files/cmake/Modules/FindOpenEXR.cmake
++++ b/build_files/cmake/Modules/FindOpenEXR.cmake
+@@ -34,11 +34,10 @@ ENDIF()
+ SET(_openexr_libs_ver_init "2.0")
+
+ SET(_openexr_FIND_COMPONENTS
+- Half
+ Iex
+- IlmImf
+- IlmThread
+ Imath
++ OpenEXR
++ IlmThread
+ )
+
+ SET(_openexr_SEARCH_DIRS
+@@ -120,7 +119,7 @@ FIND_PACKAGE_HANDLE_STANDARD_ARGS(OpenEXR DEFAULT_MSG
+ IF(OPENEXR_FOUND)
+ SET(OPENEXR_LIBRARIES ${_openexr_LIBRARIES})
+ # Both include paths are needed because of dummy OSL headers mixing #include <OpenEXR/foo.h> and #include <foo.h> :(
+- SET(OPENEXR_INCLUDE_DIRS ${OPENEXR_INCLUDE_DIR} ${OPENEXR_INCLUDE_DIR}/OpenEXR)
++ SET(OPENEXR_INCLUDE_DIRS ${OPENEXR_INCLUDE_DIR} ${OPENEXR_INCLUDE_DIR}/OpenEXR ${OPENEXR_INCLUDE_DIR}/Imath)
+ ENDIF()
+
+ MARK_AS_ADVANCED(
+diff --git a/source/blender/imbuf/intern/openexr/openexr_api.cpp b/source/blender/imbuf/intern/openexr/openexr_api.cpp
+index 382d86f2645..eff50b19c31 100644
+--- a/source/blender/imbuf/intern/openexr/openexr_api.cpp
++++ b/source/blender/imbuf/intern/openexr/openexr_api.cpp
+@@ -38,8 +38,10 @@
+ #include <ImfChannelList.h>
+ #include <ImfCompression.h>
+ #include <ImfCompressionAttribute.h>
++#include <ImfFrameBuffer.h>
+ #include <ImfIO.h>
+ #include <ImfInputFile.h>
++#include <ImfInt64.h>
+ #include <ImfOutputFile.h>
+ #include <ImfPixelType.h>
+ #include <ImfStandardAttributes.h>