aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2020-04-16 09:42:10 +0200
committerbartus2020-04-16 09:42:10 +0200
commite6a9ad79f83a1ac24e2a23f9b0f91392aeaa611e (patch)
treecb354b4cb322689e2a4cd82fa054ad0c14080226
parentce45b4b7d20fa119bcce26e901003200f0f1c59f (diff)
downloadaur-e6a9ad79f83a1ac24e2a23f9b0f91392aeaa611e.tar.gz
Fix DISABLE_CUDA=1 when cuda is installed.
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 19f998a88ba8..85734f4af893 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -89,7 +89,8 @@ build() {
msg "python version detected: ${_pyver}"
# determine whether we can precompile CUDA kernels
- if pacman -Qq cuda 2>&- ; then
+ _CUDA_PKG=`pacman -Qq cuda 2>/dev/null` || true
+ if [ "$_CUDA_PKG" != "" ] && ! ((DISABLE_CUDA)) ; then
_CMAKE_FLAGS+=( -DWITH_CYCLES_CUDA_BINARIES=ON
-DCUDA_TOOLKIT_ROOT_DIR=/opt/cuda )
((DISABLE_OPTIX)) || _CMAKE_FLAGS+=( -DOPTIX_ROOT_DIR=/opt/optix )