summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefanos Carlström2019-08-26 11:27:55 +0200
committerStefanos Carlström2019-08-26 11:27:55 +0200
commit992c94c439cadd8b43739e12229b4894eaed8d17 (patch)
treec6f383f63fb32b6505f2bb91bd72fad8fcfe6c9f
parent24c51d83813e69362bdb3e96a735c9d4cc91b760 (diff)
downloadaur-992c94c439cadd8b43739e12229b4894eaed8d17.tar.gz
Update to v2.80
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD103
2 files changed, 38 insertions, 90 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67ab79135413..dfedf87b2134 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = blender-as-py-module
pkgdesc = A fully integrated 3D graphics creation suite, to be used as Python module. Useful for programmatic/batch rendering.
- pkgver = 2.78.a
+ pkgver = 2.80
pkgrel = 1
url = http://www.blender.org
- arch = i686
arch = x86_64
license = GPL
makedepends = cmake
makedepends = boost
makedepends = mesa
makedepends = git
- makedepends = llvm35
+ makedepends = llvm
makedepends = cuda
+ makedepends = ninja
depends = libpng
depends = libtiff
depends = openexr
@@ -23,18 +23,15 @@ pkgbase = blender-as-py-module
depends = xdg-utils
depends = glew
depends = openjpeg
+ depends = python-numpy
depends = freetype2
- depends = fftw
depends = boost-libs
- depends = opencollada
depends = openimageio
depends = opencolorio
depends = openshadinglanguage
- depends = jemalloc
depends = libspnav
depends = ptex
depends = opensubdiv
- depends = openvdb
depends = log4cplus
optdepends = cuda: cycles renderer cuda support
options = !strip
@@ -42,14 +39,12 @@ pkgbase = blender-as-py-module
source = git://git.blender.org/blender-addons-contrib.git
source = git://git.blender.org/blender-translations.git
source = git://git.blender.org/blender-dev-tools.git
- source = git://git.blender.org/scons.git
- source = blender-as-py-module-2.78.a::git://git.blender.org/blender.git#commit=e8299c81006aba1e4b926c24276ce09d70435371
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
+ source = blender-as-py-module-2.80::git://git.blender.org/blender.git#tag=v2.80
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
pkgname = blender-as-py-module
diff --git a/PKGBUILD b/PKGBUILD
index de8315d34c2e..5970d66801a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,58 +1,37 @@
-# Maintainer: Stefanos Carlström <stefanos.carlstrom@gmail.com>
-# Based off of main Blender PKGBUILD by
-# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
-# Contributor: John Sowiak <john@archlinux.org>
-# Contributor: tobias <tobias@archlinux.org>
-
-# See
-# https://wiki.blender.org/index.php/User%3aIdeasman42/BlenderAsPyModule
-# for details.
-
-# Comment from main PKGBUILD:
-# Sometimes blender.org takes some time to release patch releases and because Arch users
-# are impatient, we sometimes need to build from git directly.
-# Update because I get so many queries on this:
-# Due to our other rolling deps, it's sometimes not possible to build Blender stable releases.
-# More often than not, a new openshadinglanguage breaks it and I could either backport fixes
-# or simply roll with a new version. I usually choose the latter when the former seems
-# unreasonable.
-
-#_gittag=v2.78
-_gitcommit=e8299c81006aba1e4b926c24276ce09d70435371
+_gittag=v2.80
+# _gitcommit=054dbb833e15275e0e991e2c15e754a3e7583716
pkgname=blender-as-py-module
-pkgver=2.78.a
-#[[ -n $_gitcommit ]] && pkgver=${pkgver}.git1.${_gitcommit}
+pkgver=2.80
+[[ -n $_gitcommit ]] && pkgver=${pkgver}.git1.${_gitcommit:0:8}
pkgrel=1
pkgdesc="A fully integrated 3D graphics creation suite, to be used as Python module. Useful for programmatic/batch rendering."
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('GPL')
url="http://www.blender.org"
-depends=('libpng' 'libtiff' 'openexr' 'python' 'desktop-file-utils' 'python-requests'
- 'shared-mime-info' 'hicolor-icon-theme' 'xdg-utils' 'glew' 'openjpeg'
- 'freetype2' 'fftw' 'boost-libs' 'opencollada'
- 'openimageio' 'opencolorio' 'openshadinglanguage'
- 'jemalloc' 'libspnav' 'ptex' 'opensubdiv' 'openvdb' 'log4cplus')
-makedepends=('cmake' 'boost' 'mesa' 'git' 'llvm35')
-makedepends_x86_64=('cuda')
+depends=('libpng' 'libtiff' 'openexr' 'python' 'desktop-file-utils'
+ 'python-requests' 'shared-mime-info' 'hicolor-icon-theme'
+ 'xdg-utils' 'glew' 'openjpeg' 'python-numpy' 'freetype2'
+ 'boost-libs' 'openimageio' 'opencolorio'
+ 'openshadinglanguage' 'libspnav' 'ptex' 'opensubdiv'
+ 'log4cplus')
+makedepends=('cmake' 'boost' 'mesa' 'git' 'llvm' 'cuda' 'ninja')
optdepends=('cuda: cycles renderer cuda support')
options=(!strip)
source=("git://git.blender.org/blender-addons.git"
"git://git.blender.org/blender-addons-contrib.git"
"git://git.blender.org/blender-translations.git"
- "git://git.blender.org/blender-dev-tools.git"
- "git://git.blender.org/scons.git")
+ "git://git.blender.org/blender-dev-tools.git")
if [[ -n $_gittag ]]; then
source+=("${pkgname}-${pkgver}::git://git.blender.org/blender.git#tag=${_gittag}")
elif [[ -n $_gitcommit ]]; then
source+=("${pkgname}-${pkgver}::git://git.blender.org/blender.git#commit=${_gitcommit}")
fi
-md5sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
@@ -62,55 +41,29 @@ prepare() {
git config submodule."release/scripts/addons_contrib".url ${srcdir}/blender-addons-contrib
git config submodule."release/datafiles/locale".url ${srcdir}/blender-translations
git config submodule."source/tools".url ${srcdir}/blender-dev-tools
- git config submodule."scons".url ${srcdir}/scons
git submodule update
+
+ mkdir -p build
}
build() {
- cd "$srcdir/$pkgname-$pkgver"
-
- mkdir build && cd build
+ cd "$srcdir/$pkgname-$pkgver"/build
- [[ $CARCH == i686 ]] && BUILDCUDA="OFF" || BUILDCUDA="ON"
-
- cmake -C../build_files/cmake/config/blender_full.cmake .. \
+ cmake -GNinja -C../build_files/cmake/config/bpy_module.cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
- -DWITH_INSTALL_PORTABLE=OFF \
- -DWITH_PYTHON_INSTALL=OFF \
- -DWITH_PYTHON_MODULE=ON \
- -DWITH_PLAYER=OFF \
- -DWITH_GAMEENGINE=OFF \
- -DWITH_OPENAL=OFF \
- -DWITH_SDL=OFF \
- -DWITH_JACK=OFF \
- -DWITH_CODEC_AVI=OFF \
- -DWITH_CODEC_FFMPEG=OFF \
- -DWITH_CODEC_SNDFILE=OFF \
- -DOPENIMAGEIO_ROOT_DIR=/usr \
- -DWITH_LLVM=ON \
- -DWITH_SYSTEM_OPENJPEG=ON \
- -DWITH_GL_PROFILE_CORE=OFF \
- -DWITH_GL_PROFILE_ES20=OFF \
- -DLLVM_VERSION=3.5 \
- -DLLVM_STATIC=ON \
- -DWITH_CYCLES_CUDA_BINARIES=$BUILDCUDA \
- -DWITH_CYCLES_OSL=ON \
- -DWITH_CYCLES_PTEX=OFF \
- -DWITH_OPENSUBDIV=ON \
- -DPYTHON_VERSION=3.5 \
+ -DPYTHON_VERSION=3.7 \
+ -DWITH_MEM_JEMALLOC=OFF \
-DPYTHON_LIBPATH=/usr/lib \
- -DPYTHON_LIBRARY=python3.5m \
- -DPYTHON_INCLUDE_DIRS=/usr/include/python3.5m
- make # -j5 needs 48 GB of RAM while -j9 needs 64 GB
-
- # PTEX is currently broken and experimental in blender anyway
+ -DPYTHON_LIBRARY=python3.7m \
+ -DPYTHON_INCLUDE_DIRS=/usr/include/python3.7m
+ ninja -j2
}
package() {
cd "$srcdir/$pkgname-$pkgver/build"
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" ninja install
python -m compileall "${pkgdir}/usr/share/blender"
python -O -m compileall "${pkgdir}/usr/share/blender"
}