aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-04-23 22:37:16 +0200
committerbartus2021-04-23 22:37:59 +0200
commitae4fceb304fd290ef0ad3da80e255abdafd15b97 (patch)
tree73e39d4ca403b223dc7292c3c6e0c830edee0714
parent0a00763c17b4535fff5a8488bd864856025c77b0 (diff)
downloadaur-ae4fceb304fd290ef0ad3da80e255abdafd15b97.tar.gz
Switch to branch 'cycles-x'
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
-rw-r--r--addon_path.patch64
3 files changed, 86 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0bf973ebe185..7e92750d0ca5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = blender-develop-git
+pkgbase = blender-cycles-x-git
pkgdesc = Development version of Blender (non-conflicting version)
- pkgver = 2.93.r105258.gd63b72e9f93
+ pkgver = 3.0.r105857.g1dea1d93d39
pkgrel = 1
url = https://blender.org/
changelog = blender.changelog
@@ -37,14 +37,15 @@ pkgbase = blender-develop-git
depends = libpng
depends = openimagedenoise
optdepends = cuda: CUDA support in Cycles
- provides = blender=2.93
- conflicts = blender=2.93
- source = git://git.blender.org/blender.git#branch=master
+ provides = blender-cycles-x
+ conflicts = blender-cycles-x
+ source = git://git.blender.org/blender.git#branch=cycles-x
source = blender-addons.git::git://git.blender.org/blender-addons.git
source = blender-addons-contrib.git::git://git.blender.org/blender-addons-contrib.git
source = blender-translations.git::git://git.blender.org/blender-translations.git
source = blender-dev-tools.git::git://git.blender.org/blender-dev-tools.git
source = SelectCudaComputeArch.patch
+ source = addon_path.patch
source = usd_python.patch
source = embree.patch
sha256sums = SKIP
@@ -53,8 +54,9 @@ pkgbase = blender-develop-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 66b9bf3db441f35119ef0eb5f855142f2e773e8002ac0216e056bcc6f8ac409c
+ sha256sums = ff05a19c9ff8aa3622b7d31f86c6218ac1a3ac06ad1a7cfd7e0587f623b3bd2f
sha256sums = 333b6fd864d55da2077bc85c55af1a27d4aee9764a1a839df26873a9f19b8703
sha256sums = 6249892f99ffd960e36f43fb893c14e2f8e4dd1d901b9581d25882e865f2603f
-pkgname = blender-develop-git
+pkgname = blender-cycles-x-git
diff --git a/PKGBUILD b/PKGBUILD
index 878248e8723d..6468fcc5888c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,9 @@
# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
# Configuration.
-_fragment=${FRAGMENT:-#branch=master}
+_branch="cycles-x"
+_suffix=${_branch}
+_fragment=${FRAGMENT:-#branch=${_branch}}
# shellcheck disable=SC2206
[[ -v CUDA_ARCH ]] && _cuda_capability=(${CUDA_ARCH})
@@ -25,8 +27,9 @@ _CMAKE_FLAGS+=( -DOSL_ROOT_DIR=/opt/osl
#shellcheck disable=SC2015
((DISABLE_CUDA)) && optdepends+=('cuda: CUDA support in Cycles') || { makedepends+=('cuda') ; ((DISABLE_OPTIX)) || makedepends+=('optix>=7.0'); }
-pkgname=blender-develop-git
-pkgver=2.93.r105258.gd63b72e9f93
+pkgname=blender-${_suffix}-git
+pkgver=3.0.r105857.g1dea1d93d39
+_blenver=${pkgver%.r*}
pkgrel=1
pkgdesc="Development version of Blender (non-conflicting version)"
changelog=blender.changelog
@@ -37,8 +40,8 @@ depends+=('alembic' 'embree' 'libgl' 'python' 'python-numpy' 'openjpeg2' 'libhar
'openvdb' 'opencollada' 'opensubdiv' 'openshadinglanguage-qfix' 'libtiff' 'libpng')
depends+=('openimagedenoise')
makedepends+=('git' 'cmake' 'boost' 'mesa' 'llvm')
-provides=("blender=${pkgver%%.r*}")
-conflicts=("blender=${pkgver%%.r*}")
+provides=("blender-${_suffix}")
+conflicts=("blender-${_suffix}")
license=('GPL')
# NOTE: the source array has to be kept in sync with .gitmodules
# the submodules has to be stored in path ending with git to match
@@ -51,6 +54,7 @@ source=("git://git.blender.org/blender.git${_fragment}"
'blender-translations.git::git://git.blender.org/blender-translations.git'
'blender-dev-tools.git::git://git.blender.org/blender-dev-tools.git'
SelectCudaComputeArch.patch
+ addon_path.patch
usd_python.patch #add missing python headers when building against python enabled usd.
embree.patch #add missing embree link.
)
@@ -60,6 +64,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'66b9bf3db441f35119ef0eb5f855142f2e773e8002ac0216e056bcc6f8ac409c'
+ 'ff05a19c9ff8aa3622b7d31f86c6218ac1a3ac06ad1a7cfd7e0587f623b3bd2f'
'333b6fd864d55da2077bc85c55af1a27d4aee9764a1a839df26873a9f19b8703'
'6249892f99ffd960e36f43fb893c14e2f8e4dd1d901b9581d25882e865f2603f')
@@ -78,6 +83,9 @@ prepare() {
if [ ! -v _cuda_capability ] && grep -q nvidia <(lsmod); then
git -C "$srcdir/blender" apply -v "${srcdir}"/SelectCudaComputeArch.patch
fi
+ if [[ -v _suffix ]]; then
+ git -C "$srcdir/blender" apply -v <(sed "s/@@_suffix@@/${_suffix}/g" "${srcdir}/addon_path.patch")
+ fi
((DISABLE_USD)) || git -C "$srcdir/blender" apply -v "${srcdir}"/usd_python.patch
git -C "$srcdir/blender" apply -v "${srcdir}"/embree.patch
}
@@ -118,7 +126,7 @@ build() {
}
package() {
- _suffix=${pkgver%%.r*}
+ local _suffix=${_blenver}${_suffix:+_$_suffix}
export DESTDIR="$pkgdir"
if ((DISABLE_NINJA)); then make -C "$srcdir/build" install; else ninja -C "$srcdir/build" install; fi
diff --git a/addon_path.patch b/addon_path.patch
new file mode 100644
index 000000000000..c661f0d5cc80
--- /dev/null
+++ b/addon_path.patch
@@ -0,0 +1,64 @@
+diff --git a/intern/ghost/intern/GHOST_SystemPathsUnix.cpp b/intern/ghost/intern/GHOST_SystemPathsUnix.cpp
+index 8fd6aee28da..99d61882451 100644
+--- a/intern/ghost/intern/GHOST_SystemPathsUnix.cpp
++++ b/intern/ghost/intern/GHOST_SystemPathsUnix.cpp
+@@ -56,7 +56,7 @@ const GHOST_TUns8 *GHOST_SystemPathsUnix::getSystemDir(int, const char *versions
+ {
+ /* no prefix assumes a portable build which only uses bundled scripts */
+ if (static_path) {
+- static string system_path = string(static_path) + "/blender/" + versionstr;
++ static string system_path = string(static_path) + "/blender/" + versionstr + "_@@_suffix@@";
+ return (GHOST_TUns8 *)system_path.c_str();
+ }
+
+@@ -77,7 +77,7 @@ const GHOST_TUns8 *GHOST_SystemPathsUnix::getUserDir(int version, const char *ve
+ last_version = version;
+
+ if (home) {
+- user_path = string(home) + "/.blender/" + versionstr;
++ user_path = string(home) + "/.blender/" + versionstr + "_@@_suffix@@";
+ }
+ else {
+ return NULL;
+@@ -92,7 +92,7 @@ const GHOST_TUns8 *GHOST_SystemPathsUnix::getUserDir(int version, const char *ve
+ last_version = version;
+
+ if (home) {
+- user_path = string(home) + "/blender/" + versionstr;
++ user_path = string(home) + "/blender/" + versionstr + "_@@_suffix@@";
+ }
+ else {
+ home = getenv("HOME");
+@@ -100,7 +100,7 @@ const GHOST_TUns8 *GHOST_SystemPathsUnix::getUserDir(int version, const char *ve
+ if (home == NULL)
+ home = getpwuid(getuid())->pw_dir;
+
+- user_path = string(home) + "/.config/blender/" + versionstr;
++ user_path = string(home) + "/.config/blender/" + versionstr + "_@@_suffix@@";
+ }
+ }
+
+diff --git a/source/creator/CMakeLists.txt b/source/creator/CMakeLists.txt
+index 8fb04c320a0..3102752ec97 100644
+--- a/source/creator/CMakeLists.txt
++++ b/source/creator/CMakeLists.txt
+@@ -303,15 +303,15 @@ endif()
+ if(UNIX AND NOT APPLE)
+ if(WITH_PYTHON_MODULE)
+ if(WITH_INSTALL_PORTABLE)
+- set(TARGETDIR_VER ${BLENDER_VERSION})
++ set(TARGETDIR_VER ${BLENDER_VERSION}_@@_suffix@@)
+ else()
+- set(TARGETDIR_VER ${PYTHON_SITE_PACKAGES}/${BLENDER_VERSION})
++ set(TARGETDIR_VER ${PYTHON_SITE_PACKAGES}/${BLENDER_VERSION}_@@_suffix@@)
+ endif()
+ else()
+ if(WITH_INSTALL_PORTABLE)
+- set(TARGETDIR_VER ${BLENDER_VERSION})
++ set(TARGETDIR_VER ${BLENDER_VERSION}_@@_suffix@@)
+ else()
+- set(TARGETDIR_VER share/blender/${BLENDER_VERSION})
++ set(TARGETDIR_VER share/blender/${BLENDER_VERSION}_@@_suffix@@)
+ endif()
+ endif()
+