summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordexterlb2022-12-19 17:09:35 +0200
committerbartoszek2023-02-02 18:24:29 +0100
commit51f312198caf0988bc75575133ae6070dddebd63 (patch)
tree42aaea1c80870c4f3ae8c233f04836e9d7e59355
parent7237598d906262c72dcc6e21562bfe6178eb865e (diff)
downloadaur-51f312198caf0988bc75575133ae6070dddebd63.tar.gz
fix usd_python patch
-rw-r--r--PKGBUILD2
-rw-r--r--usd_python.patch31
2 files changed, 17 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6e00ae6e5398..41b182cd105e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -56,7 +56,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '333b6fd864d55da2077bc85c55af1a27d4aee9764a1a839df26873a9f19b8703'
+ 'e737e58d1a3053da16a568e078a25f4f879fda73398475a919f397e5a8fba2a3'
'd587135fd9b815d60e8b7f48976aa835472922fc8f64c256dc397bfcd3c2642a')
pkgver() {
diff --git a/usd_python.patch b/usd_python.patch
index 8cf7e8fcbbd4..f7cd0305b14a 100644
--- a/usd_python.patch
+++ b/usd_python.patch
@@ -1,26 +1,27 @@
diff --git a/build_files/cmake/platform/platform_unix.cmake b/build_files/cmake/platform/platform_unix.cmake
-index ac570f17e47..505aa97934c 100644
+index bdf39d04d32..4322e0aa042 100644
--- a/build_files/cmake/platform/platform_unix.cmake
+++ b/build_files/cmake/platform/platform_unix.cmake
-@@ -320,6 +320,9 @@ if(WITH_BOOST)
- if(WITH_OPENVDB)
- list(APPEND __boost_packages iostreams)
- endif()
-+ if(WITH_USD)
-+ list(APPEND __boost_packages python)
-+ endif()
- list(APPEND __boost_packages system)
- find_package(Boost 1.48 COMPONENTS ${__boost_packages})
- if(NOT Boost_FOUND)
-diff --git a/source/blender/usd/CMakeLists.txt b/source/blender/usd/CMakeLists.txt
-index 6ea02f44d76..0ec18e17689 100644
+@@ -334,6 +334,10 @@ if(WITH_OPENVDB)
+ endif()
+ endif()
+
++if(WITH_USD)
++ list(APPEND __boost_packages python)
++endif()
++
+ if(WITH_NANOVDB)
+ find_package_wrapper(NanoVDB)
+ set_and_warn_library_found("NanoVDB" NANOVDB_FOUND WITH_NANOVDB)
+diff --git a/source/blender/io/usd/CMakeLists.txt b/source/blender/io/usd/CMakeLists.txt
+index ebd292782c0..02486e72461 100644
--- a/source/blender/io/usd/CMakeLists.txt
+++ b/source/blender/io/usd/CMakeLists.txt
-@@ -48,6 +48,7 @@ set(INC
+@@ -55,6 +55,7 @@ set(INC
set(INC_SYS
${USD_INCLUDE_DIRS}
${BOOST_INCLUDE_DIR}
+ ${PYTHON_INCLUDE_DIRS}
${TBB_INCLUDE_DIR}
+ ${PYTHON_INCLUDE_DIR}
)
-