summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFredrick Brennan2023-03-18 20:36:59 -0400
committerFredrick Brennan2023-03-18 20:36:59 -0400
commitf0d182cc5f47165f604d8d96d2df03642ed62406 (patch)
tree0f7fc5d7ba7399bef939ed23ffef050e2e5b96f5
parent50d796d17f42d7ac93590c8aa1bef629e057f6b1 (diff)
downloadaur-f0d182cc5f47165f604d8d96d2df03642ed62406.tar.gz
Version 3.6.r122558.g45c4a0b1ef1
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 01df27fbb8b5..0e7bdd3b61d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
#Use: VAR1=0 VAR2=1 pamac
# Use FRAGMENT=#{commit,tag,brach}=xxx for bisect build
-_fragment="${FRAGMENT:-#branch=master}"
+_fragment="${FRAGMENT:-#branch=main}"
# Use CUDA_ARCH to build for specific GPU architecture
# Supports: single arch (sm_52) and list of archs (sm_52;sm_60)
@@ -20,7 +20,7 @@ _fragment="${FRAGMENT:-#branch=master}"
_CMAKE_FLAGS+=( -DWITH_CYCLES_NETWORK=OFF )
pkgname=blender-git
-pkgver=3.5.r119175.g129197f20d3
+pkgver=3.6.r122558.g45c4a0b1ef1
pkgrel=1
pkgdesc="A fully integrated 3D graphics creation suite (development)"
arch=('i686' 'x86_64')
@@ -43,11 +43,11 @@ license=('GPL')
# the path in .gitmodules.
# More info:
# http://wiki.blender.org/index.php/Dev:Doc/Tools/Git
-source=("git://git.blender.org/blender.git${_fragment}"
- 'blender-addons.git::git://git.blender.org/blender-addons.git'
- 'blender-addons-contrib.git::git://git.blender.org/blender-addons-contrib.git'
- 'blender-translations.git::git://git.blender.org/blender-translations.git'
- 'blender-dev-tools.git::git://git.blender.org/blender-dev-tools.git'
+source=("git+https://projects.blender.org/blender/blender.git${_fragment}"
+ 'git+https://projects.blender.org/blender/blender-addons.git'
+ 'git+https://projects.blender.org/blender/blender-addons-contrib.git'
+ 'git+https://projects.blender.org/blender/blender-translations.git'
+ 'git+https://projects.blender.org/blender/blender-dev-tools.git'
usd_python.patch #add missing python headers when building against python enabled usd.
embree.patch #add missing embree link.
)
@@ -71,7 +71,7 @@ pkgver() {
prepare() {
cd "$srcdir/blender"
# update the submodules
- git -c protocol.file.allow=always submodule update --init --recursive --remote
+ git -c protocol.file.allow=always submodule update --init --recursive --remote $GITFLAGS
git apply -v "${srcdir}"/{embree,usd_python}.patch
}