summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordoakey32018-02-23 19:13:53 -0700
committerdoakey32018-02-23 19:13:53 -0700
commit8c0a54fbe825a34e04daab9d71239bbe499200b2 (patch)
treec32f6fbde8f060884dd903b2161b040aaef3bb1d
downloadaur-8c0a54fbe825a34e04daab9d71239bbe499200b2.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c18fbc6d267f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = blender-plugin-bligify
+ pkgdesc = Export and import animated GIFs from the Blender VSE
+ pkgver = 1.3.5
+ pkgrel = 1
+ url = https://github.com/doakey3/Bligify
+ arch = any
+ groups = blender
+ license = GPL
+ makedepends = unzip
+ depends = blender gifsicle imagemagick
+ source = https://github.com/doakey3/Bligify/releases/download/1.3.5/Bligify.zip
+ md5sums = d604422b40611c84b09a90d91ab60e69
+
+pkgname = blender-plugin-bligify
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15669141e4d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: doakey3 <doakey3@gmail.com>
+pkgname=blender-plugin-bligify
+pkgver=1.3.5
+pkgrel=1
+pkgdesc="Export and import animated GIFs from the Blender VSE"
+url="https://github.com/doakey3/Bligify"
+license=("GPL")
+arch=('any')
+depends=('blender' 'gifsicle' 'imagemagick')
+groups=('blender')
+makedepends=('unzip')
+source=("https://github.com/doakey3/Bligify/releases/download/1.3.5/Bligify.zip")
+md5sums=('d604422b40611c84b09a90d91ab60e69')
+
+package() {
+ addons="$pkgdir/usr/share/blender/$(blender -v | head -n1 | cut -f2 -d ' ')/scripts/addons/"
+ if [ ! -d "$addons" ]; then
+ mkdir -p "$addons"
+ fi
+ unzip Bligify -d "$addons"
+}