summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2018-07-11 17:03:13 +0200
committerbartus2018-07-11 17:03:13 +0200
commit22aeb11a37352ec4d55cfbc8d07ce63cd06bb08b (patch)
treee618821280698e69fecdfb15807dec468e31d818
parent681092b18e6a3e603121608e29a25f16578d4fcd (diff)
downloadaur-22aeb11a37352ec4d55cfbc8d07ce63cd06bb08b.tar.gz
mail update
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 002e37c8560b..825bbbdc54a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = blender-plugin-gaffer-git
pkgdesc = Blender addon for light and hdri managament.
- pkgver = 3.0.3.r1.gdef0717
+ pkgver = 3.0.4.r1.gf74e188
pkgrel = 1
url = https://blendermarket.com/products/gaffer-light-manager/
install = blender-plugin-gaffer-git.install
arch = any
license = GPL
+ makedepends = expac
makedepends = git
depends = blender
source = gaffer::git+https://github.com/gregzaal/gaffer.git
diff --git a/PKGBUILD b/PKGBUILD
index 552c3e1219a8..d56969305a17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
-# maintained by: bartus szczepaniak <aur@bartus.33mail.com>
+# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
name=gaffer
git_user_name=gregzaal
+_blender=$(expac %v blender|grep -oP '(?<=\:)[[:digit:]]{1}\.[[:digit:]]{2}(?=\.)')
+
pkgname=blender-plugin-${name}-git
-pkgver=3.0.3.r1.gdef0717
+pkgver=3.0.4.r1.gf74e188
pkgrel=1
pkgdesc="Blender addon for light and hdri managament."
arch=('any')
url="https://blendermarket.com/products/gaffer-light-manager/"
license=('GPL')
depends=('blender')
-makedepends=('git')
+makedepends=('expac' 'git')
install="${pkgname}.install"
source=("${name}::git+https://github.com/${git_user_name}/${name}.git"
"remove.updater.patch")
@@ -30,7 +32,7 @@ pkgver() {
package() {
cd ${srcdir}
- addons="$pkgdir/usr/share/blender/$(blender -v | head -n1 | cut -f2 -d ' ')/scripts/addons"
+ addons="$pkgdir/usr/share/blender/${_blender}/scripts/addons"
install -dm755 ${addons}/${name}
cp -a -t ${addons}/${name} ${name}/*
}