summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2017-09-25 11:42:01 +0200
committerbartus2017-09-25 11:42:01 +0200
commit681092b18e6a3e603121608e29a25f16578d4fcd (patch)
treecdcdf3b4be18afc5363a3d6b743554201d077e15
parent40f10c0a00667879c038fc095065314438f03c14 (diff)
downloadaur-681092b18e6a3e603121608e29a25f16578d4fcd.tar.gz
remover updater, fix version string
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
-rw-r--r--remove.updater.patch107
3 files changed, 122 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67a17d13b7e3..002e37c8560b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = blender-plugin-gaffer-git
pkgdesc = Blender addon for light and hdri managament.
- pkgver = v3.0.3.r1.gdef0717
+ pkgver = 3.0.3.r1.gdef0717
pkgrel = 1
url = https://blendermarket.com/products/gaffer-light-manager/
install = blender-plugin-gaffer-git.install
@@ -9,7 +9,9 @@ pkgbase = blender-plugin-gaffer-git
makedepends = git
depends = blender
source = gaffer::git+https://github.com/gregzaal/gaffer.git
+ source = remove.updater.patch
md5sums = SKIP
+ md5sums = ea6aa0e22871607e9b8d9285c367ad86
pkgname = blender-plugin-gaffer-git
diff --git a/PKGBUILD b/PKGBUILD
index dbc433eaa966..552c3e1219a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
name=gaffer
git_user_name=gregzaal
pkgname=blender-plugin-${name}-git
-pkgver=v3.0.3.r1.gdef0717
+pkgver=3.0.3.r1.gdef0717
pkgrel=1
pkgdesc="Blender addon for light and hdri managament."
arch=('any')
@@ -12,12 +12,20 @@ license=('GPL')
depends=('blender')
makedepends=('git')
install="${pkgname}.install"
-source=("${name}::git+https://github.com/${git_user_name}/${name}.git")
-md5sums=('SKIP')
+source=("${name}::git+https://github.com/${git_user_name}/${name}.git"
+ "remove.updater.patch")
+md5sums=('SKIP'
+ 'ea6aa0e22871607e9b8d9285c367ad86')
+
+prepare() {
+ cd ${name}
+ patch -Np1 -i ../remove.updater.patch
+ rm addon_updater.py addon_updater_ops.py
+}
pkgver() {
cd "$name"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
diff --git a/remove.updater.patch b/remove.updater.patch
new file mode 100644
index 000000000000..88188fdf06e0
--- /dev/null
+++ b/remove.updater.patch
@@ -0,0 +1,107 @@
+diff --git a/__init__.py b/__init__.py
+index 0a39c25..d0ca78a 100644
+--- a/__init__.py
++++ b/__init__.py
+@@ -34,16 +34,13 @@ if "bpy" in locals():
+ imp.reload(functions)
+ imp.reload(operators)
+ imp.reload(ui)
+- imp.reload(addon_updater)
+- imp.reload(addon_updater_ops)
+ else:
+- from . import constants, functions, operators, ui, addon_updater, addon_updater_ops
++ from . import constants, functions, operators, ui
+
+ import bpy
+ import os
+ import json
+ import bgl, blf
+-from . import addon_updater_ops
+ from collections import OrderedDict
+ from math import pi, cos, sin, log
+ from mathutils import Vector, Matrix
+@@ -54,40 +51,6 @@ from bpy.app.handlers import persistent
+ class GafferPreferences(bpy.types.AddonPreferences):
+ bl_idname = __package__
+
+- # addon updater preferences
+- auto_check_update = bpy.props.BoolProperty(
+- name = "Auto-check for Update",
+- description = "If enabled, auto-check for updates using an interval",
+- default = True,
+- )
+- updater_intrval_months = bpy.props.IntProperty(
+- name='Months',
+- description = "Number of months between checking for updates",
+- default=0,
+- min=0
+- )
+- updater_intrval_days = bpy.props.IntProperty(
+- name='Days',
+- description = "Number of days between checking for updates",
+- default=1,
+- min=0,
+- )
+- updater_intrval_hours = bpy.props.IntProperty(
+- name='Hours',
+- description = "Number of hours between checking for updates",
+- default=0,
+- min=0,
+- max=23
+- )
+- updater_intrval_minutes = bpy.props.IntProperty(
+- name='Minutes',
+- description = "Number of minutes between checking for updates",
+- default=0,
+- min=0,
+- max=59
+- )
+- updater_expand_prefs = bpy.props.BoolProperty(default=False)
+-
+ hdri_path = bpy.props.StringProperty(
+ name="HDRI Folder",
+ subtype='DIR_PATH',
+@@ -166,7 +129,6 @@ class GafferPreferences(bpy.types.AddonPreferences):
+ row.alignment = 'RIGHT'
+ row.prop(self, 'include_8bit')
+
+- addon_updater_ops.update_settings_ui(self,context)
+
+ box = layout.box()
+ col = box.column()
+@@ -531,7 +493,6 @@ class GafferProperties(bpy.types.PropertyGroup):
+
+
+ def register():
+- addon_updater_ops.register(bl_info)
+
+ functions.previews_register()
+ functions.cleanup_logs()
+diff --git a/ui.py b/ui.py
+index c6a35bb..6394b67 100644
+--- a/ui.py
++++ b/ui.py
+@@ -17,7 +17,6 @@
+ # END GPL LICENSE BLOCK #####
+
+ import bpy
+-from . import addon_updater_ops
+ from collections import OrderedDict
+ import bgl, blf
+ from math import pi, cos, sin, log
+@@ -664,7 +663,6 @@ class GafferPanelLights(bpy.types.Panel):
+ return True if context.scene.render.engine in supported_renderers else False
+
+ def draw(self, context):
+- addon_updater_ops.check_for_update_background(context)
+
+ scene = context.scene
+ gaf_props = scene.gaf_props
+@@ -704,7 +702,6 @@ class GafferPanelLights(bpy.types.Panel):
+ else:
+ layout.label ("Render Engine not supported!")
+
+- addon_updater_ops.update_notice_box_ui(self, context)
+
+
+ class GafferPanelTools(bpy.types.Panel):