summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2020-06-30 08:27:13 +0200
committerbartus2020-06-30 08:27:13 +0200
commit514a46ff851bc1478c555acde404b2a1e46b8ec7 (patch)
tree9656eb0d6adfab11db03511f2f769fd200958190
parent414822f2d9ac69ce4f74e8bb8e28b64f89b11907 (diff)
downloadaur-514a46ff851bc1478c555acde404b2a1e46b8ec7.tar.gz
Update denoiser.patch: rename binary to `oidnDenoise`
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--denoise.patch13
3 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bca000d11f41..cdad6badf135 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = blender-plugin-luxcorerender
pkgdesc = LuxCoreRender exporter plugin for Blender
pkgver = 2.3
- pkgrel = 1
+ pkgrel = 2
epoch = 2
url = https://luxcorerender.org/
arch = any
@@ -9,7 +9,7 @@ pkgbase = blender-plugin-luxcorerender
source = https://github.com/LuxCoreRender/BlendLuxCore/archive/blendluxcore_v2.3.tar.gz
source = denoise.patch
sha256sums = a5ea3dbac4e56decef5561ceb456be3eb6658111dd8feed55d632a52bfd7edaa
- sha256sums = 63103ec3bf77c502a54f6f74cad020a448c9641be90202944c46bda0a1ff8bfe
+ sha256sums = 118853c17d90f034e0f6e3b1e07f7d3042bc7c706c46cfb3c2dd13242e1c6ce0
pkgname = blender-plugin-luxcorerender
depends = blender>=2.80
diff --git a/PKGBUILD b/PKGBUILD
index c7fd81059824..4c1d31513525 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _name="luxcorerender"
pkgname=blender-plugin-${_name}
pkgver=2.3
epoch=2
-pkgrel=1
+pkgrel=2
pkgdesc="LuxCoreRender exporter plugin for Blender"
arch=('any')
url="https://luxcorerender.org/"
@@ -14,7 +14,7 @@ license=('GPL')
source=("https://github.com/LuxCoreRender/BlendLuxCore/archive/blendluxcore_v${pkgver}.tar.gz"
"denoise.patch")
sha256sums=('a5ea3dbac4e56decef5561ceb456be3eb6658111dd8feed55d632a52bfd7edaa'
- '63103ec3bf77c502a54f6f74cad020a448c9641be90202944c46bda0a1ff8bfe')
+ '118853c17d90f034e0f6e3b1e07f7d3042bc7c706c46cfb3c2dd13242e1c6ce0')
prepare() {
cd "${srcdir}/BlendLuxCore-blendluxcore_v${pkgver}"
@@ -25,7 +25,7 @@ package() {
depends=("blender>=2.80" "luxcorerender>$pkgver")
_blender=$(pacman -Sddp --print-format %v blender|grep -oP '(?<=\:)[[:digit:]]{1}\.[[:digit:]]{2}(?=)')
install -d -m755 "${pkgdir}"/usr/share/blender/"${_blender}"/scripts/addons
- cp -a "${srcdir}"/BlendLuxCore-blendluxcore_v${pkgver} "${pkgdir}"/usr/share/blender/${_blender}/scripts/addons/${_name}
+ cp -a "${srcdir}"/BlendLuxCore-blendluxcore_v${pkgver} "${pkgdir}"/usr/share/blender/"${_blender}"/scripts/addons/${_name}
# change the search path in exporter so it finds pylux in its new location :(previous solution was much better, what happen to blendlux )
#sed -i 's|from.*import pylux|import pylux|' "$pkgdir/usr/share/blender/$_blender/scripts/addons/luxrender/outputs/pure_api.py"
# shellcheck disable=SC2013 # works until path has no white space.
diff --git a/denoise.patch b/denoise.patch
index 4c74a4a1690e..5b3048b91786 100644
--- a/denoise.patch
+++ b/denoise.patch
@@ -1,7 +1,8 @@
-diff -Naur BlendLuxCore-blendluxcore_v2.2/draw/viewport.py BlendLuxCore-blendluxcore_v2.2-patch/draw/viewport.py
---- BlendLuxCore-blendluxcore_v2.2/draw/viewport.py 2019-09-30 12:40:01.000000000 +0200
-+++ BlendLuxCore-blendluxcore_v2.2-patch/draw/viewport.py 2019-11-28 08:19:28.433741235 +0100
-@@ -8,6 +8,7 @@
+diff --git a/draw/viewport.py b/draw/viewport.py
+index a28cf9f..f7fd34c 100644
+--- a/draw/viewport.py
++++ b/draw/viewport.py
+@@ -8,6 +8,7 @@ import tempfile
from ..bin import pyluxcore
from .. import utils
from ..utils import pfm
@@ -9,13 +10,13 @@ diff -Naur BlendLuxCore-blendluxcore_v2.2/draw/viewport.py BlendLuxCore-blendlux
NULL = 0
-@@ -72,8 +73,7 @@
+@@ -72,8 +73,7 @@ class FrameBuffer(object):
self._albedo_file_path = self._make_denoiser_filepath("albedo")
self._normal_file_path = self._make_denoiser_filepath("normal")
self._denoised_file_path = self._make_denoiser_filepath("denoised")
- current_dir = os.path.dirname(os.path.realpath(__file__))
- self._denoiser_path = os.path.join(os.path.dirname(current_dir), "bin", "denoise")
-+ self._denoiser_path = which('denoise')
++ self._denoiser_path = which('oidnDenoise')
if platform.system() == "Windows":
self._denoiser_path += ".exe"
self._denoiser_process = None