summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfab2016-04-27 18:53:47 +0200
committerfab2016-04-27 18:53:47 +0200
commit2664941670a467581987386e97e13e641e3c253c (patch)
treee87f6cfac48f821b148f1438a3dd60d4b0edbb06
downloadaur-2664941670a467581987386e97e13e641e3c253c.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..952a1aa63027
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = blender-plugin-miratools
+ pkgdesc = Modern modeling and retopology tools
+ pkgver = 6.4.27
+ pkgrel = 1
+ url = https://github.com/mifth/mifthtools/wiki/Mira-Tools
+ arch = any
+ groups = blender
+ license = GPL
+ makedepends = unzip
+ depends = blender
+ source = https://github.com/mifth/mifthtools/archive/238cd26c7ec0ee5c31318cd27344e410b0c9bca4.zip
+ md5sums = f5df06f9e53b7c3d57f8620c6d8361a5
+
+pkgname = blender-plugin-miratools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9914f634402a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Fabien Devaux <fdev31@gmail.com>
+pkgname=blender-plugin-miratools
+pkgver=6.4.27 # Y.M.D
+pkgrel=1
+_h="238cd26c7ec0ee5c31318cd27344e410b0c9bca4"
+pkgdesc="Modern modeling and retopology tools"
+url="https://github.com/mifth/mifthtools/wiki/Mira-Tools"
+license=("GPL")
+arch=('any')
+depends=('blender')
+groups=('blender')
+makedepends=('unzip')
+source=("https://github.com/mifth/mifthtools/archive/$_h.zip")
+md5sums=('f5df06f9e53b7c3d57f8620c6d8361a5')
+
+package() {
+ addons="$pkgdir/usr/share/blender/$(blender -v | head -n1 | cut -f2 -d ' ')/scripts/addons/"
+ if [ ! -d "$addons" ]; then
+ mkdir -p "$addons"
+ fi
+ cp -r "$srcdir/mifthtools-$_h/blender/addons/"* "$addons"
+}
+