summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2018-05-21 13:52:04 +0200
committerbartus2018-05-21 13:52:04 +0200
commit7c04f5e5c30f33f11bfecd7fcac54a058964ef34 (patch)
treeeacf14119d322b061b0008356e182d578beb4da5
parent19ea2b2cf4ce8f380d95379b6319b76236f1d260 (diff)
downloadaur-7c04f5e5c30f33f11bfecd7fcac54a058964ef34.tar.gz
use expac
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff5058a5d25b..d5a663707b00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = blender-plugin-miratools
pkgdesc = Modern modeling and retopology tools
- pkgver = r651.0dfd4c1
+ pkgver = r688.6f50f8d
pkgrel = 1
url = https://github.com/mifth/mifthtools/wiki/Mira-Tools
arch = any
groups = blender
license = GPL
+ makedepends = expac
makedepends = git
depends = blender
source = blender-plugin-miratools::git+https://github.com/mifth/mifthtools.git
diff --git a/PKGBUILD b/PKGBUILD
index 6b4fb5bc9b1f..acce54645cce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,10 @@
# Maintainer: bartus <szczepaniak.bartek+aur@gmail.com>
# original maintainer : Fabien Devaux <fdev31@gmail.com>
+_blender=$(expac %v blender|grep -oP '(?<=\:)[[:digit:]]{1}\.[[:digit:]]{2}(?=\.)')
+
pkgname=blender-plugin-miratools
-pkgver=r651.0dfd4c1 # commit-num.commit-hash
+pkgver=r688.6f50f8d # commit-num.commit-hash
pkgrel=1
pkgdesc="Modern modeling and retopology tools"
url="https://github.com/mifth/mifthtools/wiki/Mira-Tools"
@@ -10,7 +12,7 @@ license=("GPL")
arch=('any')
depends=('blender')
groups=('blender')
-makedepends=('git')
+makedepends=('expac' 'git')
source=("${pkgname}::git+https://github.com/mifth/mifthtools.git")
md5sums=('SKIP')
@@ -20,7 +22,7 @@ pkgver() {
}
package() {
- addons="$pkgdir/usr/share/blender/$(blender -v | head -n1 | cut -f2 -d ' ')/scripts/addons/"
+ addons="$pkgdir/usr/share/blender/${_blender}/scripts/addons/"
install -dm755 ${addons}/${name}
cp -a ${srcdir}/${pkgname}/blender/addons/* ${addons}/${name}
}