summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2017-03-19 11:04:08 +0100
committerbartus2017-03-19 11:04:08 +0100
commitb629729a56c60e6113fbaa5a5af988d2123ba646 (patch)
tree93d0c23f96ef80f364b04106be9d79f7b4fdfb66
parent2664941670a467581987386e97e13e641e3c253c (diff)
downloadaur-b629729a56c60e6113fbaa5a5af988d2123ba646.tar.gz
new version - git master source
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD27
2 files changed, 21 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 952a1aa63027..c78864a146b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = blender-plugin-miratools
pkgdesc = Modern modeling and retopology tools
- pkgver = 6.4.27
- pkgrel = 1
+ pkgver = r569.87031bc
+ pkgrel = 2
url = https://github.com/mifth/mifthtools/wiki/Mira-Tools
arch = any
groups = blender
license = GPL
- makedepends = unzip
+ makedepends = git
depends = blender
- source = https://github.com/mifth/mifthtools/archive/238cd26c7ec0ee5c31318cd27344e410b0c9bca4.zip
- md5sums = f5df06f9e53b7c3d57f8620c6d8361a5
+ source = blender-plugin-miratools::git+https://github.com/mifth/mifthtools.git
+ md5sums = SKIP
pkgname = blender-plugin-miratools
diff --git a/PKGBUILD b/PKGBUILD
index 9914f634402a..4da890874297 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,28 @@
-# Maintainer: Fabien Devaux <fdev31@gmail.com>
+# Maintainer: bartus <szczepaniak.bartek+aur@gmail.com>
+# original maintainer : Fabien Devaux <fdev31@gmail.com>
+
pkgname=blender-plugin-miratools
-pkgver=6.4.27 # Y.M.D
-pkgrel=1
-_h="238cd26c7ec0ee5c31318cd27344e410b0c9bca4"
+pkgver=r569.87031bc # commit-num.commit-hash
+pkgrel=2
pkgdesc="Modern modeling and retopology tools"
url="https://github.com/mifth/mifthtools/wiki/Mira-Tools"
license=("GPL")
arch=('any')
depends=('blender')
groups=('blender')
-makedepends=('unzip')
-source=("https://github.com/mifth/mifthtools/archive/$_h.zip")
-md5sums=('f5df06f9e53b7c3d57f8620c6d8361a5')
+makedepends=('git')
+source=("${pkgname}::git+https://github.com/mifth/mifthtools.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
package() {
addons="$pkgdir/usr/share/blender/$(blender -v | head -n1 | cut -f2 -d ' ')/scripts/addons/"
- if [ ! -d "$addons" ]; then
- mkdir -p "$addons"
- fi
- cp -r "$srcdir/mifthtools-$_h/blender/addons/"* "$addons"
+ install -d 755 ${addons}/${name}
+ cp -a ${srcdir}/${pkgname}/blender/addons/* ${addons}/${name}
+# cp -r "$srcdir/mifthtools-$_h/blender/addons/"* "$addons"
}