summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2018-10-29 01:21:30 +0100
committerbartus2018-10-29 01:21:30 +0100
commit5d07dbfc688cf24fa3519b6d7c197ec4a5093190 (patch)
tree6e0b15835e69157d3d86cf93aeea4cd8a46ef0cb
downloadaur-5d07dbfc688cf24fa3519b6d7c197ec4a5093190.tar.gz
init
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8611c165d93f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = blender-plugin-polytrim-git
+ pkgdesc = Blender addon for triming and cutting a mesh over geodesic path.
+ pkgver = r173.ce4f36b
+ pkgrel = 1
+ url = https://github.com/patmo141/cut_mesh
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = blender
+ conflicts = blender-plugin-polytrim
+ source = polytrim::git+https://github.com/patmo141/cut_mesh.git
+ md5sums = SKIP
+
+pkgname = blender-plugin-polytrim-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5d81ade3ea2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
+
+name=polytrim
+_blender=$(pacman -Sddp --print-format %v blender|grep -oP '(?<=\:)[[:digit:]]{1}\.[[:digit:]]{2}(?=\.)')
+
+pkgname=blender-plugin-${name}-git
+pkgver=r173.ce4f36b
+pkgrel=1
+pkgdesc="Blender addon for triming and cutting a mesh over geodesic path."
+arch=('any')
+url="https://github.com/patmo141/cut_mesh"
+license=('GPL')
+depends=('blender')
+makedepends=('git')
+conflicts=("blender-plugin-${name}")
+source=("${name}::git+${url}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$name"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ${srcdir}
+ addons="$pkgdir/usr/share/blender/${_blender}/scripts/addons"
+ install -dm755 ${addons}/${name}
+ cp -a ${name}/* ${addons}/${name}
+}
+
+# vim:set ts=2 sw=2 et: