summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfab2016-04-22 22:20:51 +0200
committerfab2016-04-22 22:20:51 +0200
commit932bc87607516b2328c08a2535d7c9b7794be28d (patch)
tree9411561c3267038f38da76d43b35089f7a944a9b
downloadaur-932bc87607516b2328c08a2535d7c9b7794be28d.tar.gz
add stable retopoflow version
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD61
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d343fdd4ed2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = blender-plugin-retopoflow
+ pkgdesc = A suite of retopology tools for Blender
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://cgcookiemarkets.com/all-products/retopoflow/
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = blender
+
+pkgname = blender-plugin-retopoflow
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ae65f20044d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# See http://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines
+# for more information on packaging from GIT sources.
+
+# Maintainer: Fabien Devaux <fdev31@gmail.com>
+pkgname=blender-plugin-retopoflow
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="A suite of retopology tools for Blender"
+arch=('any')
+url="https://cgcookiemarkets.com/all-products/retopoflow/"
+license=('GPL')
+groups=()
+depends=('blender')
+makedepends=('git')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=()
+noextract=()
+md5sums=() #generate with 'makepkg -g'
+
+_gitroot=https://github.com/CGCookie/retopoflow.git
+_gitname=retopoflow
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone -b v1.2.0 "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+}
+
+package() {
+ cd "$srcdir/"
+ addons="$pkgdir/usr/share/blender/$(blender -v | head -n1 | cut -f2 -d ' ')/scripts/addons/"
+ if [ ! -d "$addons" ]; then
+ mkdir -p "$addons"
+ fi
+ cp -a "$_gitname" "$addons/$_gitname"
+ rm -fr "$addons/$_gitname/.git"*
+}
+
+# vim:set ts=2 sw=2 et: