summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjmcb2023-06-12 20:39:42 +0100
committerjmcb2023-06-12 20:39:42 +0100
commitef8db66b2f0db06de3aa7bfc9a35387c7d5fcbcd (patch)
tree916e07ec23e3fa739c310ab7e8bfc6427dba4d6b
downloadaur-ef8db66b2f0db06de3aa7bfc9a35387c7d5fcbcd.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore13
-rw-r--r--PKGBUILD27
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af269e9f90f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = blender-plugin-sketchfab
+ pkgdesc = Directly import and export models from and to Sketchfab in Blender
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = https://github.com/sketchfab/blender-plugin
+ arch = any
+ license = Apache
+ depends = blender
+ source = https://github.com/sketchfab/blender-plugin/releases/download/1.5.0/sketchfab-plugin-1-5-0.zip
+ sha256sums = 2af10639ec07177e8494d492200caf254cb43c4572519ce55f705e348b50cf4b
+
+pkgname = blender-plugin-sketchfab
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b73905529f23
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,13 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea10ebe59e94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: jmcb <joelsgp@protonmail.com>
+
+pkgname='blender-plugin-sketchfab'
+pkgver='1.5.0'
+# replace . with -
+_name="sketchfab-plugin-${pkgver//./-}"
+_blenderver='3.5'
+pkgrel=1
+pkgdesc="Directly import and export models from and to Sketchfab in Blender"
+arch=('any')
+url="https://github.com/sketchfab/blender-plugin"
+license=('Apache')
+depends=('blender')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+source=("https://github.com/sketchfab/blender-plugin/releases/download/${pkgver}/${_name}.zip")
+sha256sums=('2af10639ec07177e8494d492200caf254cb43c4572519ce55f705e348b50cf4b')
+
+
+package() {
+ _dest="${pkgdir}/usr/share/blender/${_blenderver}/scripts/addons"
+ install -d "${_dest}"
+ bsdtar --cd "${_dest}" -xf "${_name}.zip"
+}