summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2018-07-11 17:05:56 +0200
committerbartus2018-07-11 17:05:56 +0200
commit4d3623e1eac221197ae1f2e373caf266f7fb133b (patch)
tree37c388fc4efa949958b2ce76a578e498ae6d4978
parente5b4d2b2e166b5ba0da93c952a20d2385f59861b (diff)
downloadaur-4d3623e1eac221197ae1f2e373caf266f7fb133b.tar.gz
mail update
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0f13d87a437..e77196c321e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,6 +5,7 @@ pkgbase = blender-plugin-yavne
url = https://github.com/fedackb/yavne
arch = any
license = GPL
+ makedepends = expac
makedepends = git
depends = blender
source = yavne::git+https://github.com/fedackb/yavne.git
diff --git a/PKGBUILD b/PKGBUILD
index d2765f19f154..a5fe179e18ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,11 @@
-# maintained by: bartus szczepaniak <aur@bartus.33mail.com>
+# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
name=yavne
version=1.3.0
#fragment="#commit=7e49329 "
files=(__init__.py operators.py panel.py preferences.py utils.py)
+_blender=$(expac %v blender|grep -oP '(?<=\:)[[:digit:]]{1}\.[[:digit:]]{2}(?=\.)')
+
pkgname=blender-plugin-${name}
pkgver=1.3.0_r16.8eb2b18
pkgrel=1
@@ -12,7 +14,7 @@ arch=('any')
url="https://github.com/fedackb/yavne"
license=('GPL')
depends=('blender')
-makedepends=('git')
+makedepends=('expac' 'git')
source=("${name}::git+https://github.com/fedackb/yavne.git${fragment}")
md5sums=('SKIP')
@@ -23,7 +25,7 @@ pkgver() {
package() {
cd ${name}
- addons="$pkgdir/usr/share/blender/$(blender -v | head -n1 | cut -f2 -d ' ')/scripts/addons"
+ addons="$pkgdir/usr/share/blender/${_blender}/scripts/addons"
install -dm755 ${addons}/${name}
for file in ${files[@]} ; do install -m 755 ${file} ${addons}/${name}/${file} ; done
# install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE