summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2017-08-31 15:16:01 +0200
committerbartus2017-08-31 15:16:01 +0200
commite5b4d2b2e166b5ba0da93c952a20d2385f59861b (patch)
treed898d93197776c6ab42fc2949fbb4ee86d8bd56d
downloadaur-e5b4d2b2e166b5ba0da93c952a20d2385f59861b.tar.gz
init
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0f13d87a437
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = blender-plugin-yavne
+ pkgdesc = This Blender addon provides a set of tools for editing vertex normals. Y.A.V.N.E. can dramatically improve the visual quality of a mesh without altering geometry.
+ pkgver = 1.3.0_r16.8eb2b18
+ pkgrel = 1
+ url = https://github.com/fedackb/yavne
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = blender
+ source = yavne::git+https://github.com/fedackb/yavne.git
+ md5sums = SKIP
+
+pkgname = blender-plugin-yavne
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2765f19f154
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# maintained by: bartus szczepaniak <aur@bartus.33mail.com>
+
+name=yavne
+version=1.3.0
+#fragment="#commit=7e49329 "
+files=(__init__.py operators.py panel.py preferences.py utils.py)
+pkgname=blender-plugin-${name}
+pkgver=1.3.0_r16.8eb2b18
+pkgrel=1
+pkgdesc="This Blender addon provides a set of tools for editing vertex normals. Y.A.V.N.E. can dramatically improve the visual quality of a mesh without altering geometry."
+arch=('any')
+url="https://github.com/fedackb/yavne"
+license=('GPL')
+depends=('blender')
+makedepends=('git')
+source=("${name}::git+https://github.com/fedackb/yavne.git${fragment}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${name}
+ printf "${version}_r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ${name}
+ addons="$pkgdir/usr/share/blender/$(blender -v | head -n1 | cut -f2 -d ' ')/scripts/addons"
+ install -dm755 ${addons}/${name}
+ for file in ${files[@]} ; do install -m 755 ${file} ${addons}/${name}/${file} ; done
+# install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+
+# vim:set ts=2 sw=2 et: