summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Attali2022-05-08 19:35:27 -0400
committerJeremy Attali2022-05-08 21:20:19 -0400
commitfea06712fbe81b8bcf02d6fcb70b911bdac80df5 (patch)
treebec111c640a8142962515a45787b654993603991
parent40b4e309030a26a77d6407410adccab1f30e8183 (diff)
downloadaur-fea06712fbe81b8bcf02d6fcb70b911bdac80df5.tar.gz
rebase from upstream blender-git
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--embree.patch11
-rw-r--r--openexr3.patch42
4 files changed, 11 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec956000bc77..280050aab22f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = blender-wayland-git
pkgdesc = A fully integrated 3D graphics creation suite (development)
- pkgver = 3.1.r111319.g5457b663011
+ pkgver = 3.3.r114671.g2a2261d7e19
pkgrel = 1
url = https://blender.org/
arch = i686
@@ -47,14 +47,12 @@ pkgbase = blender-wayland-git
source = blender-dev-tools.git::git://git.blender.org/blender-dev-tools.git
source = usd_python.patch
source = embree.patch
- source = openexr3.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 333b6fd864d55da2077bc85c55af1a27d4aee9764a1a839df26873a9f19b8703
- sha256sums = ab353b7a9fdb5e9a87fefdade6915f44660299b67446735a9720833aa45f6be8
- sha256sums = 5297dc61cc4edcc1d5bad3474ab882264b69d68036cebbd0f2600d9fe21d5a1b
+ sha256sums = d587135fd9b815d60e8b7f48976aa835472922fc8f64c256dc397bfcd3c2642a
pkgname = blender-wayland-git
diff --git a/PKGBUILD b/PKGBUILD
index 15743a80e52c..e61d2f4fd36c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ _fragment="${FRAGMENT:-#branch=master}"
_CMAKE_FLAGS+=( -DWITH_CYCLES_NETWORK=OFF )
pkgname=blender-wayland-git
-pkgver=3.1.r111319.g5457b663011
+pkgver=3.3.r114671.g2a2261d7e19
pkgrel=1
pkgdesc="A fully integrated 3D graphics creation suite (development)"
arch=('i686' 'x86_64')
@@ -47,7 +47,6 @@ source=("git://git.blender.org/blender.git${_fragment}"
'blender-dev-tools.git::git://git.blender.org/blender-dev-tools.git'
usd_python.patch #add missing python headers when building against python enabled usd.
embree.patch #add missing embree link.
- openexr3.patch #fix build against openexr:3
)
sha256sums=('SKIP'
'SKIP'
@@ -55,8 +54,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'333b6fd864d55da2077bc85c55af1a27d4aee9764a1a839df26873a9f19b8703'
- 'ab353b7a9fdb5e9a87fefdade6915f44660299b67446735a9720833aa45f6be8'
- '5297dc61cc4edcc1d5bad3474ab882264b69d68036cebbd0f2600d9fe21d5a1b')
+ 'd587135fd9b815d60e8b7f48976aa835472922fc8f64c256dc397bfcd3c2642a')
pkgver() {
blender_version=$(grep -Po "BLENDER_VERSION \K[0-9]{3}" "$srcdir"/blender/source/blender/blenkernel/BKE_blender_version.h)
@@ -71,7 +69,7 @@ prepare() {
cd "$srcdir/blender"
# update the submodules
git submodule update --init --recursive --remote
- git apply -v "${srcdir}"/{embree,usd_python,openexr3}.patch
+ git apply -v "${srcdir}"/{embree,usd_python}.patch
}
build() {
diff --git a/embree.patch b/embree.patch
index 4790c4ea873a..e6cee1fb8a62 100644
--- a/embree.patch
+++ b/embree.patch
@@ -1,8 +1,8 @@
diff --git a/build_files/cmake/Modules/FindEmbree.cmake b/build_files/cmake/Modules/FindEmbree.cmake
-index 90cf23d3e13..f625efaa542 100644
+index bb65a24c4b5..5d1ba7b459a 100644
--- a/build_files/cmake/Modules/FindEmbree.cmake
+++ b/build_files/cmake/Modules/FindEmbree.cmake
-@@ -7,6 +7,9 @@
+@@ -10,6 +10,9 @@
# EMBREE_ROOT_DIR, The base directory to search for Embree.
# This can also be an environment variable.
# EMBREEFOUND, If false, do not try to use Embree.
@@ -10,9 +10,9 @@ index 90cf23d3e13..f625efaa542 100644
+# also defined, but not for general use are
+# EMBREE_LIBRARY, where to find the Embree library.
- #=============================================================================
- # Copyright 2018 Blender Foundation.
-@@ -67,14 +70,23 @@ FOREACH(COMPONENT ${_embree_FIND_COMPONENTS})
+ # If EMBREE_ROOT_DIR was defined in the environment, use it.
+ IF(NOT EMBREE_ROOT_DIR AND NOT $ENV{EMBREE_ROOT_DIR} STREQUAL "")
+@@ -72,15 +75,24 @@ FOREACH(COMPONENT ${_embree_FIND_COMPONENTS})
ENDFOREACH()
@@ -38,6 +38,7 @@ index 90cf23d3e13..f625efaa542 100644
SET(EMBREE_INCLUDE_DIRS ${EMBREE_INCLUDE_DIR})
ENDIF()
+ MARK_AS_ADVANCED(
diff --git a/intern/cycles/blender/CMakeLists.txt b/intern/cycles/blender/CMakeLists.txt
index 2316800e21e..591841152e2 100644
--- a/intern/cycles/blender/CMakeLists.txt
diff --git a/openexr3.patch b/openexr3.patch
deleted file mode 100644
index 73a727a3dbc9..000000000000
--- a/openexr3.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff --git a/build_files/cmake/Modules/FindOpenEXR.cmake b/build_files/cmake/Modules/FindOpenEXR.cmake
-index 090f80b8df7..a2f7b4c622b 100644
---- a/build_files/cmake/Modules/FindOpenEXR.cmake
-+++ b/build_files/cmake/Modules/FindOpenEXR.cmake
-@@ -34,11 +34,10 @@ ENDIF()
- SET(_openexr_libs_ver_init "2.0")
-
- SET(_openexr_FIND_COMPONENTS
-- Half
- Iex
-- IlmImf
-- IlmThread
- Imath
-+ OpenEXR
-+ IlmThread
- )
-
- SET(_openexr_SEARCH_DIRS
-@@ -120,7 +119,7 @@ FIND_PACKAGE_HANDLE_STANDARD_ARGS(OpenEXR DEFAULT_MSG
- IF(OPENEXR_FOUND)
- SET(OPENEXR_LIBRARIES ${_openexr_LIBRARIES})
- # Both include paths are needed because of dummy OSL headers mixing #include <OpenEXR/foo.h> and #include <foo.h> :(
-- SET(OPENEXR_INCLUDE_DIRS ${OPENEXR_INCLUDE_DIR} ${OPENEXR_INCLUDE_DIR}/OpenEXR)
-+ SET(OPENEXR_INCLUDE_DIRS ${OPENEXR_INCLUDE_DIR} ${OPENEXR_INCLUDE_DIR}/OpenEXR ${OPENEXR_INCLUDE_DIR}/Imath)
- ENDIF()
-
- MARK_AS_ADVANCED(
-diff --git a/source/blender/imbuf/intern/openexr/openexr_api.cpp b/source/blender/imbuf/intern/openexr/openexr_api.cpp
-index 382d86f2645..eff50b19c31 100644
---- a/source/blender/imbuf/intern/openexr/openexr_api.cpp
-+++ b/source/blender/imbuf/intern/openexr/openexr_api.cpp
-@@ -38,8 +38,10 @@
- #include <ImfChannelList.h>
- #include <ImfCompression.h>
- #include <ImfCompressionAttribute.h>
-+#include <ImfFrameBuffer.h>
- #include <ImfIO.h>
- #include <ImfInputFile.h>
-+#include <ImfInt64.h>
- #include <ImfOutputFile.h>
- #include <ImfPixelType.h>
- #include <ImfStandardAttributes.h>