summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-03-27 10:18:16 +0100
committerAlexander F. Rødseth2019-03-27 10:18:16 +0100
commitf3d41c47ead68e9b3179a5301e216e4c0a7cf21c (patch)
treef0e0519ab1a71a0ade2b39bda0c5334ebff72373
downloadaur-f3d41c47ead68e9b3179a5301e216e4c0a7cf21c.tar.gz
Move from [community] to AUR in connection with the spring cleaning
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78ff1635b2d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Wed Mar 27 09:15:56 UTC 2019
+pkgbase = bless
+ pkgdesc = High-quality, full-featured hex editor
+ pkgver = 0.6.1
+ pkgrel = 1
+ url = https://web.archive.org/web/20170503150524/http://home.gna.org/bless/
+ arch = any
+ license = GPL
+ makedepends = rarian
+ depends = gtk-sharp-2
+ source = bless-0.6.1.tar.gz::https://github.com/afrantzis/bless/archive/v0.6.1.tar.gz
+ sha256sums = 5f82e43e22e48080ea8e24668197f79dc8bddfcbf3b5f631dbe17f952e7b0f0e
+
+pkgname = bless
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..695a56c582d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer:
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+# Contributor: TDY <tdy@gmx.com>
+# Contributor: dcraven <dcraven@gmail.com>
+
+pkgname=bless
+pkgver=0.6.1
+pkgrel=1
+pkgdesc="High-quality, full-featured hex editor"
+arch=('any')
+url="https://web.archive.org/web/20170503150524/http://home.gna.org/bless/"
+license=('GPL')
+depends=('gtk-sharp-2')
+makedepends=('rarian')
+source=($pkgname-$pkgver.tar.gz::"https://github.com/afrantzis/bless/archive/v0.6.1.tar.gz")
+sha256sums=('5f82e43e22e48080ea8e24668197f79dc8bddfcbf3b5f631dbe17f952e7b0f0e')
+
+prepare() {
+ ./autogen.sh
+}
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" MKDIR_P='mkdir -p' install
+}