summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Haider2020-07-03 10:58:39 +0200
committerThomas Haider2020-07-03 11:04:44 +0200
commit50e9e7b9099439db3a3dda424f7e2f01c3d96bb7 (patch)
treea430cbe1dbf3c68ffbf4b9725ae14146e75624c3
parenta8ecd135c938dda752bb4ff6927d11e38d810dbd (diff)
downloadaur-50e9e7b9099439db3a3dda424f7e2f01c3d96bb7.tar.gz
Modernize PKGBUILD and update dependencies
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--bley.install4
-rw-r--r--bley.sysusers1
-rw-r--r--fix_setup.patch25
5 files changed, 42 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ae26708025e..48a8cbb39a6e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = bley-git
pkgdesc = Intelligent greylisting daemon for postfix and exim
- pkgver = r373.6749631
+ pkgver = r388.30571b1
pkgrel = 1
url = http://bley.mx
- install = bley.install
+ install = bley.sysusers
arch = any
license = BSD
makedepends = git
@@ -11,7 +11,7 @@ pkgbase = bley-git
depends = python-pyspf
depends = python-twisted
depends = python-ipaddress
- depends = python-publicsuffix
+ depends = python-publicsuffix2
optdepends = postfix: mail server (Message Transfer Agent)
optdepends = exim: mail server (Message Transfer Agent)
optdepends = sqlite: required for SQLite support
@@ -21,9 +21,11 @@ pkgbase = bley-git
provides = bley
conflicts = bley
source = bley-git::git+https://github.com/evgeni/bley.git
- source = bley.install
+ source = fix_setup.patch
+ source = bley.sysusers
md5sums = SKIP
- md5sums = ce7ed2174176dfcb0ca2d526f3374e72
+ md5sums = 18f197d7034087e3125751624a8c13c3
+ md5sums = 4c5d548dd75a3b40c8b5b8f5c74f76ef
pkgname = bley-git
diff --git a/PKGBUILD b/PKGBUILD
index 320bc2b63288..51f212b7cff7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Thomas Haider <t.haider@deprecate.de>
pkgname=bley-git
-pkgver=r373.6749631
+pkgver=r388.30571b1
pkgrel=1
pkgdesc="Intelligent greylisting daemon for postfix and exim"
arch=(any)
url="http://bley.mx"
license=('BSD')
-depends=('python-pyspf' 'python-twisted' 'python-ipaddress' 'python-publicsuffix')
+depends=('python-pyspf' 'python-twisted' 'python-ipaddress' 'python-publicsuffix2')
optdepends=('postfix: mail server (Message Transfer Agent)'
'exim: mail server (Message Transfer Agent)'
'sqlite: required for SQLite support'
@@ -16,11 +16,13 @@ optdepends=('postfix: mail server (Message Transfer Agent)'
makedepends=('git' 'python-setuptools')
provides=("bley")
conflicts=("bley")
-install='bley.install'
+install='bley.sysusers'
source=("${pkgname}::git+https://github.com/evgeni/bley.git"
- "bley.install")
+ "fix_setup.patch"
+ "bley.sysusers")
md5sums=('SKIP'
- 'ce7ed2174176dfcb0ca2d526f3374e72')
+ '18f197d7034087e3125751624a8c13c3'
+ '4c5d548dd75a3b40c8b5b8f5c74f76ef')
pkgver() {
cd "$srcdir/${pkgname-git}"
@@ -29,10 +31,12 @@ pkgver() {
build() {
cd "$srcdir/${pkgname-git}"
+ git apply $srcdir/fix_setup.patch
python setup.py build
}
package() {
cd "$srcdir/${pkgname-git}"
python setup.py install --root="${pkgdir}" --prefix="/usr" --optimize=1
+ install -Dm 644 ../bley.sysusers "${pkgdir}"/usr/lib/sysusers.d/bley.conf
}
diff --git a/bley.install b/bley.install
deleted file mode 100644
index 06f8571a63c0..000000000000
--- a/bley.install
+++ /dev/null
@@ -1,4 +0,0 @@
-post_install() {
- getent group bley &>/dev/null || groupadd -r bley >/dev/null
- getent passwd bley &>/dev/null || useradd -r -g bley -d /etc/bley -s /bin/false bley >/dev/null
-}
diff --git a/bley.sysusers b/bley.sysusers
new file mode 100644
index 000000000000..a55cbbd30020
--- /dev/null
+++ b/bley.sysusers
@@ -0,0 +1 @@
+u bley - - /etc/bley
diff --git a/fix_setup.patch b/fix_setup.patch
new file mode 100644
index 000000000000..072963bd1ea5
--- /dev/null
+++ b/fix_setup.patch
@@ -0,0 +1,25 @@
+From 1ced7a71a68bd2da82b5e0031eed2b671c0e8523 Mon Sep 17 00:00:00 2001
+From: Thomas Haider <t.haider@deprecate.de>
+Date: Mon, 20 Mar 2017 08:48:41 +0100
+Subject: [PATCH] fix getoutput call
+
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 0785e68..ba17f5f 100755
+--- a/setup.py
++++ b/setup.py
+@@ -8,7 +8,7 @@ def systemd_unit_path():
+ try:
+ command = ["pkg-config", "--variable=systemdsystemunitdir", "systemd"]
+ try:
+- path = subprocess.getoutput(command)
++ path = subprocess.getoutput(' '.join(command))
+ except AttributeError:
+ path = subprocess.check_output(command, stderr=subprocess.STDOUT)
+ return path.strip()
+--
+2.12.0
+