summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Stalder2020-10-23 23:43:35 +0200
committerNicolas Stalder2020-10-23 23:43:41 +0200
commit9fab96b1f01726ff02fbe346a55f9a9e14210bb0 (patch)
tree50a3064c787998730a7de6315fb08c897a83945f
parentaf2118fcf1fd9e3e43cd3a793b717091685bb28e (diff)
downloadaur-9fab96b1f01726ff02fbe346a55f9a9e14210bb0.tar.gz
:bookmark: blhost 2.6.2-2
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD27
2 files changed, 15 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 768f832ceaa1..d04028d5c79a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = blhost
pkgdesc = Bootloader Host Application for NXP MCUs
pkgver = 2.6.2
- pkgrel = 1
+ pkgrel = 2
url = https://www.nxp.com/design/software/development-software/mcuxpresso-software-and-tools-/mcuboot-mcu-bootloader-for-nxp-microcontrollers:MCUBOOT
arch = x86_64
license = custom:NXP
- source = file://blhost_2.6.2.zip
+ makedepends = nxp-dlagent
+ source = blhost_2.6.2.zip::nxp://blhost_2.6.2
sha256sums = 2e7aa1aa430fbbe01093412f97d618e1773ea40f2f6f24ffcc1e26102d36eb2b
pkgname = blhost
diff --git a/PKGBUILD b/PKGBUILD
index af0deb1c6d9c..f1cd508f8277 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,34 +3,31 @@
# BUILD INSTRUCTIONS
#
# The source for `blhost` is available behind a login wall.
-# Visit <https://www.nxp.com/webapp/Download?colCode=blhost_2.6.2&appType=license>,
-# accept the license terms, and place the downloaded ZIP file in the same directory as this PKGBUILD,
-# then try building again.
+#
+# By default, `nxp-dlagent` is used to fetch, you can avoid the prompts
+# by setting `NXP_USERNAME` and `NXP_PASSWORD` for your account.
+#
+# Alternatively, visit <https://www.nxp.com/webapp/Download?colCode=blhost_2.6.2&appType=license>,
+# accept the license terms, and place the downloaded ZIP file in the same directory as this PKGBUILD.
pkgname=blhost
pkgver=2.6.2
pkgname_pkgver=${pkgname}_$pkgver
-pkgrel=1
+pkgrel=2
pkgdesc="Bootloader Host Application for NXP MCUs"
url="https://www.nxp.com/design/software/development-software/mcuxpresso-software-and-tools-/mcuboot-mcu-bootloader-for-nxp-microcontrollers:MCUBOOT"
# could also support 32-bit with some more work
arch=(x86_64)
license=(custom:NXP)
+makedepends=(nxp-dlagent)
depends=()
-download_url="https://www.nxp.com/webapp/Download?colCode=${pkgname}_${pkgver}&appType=license"
-DLAGENTS=("file::/usr/bin/echo ${BOLD}${RED} Unable to find %u, please download from ${download_url} and read the PKGBUILD ${ALL_OFF}" $DLAGENTS[@])
-source=(
- file://${pkgname}_$pkgver.zip
- # common.mk
-)
-sha256sums=(
- "2e7aa1aa430fbbe01093412f97d618e1773ea40f2f6f24ffcc1e26102d36eb2b"
- # "SKIP"
-)
+DLAGENTS=("nxp::/usr/bin/nxp-dl %u")
+source=("blhost_2.6.2.zip"::"nxp://blhost_2.6.2")
+sha256sums=("2e7aa1aa430fbbe01093412f97d618e1773ea40f2f6f24ffcc1e26102d36eb2b")
# File common.mk seems to be used only to prettify compile output
-# For instance, the ZIP for Downloads/NXP_Kinetis_Bootloader_2_0_0 from the same download page contains a variant
+# See e.g. the version in the ZIP for NXP_Kinetis_Bootloader_2_0_0 from the same download page
prepare() {
makefile=$srcdir/$pkgname_pkgver/proj/blhost/gcc/Makefile