summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonan Pigott2020-02-20 22:46:21 -0700
committerRonan Pigott2020-02-20 22:46:21 -0700
commitefc91d5619c6821891699fcf6c402e6554b61882 (patch)
tree6648fb655e3c1484fb3d6d0f9f0929048a6b1d8a
downloadaur-efc91d5619c6821891699fcf6c402e6554b61882.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e92b43b21a75
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = blight
+ pkgdesc = Basic general backlight utility written in python
+ pkgver = 0.0.3
+ pkgrel = 1
+ url = https://github.com/RPigott/blight
+ arch = any
+ license = custom:ISC
+ depends = python
+ depends = python-gobject
+ source = blight-0.0.3.tar.gz::https://github.com/RPigott/blight/releases/download/v0.0.3/blight-0.0.3.tar.gz
+ source = blight-0.0.3.tar.gz.asc::https://github.com/RPigott/blight/releases/download/v0.0.3/blight-0.0.3.tar.gz.asc
+ validpgpkeys = AE54EAF95DC5D7BB5F1CF422E8E098BBF6E920A0
+ sha256sums = ae96f5fee70f30896c60036a385c9f8aaf6b322cbfd547df62b66d62155e1cfa
+ sha256sums = SKIP
+
+pkgname = blight
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b1a3b49ebe14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Ronan Pigott <rpigott@berkeley.edu>
+
+pkgname=blight
+pkgver=0.0.3
+pkgrel=1
+pkgdesc='Basic general backlight utility written in python'
+url='https://github.com/RPigott/blight'
+arch=('any')
+license=('custom:ISC')
+source=("$pkgname-$pkgver.tar.gz::$url/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
+ "$pkgname-$pkgver.tar.gz.asc::$url/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz.asc")
+depends=('python' 'python-gobject')
+
+sha256sums=('ae96f5fee70f30896c60036a385c9f8aaf6b322cbfd547df62b66d62155e1cfa'
+ 'SKIP')
+validpgpkeys=('AE54EAF95DC5D7BB5F1CF422E8E098BBF6E920A0') # Ronan Pigott <rpigott@berkeley.edu>
+
+package() {
+ install -Dm755 blight.py "$pkgdir/usr/bin/blight"
+ install -Dm644 completion/zsh/_blight "$pkgdir/usr/share/zsh/site-functions/_blight"
+ install -Dm644 completion/bash/blight "$pkgdir/usr/share/bash-completion/completions/blight"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/blight/LICENSE"
+}